Thermal
Solutions
Sauna™ V5.0 Release Notes
Welcome to Version V5.0 of the Sauna thermal modeling package.

Getting started with Sauna V5.0
Please begin by reading “Sauna V5.0 New Features” on the next page.
When you are ready to begin using Sauna V5.0, work through "Sauna V5.0 Tour", which starts on page 6.
This is a brief exercise which takes around 20 minutes to complete.
The Sauna User Manual has been fully updated for V5.0. A PDF version of the manual is available
through the Windows Start Menu.

Installation
To install or update Sauna, see the “Installation” chapter in the Sauna User Manual. The method is the
same as for previous Sauna releases. The software is now distributed on a flash drive.

Sauna is a trademark of Thermal Solutions Inc.
Thermal Solutions Inc., 3135 S. State St., Suite 350C, Ann Arbor MI 48108 www.thermalsoftware.com 734-761-1956

Sauna V5.0 New Features
Circular assemblies are now supported

Figure 1: Circular board with traces and components

Circular and rectangular holes are allowed
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Figure 2: Assemblies with rectangular and circular holes
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Circular assemblies can be sliced to obtain derivative shapes

Sliced at center

Sliced at arbitrary
coordinate

Sliced in X and Y
directions
Sliced annular shape

Figure 3: Sliced circular assemblies

Hole center can be external to assembly

rectangular with round
hole, hole center is
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rectangular with round
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external to assembly

round with offset
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Figure 4: Holes which are external to the assembly
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Combine circular assemblies with other assemblies to quickly create complex
shapes

Figure 5: Complex shape created by combining circular, polygon and rectangular assemblies

Circular assembly
•

easy to create, largely the same procedure as for rectangular assemblies

•

circular assemblies can be sliced to create partial circles, pie shapes, etc.

•

easy to add float resistors, flow length automatically adjusted when the assembly
is sliced or a hole added

Assembly holes
•

rectangular and circular holes are allowed

•

hole can be centered or offset
- polar mesh is used when the hole is large (tube shape)
- the hole center can be outside the assembly

•

easy to resize and reposition holes

•

assembly holes reduce the need to perform slicing and also reduces the number
of assemblies in the model (useful for Sauna Standard users)
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Miscellaneous
•

fixed bug with obtaining node capacitance for a finned plate, impact is generally small (around 0.1°C,
only impacts transient/duty cycle calculations)

•

reference point color has changed to improve visibility

•

option to display numerical wattage for resistors

•

new method for distributed wattage when resizing plates or boards
- wattage / face_area is kept constant
- when plate size changes, the wattage is increased or decreased proportionally

•

new Toolbox calculations for heat transfer from isolated plates
- round and annular plates
- rectangular plate with hole

•

complete Sauna User Manual is available through the Windows Start Menu

Limitations
•

Sauna V5.0 is primarily useful for modeling circular circuit boards

•

modeling cold plates, cans and wires is possible, but is reserved for experienced users

•

circular superassemblies not supported

•

circular traces and pads not allowed

•

fins not allowed for circular plates
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Sauna V5.0 Tour
In the first part of this exercise, you will model the circular circuit board stackup shown in
Figure 6. It's a simple process, as it's very similar to the creation of a rectangular circuit board
stackup. Besides the configuration shown in Figure 6, you will also model the same board with
a hole which cuts through the entire stackup.

board diameter = 100
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3 DPAK devices,
q = 2 watts
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30
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Z
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Figure 6: Round circuit board stackup

The primary benefit of Sauna V5.0 is the modeling of circular boards. More things are possible,
but it's generally reserved for experienced users. An example of the advanced capabilities is
shown in "Modeling heat loss through a wire" which follows the board exercise.

Creating the board and slicing
Begin creating the circular board with:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Circuit Brd ➔ hit <Enter> to skip ➔ Round
➔ Vertical XY ➔ "100" ➔ .062"/1.57mm

As shown on the next page, you will reach the Circ Origin menu:
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CIRC ORIGIN
Coords/Trap
Digitize
Midpoint
Ref/Dx
Ref/Dy
Ref/Dz
Ref/Dx-Dy-Dz
Ref/Options

For a circular assembly in the XY plane, the origin point is the center of the circle on the front
face. You will be using "0,0,0" (you only need to enter "0") as the center of the circle, so continue
with:
Coords/Trap ➔ "0" ➔ FR4 ➔ Zer/Lam Only ➔ .025"/0.64mm ➔ One oz. ➔ None

The laminate assembly will be created. Note that there is a reference point at a the center of the
assembly. (For improved visibility, reference points now have a reddish/brown color.)
Slice the board at Y = -30:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Line Slice ➔ Y-Coord ➔ Enter Value
➔ "-30" ➔ All In Wind ➔ USE

The slice will be completed, creating lower and upper board assemblies. Delete the lower board
assembly:
<F12 Root Menu> ➔ Delete ➔ Assembly ➔ Board ➔ Select 1 ➔ trap lower board ➔ USE
<F1 Window> ➔ Refresh

Adding components pads
As shown in Figure 6, the three DPAK components are mounted on a common 60 mm x 30 mm
pad. To achieve this, you will start with "Same As Body" pads for each of the DPAK's. Then
you will delete the left and right pads and enlarge the center pad to 60 x 30.
Add pads for the center DPAK:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ trap board ➔ Component
➔ One oz. ➔ Pad Library ➔ DPAK's ➔ DPAK ➔ 2 ➔ Same As Body ➔ 25 mm/1.0"
➔ 0.50mm/20mil ➔ No ➔ 0 Degrees ➔ Coords/Trap ➔ "0,10"

The center DPAK pads will be created. Now create the left and right DPAK pads:
DPAK ➔ 2 ➔ Same As Body ➔ 25 mm/1.0" ➔ 0.50mm/20mil ➔ No ➔ 0 Degrees
➔ Coords/Trap ➔ "-15,10"
DPAK ➔ 2 ➔ Same As Body ➔ 25 mm/1.0" ➔ 0.50mm/20mil ➔ No ➔ 0 Degrees
➔ Coords/Trap ➔ "15,10"

Now there are pads for all three DPAK’s.
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Next, you need to combine the three heat slug pads into a large 60 x 30 pad. Instead of creating
additional pads, you will simply delete the left and right slug pads, then enlarge the center pad.
Delete the left and right slug pads:
<F12 Root Menu> ➔ Delete ➔ Assembly ➔ Plate ➔ Select 1 ➔ trap left slug pad ➔ Select 1
➔ trap right slug pad ➔ USE

The two pads will be deleted. Note that the reference points are still present, so you will be able
to place the heat sources at the appropriate locations.
Enlarge the center pad:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Dimensions ➔ Modify X ➔ Enter Dimen ➔ "60"
➔ Center ➔ Select 1 ➔ trap center slug pad ➔ USE
Modify Y ➔ Enter Dimen ➔ "30" ➔ Origin ➔ Select 1 ➔ trap center slug pad ➔ USE

The pad will now be 60 x 30.

Completing the model and calculating temperatures
Working from left to right, add the 2W sources:
<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ DPAK's ➔ "2" ➔ "S1" ➔ DPAK ➔ 2
➔ Typical ➔ Typ-1500 C/W ➔ Ref Point ➔ trap left reference point
DPAK's ➔ "2" ➔ "S2" ➔ DPAK ➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point
➔ trap center reference point
DPAK's ➔ "2" ➔ "S3" ➔ DPAK ➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point
➔ trap right reference point

The three heat sources will be added. The center DPAK will be the hottest, so align the mesh to
this heat source:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ trap center heat source ➔ All In Wind ➔ USE

The mesh will be aligned. Now add float resistors and calculate temperatures:
<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Both Sides ➔ All In Wind ➔ USE
click
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the temperature calculation is complete, you should obtain Tjunct-center = 158.54°C and
Tjunct-left/right = 145.63°C.
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It is a simple matter to convert from a single layer board to a four layer board. The procedure is
the same as always:
click
<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Stackup ➔ Board ➔ Intern Layer ➔ Two
➔ Uniform ➔ One oz. ➔ Typical ➔ All In Wind ➔ USE

The internal layers will be created. Add float resistors and calculate temperatures:
<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd➔Fix ➔ "Room Amb" ➔ Natural ➔ Both Sides
➔ All In Wind ➔ USE
click
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

With the internal planes, there is a significant drop in temperature. You should obtain
Tjunct-ctr = 98.91°C and Tjunct-lft/rgh = 90.76°C.
You won't be adding vias in this exercise, but the procedure is the same as for rectangular
assemblies.

Adding a hole to the stackup
Now you will add the 20 x 10 rectangular slot shown in Figure 7:

20 x 10 hole, centered at (0,25)

Y

Z

X

Figure 7: Board stackup with hole
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Begin by deleting fixed nodes:
click
<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

It's easy to create the hole:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Add/Rem Hole ➔ Add Rect ➔ "20,10"
➔ Specify Pt ➔ Coords/Trap ➔ "0,25" ➔ Vertical XY ➔ Select Regn
➔ use grouping rectangle from Figure 8 ➔ USE

grouping rectangle

Y
X

Figure 8: Grouping rectangle for adding rectangular hole

The rectangular slot will be added. It's an easy thing to do.
Add float resistors and calculate temperatures:
<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd➔Fix ➔ "Room Amb" ➔ Natural ➔ Both Sides
➔ All In Wind ➔ USE
click
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the temperature calculation is complete, you should see that T junct-ctr increases to
104.40°C, roughly 5°C hotter.
Activate temperature contours:
click
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When the temperature contours are displayed, you can clearly see how the slot blocks the
spreading of heat within the board.
Delete the current model:
<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

Heat loss through a wire
As stated earlier, Sauna V5.00 is primarily useful for modeling circular circuit boards.
However, there are many more possibilities, provided that you are an experienced user and
have some patience. The modeling of wires, as shown in Figure 9, is one of the areas that
require an advanced skill level. Please note that Sauna V5.1 will make this modeling task
significantly easier.
18 ga copper wire (1 mm dia),
PVC insulation, 2 mm dia

25 mm

Y

Z

X

T = 60˚C at base

Figure 9: Modeling heat loss through a thick wire, base held at 60°C

Creating the first two assemblies
In Sauna V5.0, all assemblies are one node thick. To model the wire in Figure 9, you will create
10 assemblies and join them together. And, even though this is a vertical wire, you will actually
be modeling with horizontal round plates.
As a first step, you will create a round PVC assembly (2 mm dia, 5 mm thick) in the horizontal
plane. Be sure to use the label "insul>1". Enter:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Plate ➔ "insul>1" ➔ Round ➔ Horizontal ➔ "2,5"
➔ Coords/Trap ➔ "0" ➔ Plastic ➔ Rigid PVC
Top

click
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The plate will be created and the window will be as shown in Figure 10:

X
Z

Figure 10: round assembly with 9 nodes

The plate will contain 9 nodes, which probably seems a bit odd. With Sauna V5.00, a round
plate will contain a minimum of 9 nodes. Since the default node spacing for plates is 12 mm,
much larger than the plate diameter, Sauna is using the minimum mesh of 9 nodes. The mesh
will probably make more sense is you activate the outlining of nodes:
<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Plt/Brd Node

With outlines visible, you can clearly see that there is a large square node at the center of the
round plate, with 8 outer nodes.
Turn off outlines and switch to a perspective view:
Turn Off
click

In the perspective view, you can clearly see that you have created a thick round disk.
Now return to a top view and add a 1 mm hole:
Top

click

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Add/Rem Hole ➔ Add Round
➔ "1" ➔ Assy Center ➔ Horizontal ➔ All In Wind ➔ USE

The hole will be added. Also, Sauna switches to a polar mesh. Sauna uses a polar mesh
whenever a round assembly has a round hole with an inner diameter which is 50% or more of
the outer diameter (ID >= 0.5 OD).
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Now you are ready to create the assembly which represents the actual copper wire. Create the
assembly with a label of "wire>1":
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Plate ➔ "wire>1" ➔ Round ➔ Horizontal ➔ "1,5"
➔ Coords/Trap ➔ trap reference point ➔ Copper ➔ Pure ➔ Emis=0.1

The round copper assembly will be created. Once again you will be using the minimum mesh
of 9 nodes. Join the assemblies together:
<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Zero Resis ➔ Group 2 Assy ➔ All In Wind ➔ USE

The assemblies will be joined together. Get an assembly list report:
<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

You should see that there is an "insul>1" and "wire>1" assembly. If you forgot to use these
labels, please correct this issue before continuing.
Clear the report before continuing.

Completing the stackup
Copy assemblies:
Front

click

<F12 Root Menu> ➔ Move/Copy ➔ Copy ➔ Four ➔ Assembly ➔ Plate
➔ All In Wind ➔ USE ➔ Dy ➔ "5"
click

The copies will be created. Get an assembly list report:
<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

Because you started with "wire>1" and "insul>1", you now have nicely organized labels, with
"wire>5" and "insul>5" at the top of the stackup.
Clear the report and create stack joins:
<F12 Root Menu> ➔ Model ➔ Join ➔ Stack ➔ Ordinary ➔ Strict ➔ Zero Resis
➔ Grp To Grp ➔ All In Wind ➔ USE

Sauna should indicate that 8 joins were created.

Applying the boundary temperature
Start by isolating the wire assembly at the bottom of the stackup:
<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only ➔ Plate
➔ Select 1 ➔ "wire>1" ➔ USE
click
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Create a thin surface assembly with the label "wire>0":
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Surface ➔ Neg Y ➔ Plate ➔ Thin (.05mm)
➔ Enter Label ➔ "wire>0" ➔ Auto ➔ Same ➔ All In Wind ➔ USE

The surface assembly will be created. Next, create a fixed node below the surface assembly.
<F12 Root Menu> ➔ Model ➔ Node ➔ Fixed Temp ➔ "base" ➔ Enter Now ➔ "60"
➔ One ➔ Coords/Trap ➔ "0,-1,0"
click

You need to “short” the surface assembly to the fixed node. You will do this by creating generic
resistors with a small resistance value:
<F12 Root Menu> ➔ Model ➔ Resistor ➔ Constant ➔ Generic ➔ Plt/Bd->1 ➔ Distribute
➔ ".001" ➔ Select 1 ➔ "wire>0" ➔ USE ➔ trap “base” fixed node

9 generic resistors will be created. To make it easy to monitor temperature, add a label to the
center node of "wire>0":
click
<F12 Root Menu> ➔ Edit ➔ Node ➔ Labels ➔ Trap 1 Node ➔ Any Node
➔ trap center node of “wire>0” ➔ type "lower" in text box ➔ click OK button

The label will be added.

Adding float resistors and completing the model
All of the assemblies, other than "wire>0", are very thick. This means that most of the
dissipating surface area is on the edges. So you need to be sure that all of the edge area is
properly utilized.
To simply the addition of float resistors, assign all of the edge area to the component (top) side:
click

➔ click

Front

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Area Params ➔ Edge Area ➔ 100% Comp
➔ All In Wind ➔ USE

With this change, you only need to add float resistors on the component side. Now create the
float resistors:
<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Component ➔ Select Regn ➔ select all assemblies except "copp>0" ➔ USE

Sauna should indicate that 6 fixed temperature nodes and 89 float resistors were created. The
fixed nodes were place right in the center of the stackup. This makes perfect sense for a thin
plate, but is obviously not the best position for this type of stackup.
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This a vertical structure, so you should be using a flow length of 25 mm:
<F12 Root Menu> ➔ Edit ➔ Resistor ➔ Float ➔ Isoltd->Fix ➔ Flow Length ➔ Horiz Assy
➔ Enter ➔ "25" ➔ All In Wind ➔ USE

Sauna should indicate that 89 resistors were modified.
Finally, it's nice to monitor a node at the top of the stackup. Add a node label to the node at the
center of "wire>5":
<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only ➔ Plate
➔ Select 1 ➔ “wire>5” ➔ USE
Top

click

<F12 Root Menu> ➔ Edit ➔ Node ➔ Labels ➔ Trap 1 Node ➔ Any Node ➔ trap center node
➔ type "top" in text box ➔ click OK button

Turn on all assemblies, but keep fixed nodes turned off:
click

➔ click

Front

Calculating temperatures and discussing results
Calculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the temperature calculation is complete, you should obtain Ttop = 57.58°C.
Change the view as follows, then activate shade mode:
click

➔ click

➔ click

click

click

The contour view is not impressive. While you can see contours at the top of the stackup, there
is nothing for the side surfaces (as always with Sauna). This is an obvious shortcoming and will
be corrected in Sauna V5.1.
It's very interesting to learn how much wattage is dissipated through the wire stackup. First,
modify the view as follows:
click

➔ click

Front

<F3 Zoom In> ➔ zoom in on base fixed node

To obtain wattage, get an Info report for the base fixed node:
<F7 Info> ➔ Trap ➔ Node ➔ Fixed ➔ trap base fixed node
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The report will indicate that there is dissipation of -0.06 watts (leaving the node). This probably
doesn't seem like much. But you need to remember that the wire is only one inch (25 mm) tall,
and the end of the wire is still quite warm. With a 10” (250 mm) wire, you could lose around
0.5 watts, which is significant. Wires, particularly thick wires, do impact the cooling of a circuit
board.
The exercise is complete. You can delete the model:
<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button
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