Thermal
Solutions
Sauna™ V5.05 Release Notes
Welcome to Version V5.05 of the Sauna thermal modeling package.

Getting started with Sauna V5.05
Please begin by reading “Sauna V5.05 New Features List” on the next page.
When you are ready to begin using Sauna V5.05, work through "Sauna V5.05 Tour", which starts on
page 4. This is a brief exercise which takes around 15 minutes to complete.

Who should install Sauna V5.05?
As described in “Sauna V5.05 New Features List” on the next page, there are a number of enhancements
which are useful for circuit board modeling. Also, as shown on page 3, Sauna V5.05 fixes a significant
bug in Sauna V5.00 which impacts the modeling of naturally cooled heat sinks with a horizontal
backplane. It is recommended that all users install Sauna V5.05.

Installation
To install or update Sauna, see the “Installation” chapter in the Sauna User Manual. The method is the
same as for previous Sauna releases. You can use the same installation password as for Sauna V5.00.

Sauna is a trademark of Thermal Solutions Inc.
Thermal Solutions Inc., 3135 S. State St., Suite 350C, Ann Arbor MI 48108 www.thermalsoftware.com 734-761-1956

Sauna V5.05 New Features List
Easier to work with boards that have more than 4 copper layers
•

new menus provide additional layer names

•

frequently used combination of "Copp>1" and "Lamin>1" is now a menu selection

Easier to work with models which have two or more board stackups
•

numerous refinements for creating and editing models with multiple stackups

•

easy to switch between the different board stackups when making modifications

•

Sauna now directly supports the use of "Bd1:", "Bd2:", etc. to identify board stackups

Directional copper conductivity
•

copper traces frequently have directional characteristics

•

Sauna V5.05 allows the specification of an "East/West" and "North/South" copper coverage

•

Matlab can be used to convert a complex layout into a much simpler Sauna layout with
directional conductivity

New "pad to pad" interface type for edge joins
•

when pads are separated by small gaps (typically less than 0.2 mm/0.008"), the "across gap"
heat conduction through the FR4 and solder mask can impact temperatures (see Figure 1 on
next page)

•

Sauna can use either the actual physical gap or a user-specified gap

•

user-specified gap is useful for what-if studies

•

see the Sauna V5.05 Tour to see the impact for a single layer board and multilayer board
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small gap, typically
less than 0.2 mm/0.008"

Figure 1: Configuration for "pad to pad" heat transfer

Important bug fix for naturally cooled horizontal sink
•

Sauna V5.00 has a bug for naturally cooled horizontal backplane heat sinks (see Figure 2)

•

if this bug will impact you, be sure to install Sauna V5.05

small distance (~0.1 mm/0.004") between
end fin and limit of backplane, model
will not calculate

horizontal, naturally cooled heat sink
Y
X

Figure 2: Horizontal heat sink bug
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Sauna V5.05 Tour
For this portion of the Sauna V5.05 Tour, you will need the model qfp_dpak.smf, which is
located in the Reference Models folder. Load the model now:
<F12 Root Menu> ➔ File ➔ Open
➔ navigate to C:\Program File (x86)\Sauna Thermal Modeling\Reference Models
➔ select qfp_dpak ➔ click Open button

Easier to work with boards that have more than 4 copper layers
With Sauna V5.05, the Layer menu has been split up to make it easier to work with boards that
have more than 4 layers. To illustrate, begin with:
<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer

You will reach the new version of the Layer menu:

1
2
3
4
5
6
7
8

LAYER
Copp>1
Copp>2
Copp>3+
Lamin>1
Lamin>2+
Copp/Lamin>1
Enter Prefix
Mult Stackup

In the previous version of Sauna, you had "Copp>1" through "Copp>4" on this menu, as well as
"Lamin>1" through "Lamin>3". But if your board had more than 4 copper layers, you were
forced to use "Enter Prefix" and type in the entire layer name. This was a nuisance. Now, you
have additional choices available through "Copp>3+" and "Lamin>2+".
Try this:
Copp>3+

You will reach the Copp>3+ menu:

1
2
3
4
5
6
7
8

COPP>3+
Copp>3
Copp>4
Copp>5
Copp>6
Copp>7
Copp>8
Copp>9
Copp>n

With this menu you have easy access to “Copp>3” to “Copp>9”. If you have more layers, you
can use "Copp>n".
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With "Copp>n", you only have to enter the number of the layer. To demonstrate, you can
isolate "Copp>1" with
Copp>n ➔ "1"

Just the front layer will be visible. Return to the previous menu:
<F2 Backup>

Notice that the 6th selection is "Copp/Lamin>1". This choice makes it easy to isolate both
"Copp>1" and "Lamin>1", which is a very useful combination when modeling. Continue with:
Copp/Lamin>1

The front copper and front laminate layers will be isolated. This is just what you need when
editing vias.

Models with more than one board stackup
When your model has more than one board stackup, you will need to pay attention to stackup
prefixes ("Bd1:", "Bd2:", etc.). For the first board stackup in the model, just create the board
layers as directed in Introductory Exercise 5: Basics Of Circuit Board Modeling.
When the first stackup is more or less complete, you should add the "Bd1:" prefix. This is easy
to do with Edit ➔ Plate/Board ➔ Label/Color ➔ Add Prefix.
Let's see how this would work. Turn on all layers of the qfp_dpak model:
click

Add the "Bd1:" prefix:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Label/Color ➔ Add Prefix ➔ Plate/Board
➔ All In Wind ➔ USE ➔ type in "Bd1:" (no quotes) ➔ click OK button

Sauna should indicate "modified 57 assembly labels to use "Bd1:" prefix". Check the board
stackup report:
<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

The report will show "Bd1:Copp>1" through "Bd1:Copp>3" and "Bd1:Lamin>1" through
"Bd1:Lamin>3".
It's easy to turn off the entire stackup. After clearing the report, enter:
<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Layer ➔ Mult Stackup ➔ Bd1:

The entire stackup will be turned off. Now make the front copper layer visible:
<F12 Root Menu> ➔ Visibility ➔ Turn On ➔ Layer ➔ Mult Stackup ➔ Bd1:Copp>n ➔ "1"

The front layer will be turned on.
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Creating the second board stackup in the model
Now you are ready to create a second stackup to the right of the first stackup. You can use the
same method as you have always used:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Circuit Brd ➔ hit <Enter> to skip ➔ Rectangle
➔ Vertical XY ➔ "60,60" ➔ .062"/1.57mm ➔ Coords/Trap ➔ "90,0" ➔ FR4
➔ Zer/Lam Only ➔ .025"/0.64mm ➔ One oz. ➔ None

The laminate assembly will be created just to the right of the first stackup. Next, add a
rectangular pad to the new stackup:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ trap right board
➔ Component ➔ One oz. ➔ Pad/Rect ➔ Coords/Trap ➔ "100,10" ➔ Dx-Dy-Dz ➔ "40,40"

A large pad will be created at the center of the second stackup. Now is a good time to check the
board stackup report:
<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

The report shows that Sauna is using the layers "Copp>1" and "Lamin>1" for the new stackup.
This is convenient because you can easily turn layers on and off using the options on the Layer
menu, just as you have always done.
Earlier, you saw it was easy to turn on or off the entire "Bd1:" stackup. You can do something
similar with the new stackup by using the "No Prefix" menu choice. After clearing the report,
isolate the second stackup with:
<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Mult Stackup ➔ No Prefix

Just the new stackup will be visible. When creating a new stackup, or making extensive
changes to an existing stackup, it's easier if the stackup does not have a prefix. You should wait
until the stackup is more or less complete before adding a prefix.

Creating a copy of an entire board stackup
Begin by deleting the second stackup:
<F12 Root Menu> ➔ Delete ➔ Assembly ➔ Plate/Board ➔ All In Wind ➔ USE

Turn on the "Bd1:" stackup:
click

Now copy the stackup:
<F12 Root Menu> ➔ Move/Copy ➔ Copy ➔ One ➔ Assembly ➔ Plate/Board ➔ All In Wind ➔ USE
➔ Dx ➔ "90" ➔ click Yes to increment the prefix

A copy of the stackup will be created.
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Check the board stackup report:
<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

The report will show that there are now "Bd1:" and "Bd2:" stackups, so the model is nicely
organized. However, if you need to make a series of modifications to the second stackup, it's
actually easier if the "Bd2:" prefix is removed. After clearing the report, remove the “Bd2:”
prefix:
click
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Label/Color ➔ Edit Prefix ➔ Plate/Board
➔ All In Wind ➔ USE ➔ type in "Bd2:" (no quotes) for old prefix ➔ click OK button

Sauna will indicate "modified 57 assemblies labels to use "" prefix". So the "Bd2:" prefix has
been removed. Verify this with:
<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Mult Stackup ➔ No Prefix

Just the right stackup will be visible. Isolate the "Copp>1" and "Lamin>1" layers for the right
stackup:
<F2 Backup>
Copp/Lamin>1
click

Directional copper coverage
Sauna V5.05 provides directional copper coverage. To illustrate, create a 25 x 25 pad at the
lower left of the board:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad ➔ trap a trace or pad
➔ Pad/Rect ➔ Coords/Trap ➔ "95,5" ➔ Dx-Dy-Dz ➔ "25,25"

The pad will be created. Next, activate copper coverage display:
<F6 Setup> ➔ Display ➔ Node ➔ Cu Coverage ➔ On

The screen will show 100% copper coverage for the newly created pad. Now suppose that the
pad actually represents a series of evenly spaced X-direction copper traces. It is also assumed
that the gap between traces is the same as the trace width. For this situation, it would make
sense to use 50% for the X-direction copper coverage and 0% for the Y-direction copper
coverage. With Sauna V5.05, this is easy to do. Begin with:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ Trace/Pad ➔ Coverage
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You will reach the new Coverage menu:
COVERAGE
>1 Both Direc
2 East/West
3 North/South

The "East/West" and "North/South" notation makes sense when viewing the board in a
window which is in the same plane as the board. Since you are viewing an XY board in a front
orthogonal window, you want the east/west coverage to be 50%. Make the change with:
East/West ➔ 50% ➔ Entire Assy ➔ Select 1 ➔ trap 25 x 25 pad ➔ USE

Sauna will indicate that "copper coverage modified for 1 trace/pad". To better see the copper
coverage, zoom in on the upper-left corner of the pad (see Figure 3):
<F4 Zoom In> ➔ zoom rectangle to select upper-left quadrant of 25 x 25 pad
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Figure 3: Model after zooming in

In a zoomed-in view, you can see that Sauna shows "50/100" for the copper coverage, which
indicates 50% coverage in the east/west direction and 100% for the north/south direction.
Complete the modification with:
North/South ➔ 0% ➔ Entire Assy ➔ Select 1 ➔ trap 25 x 25 pad ➔ USE

Now the copper coverage is "50/0". To see resistance values, isolate "Copp>1" and turn on
resistor values:
<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Copp>1
<F6 Setup> ➔ Display ➔ Resistor ➔ Numeric Rth ➔ On

8

With resistor values visible, you will see that the X-direction (east/west) resistance is much less
than the Y-direction (north/south) resistance, as expected.
Before starting the next section, restore the default display setup and delete the current model:
<F6 Setup> ➔ Display ➔ Use Default
<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

Pad to pad joins, creating the basic model
Now you will create the model shown in Figure 4:

45 x 30 pad

80

0.2 mm/0.008"
15 x 15 DPAK
slug pad

DPAK, 1 watt

Y

80
X

Figure 4: Model for exploring pad to pad joins

Begin by creating an 80 x 80 vertical board:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Circuit Brd ➔ hit <Enter> to skip ➔ Rectangle
➔ Vertical XY ➔ "80,80" ➔ .062"/1.57mm ➔ (0,0,0) ➔ FR4 ➔ Zer/Lam Only
➔ .025"/0.64mm ➔ One oz. ➔ None

The board will be created. Next, add pads for the DPAK device:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ trap board ➔ Component
➔ One oz. ➔ Pad Library ➔ DPAK's ➔ DPAK ➔ 2 ➔ 15 x 15 ➔ 15 mm/0.6" ➔ 0.50mm/20mil
➔ No ➔ 0 Degrees ➔ Coords/Trap ➔ "40,30"

The pads will be created.
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Now create the 45 x 30 pad above the heat source:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad ➔ trap any trace or pad
➔ Pad/Rect ➔ Ref/Dx-Dy-Dz ➔ trap top-left corner of 15 x 15 pad
➔ "-15,.2" ➔ Dx-Dy-Dz ➔ "45,30"

The large pad will be created. Add the heat source with 1W of dissipation:
<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ DPAK's ➔ "1" ➔ "S1" ➔ DPAK
➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point ➔ trap reference point

Align the board and pads to the heat source:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ trap heat source ➔ All In Wind ➔ USE

The board will be realigned.
Add float resistors and calculate temperatures:
<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Both Sides ➔ All In Wind ➔ USE
click
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain Tjunction = 106.51°C.

Creating a pad to pad join, one copper layer
Begin with:
<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Pad To Pad

You will reach the Gap Type menu:
GAP TYPE
>1 Physical
2 Specify

Sauna lets you choose between using the physical (actual) gap between pads (in this case 0.2
mm), or specifying a gap of your own choosing. You want the actual gap, so choose:
Physical

Now you will reach the Multiplier menu:
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MULTIPLIER
x2
x1
x3
Enter

>1
2
3
4

To obtain a conduction resistance, a cross-sectional area is needed (Rcond = ∆x/kA). The
simplest method is to calculate the conduction area using the thickness of the copper pad.
However, testing has shown that this is too conservative, as conduction takes place within a
broader cross-section of the laminate. To compensate for this effect, the conduction area can be
increased with a multiplier (which in turn reduces the interface resistance). Detailed simulations
have shown that it is appropriate to multiply the conduction area by a factor of 2 or 3. The
default multiplier value is 2 and you will be using this value. Finish with:
x2 ➔ Group 2 Assy ➔ Select Regn ➔ select two large pads ➔ USE
It won't work. The default setup for Sauna does not allow for gaps. So you need to change the
modeling setup first:
<F6 Setup> ➔ Modeling ➔ Join Gap ➔ 0.2mm/8 mil

Sauna will indicate that "maximum gap for new edge joins = 0.20". Now you can create the join:
<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Pad To Pad ➔ Physical ➔ x2 ➔ Group 2 Assy
➔ Select Regn ➔ select two large pads ➔ USE ➔ click Yes button to confirm join

This time the join will be allowed. Calculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain Tjunction = 102.71°C. The temperature has been reduced by 3.8°C, or 4.7%. So
for this model, there is appreciable heat transfer across the gap between pads. Please note that
the current board is a limit case because there is only one copper layer and the pads are
positioned in a way which maximizes the "across gap" heat transfer. Nonetheless, it can be
concluded that the effect is significant for certain boards.

Editing pad to pad joins, single layer board
Let's try using an even smaller gap of 0.1 mm (0.004”). You can perform this what-if without
actually moving the pad. You only need to edit the join interface:
<F12 Root Menu> ➔ Edit ➔ Join Intrfc ➔ Edge ➔ Pad To Pad ➔ Specify ➔ ".1" ➔ x2
➔ Group 2 Assy ➔ Select Regn ➔ select two large pads ➔ USE

The join interface will be modified. Calculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain Tjunction = 100.04°C, a further reduction of 2.7°C. While it's not clear that this
gap would be acceptable with your company's design rules, it does help to reduce
temperatures.
In the next section, you will see how pad to pad joins impact a multilayer board.
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Creating pad to pad joins, multilayer board
You will be adding internal layers to the current board. Then you will make a comparison
between the “no join” and “pad to pad join” cases.
Begin by deleting the join between the two large pads:
<F12 Root Menu> ➔ Delete ➔ Join ➔ Edge ➔ Group 2 Assy ➔ Trace/Pad ➔ Select Regn
➔ select two large pads ➔ USE

Now calculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain Tjunction = 106.51°C, the same temperature as before.
You will need to delete fixed nodes before subdividing:
click
<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

Subdivide the board:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Stackup ➔ Board ➔ Intern Layer
➔ Two ➔ Uniform ➔ One oz. ➔ Typical ➔ All In Wind ➔ USE

The internal layers will be created. Isolate the front copper layer and front laminate layer:
<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Copp/Lamin>1

Turn on via density and edit the vias directly under the DPAK:
<F6 Setup> ➔ Display ➔ Node ➔ Via Density ➔ Vias/In2
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Board Props ➔ Vias ➔ Density ➔ High (100)
➔ Node Group ➔ Select Regn ➔ grouping rectangle matches DPAK outline ➔ USE

Sauna should indicate that “via density modified for 4 nodes”. Now restore the default display
setup:
<F6 Setup> ➔ Display ➔ Use Default

Add float resistors and calculate temperatures:
<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Both Sides ➔ All In Wind ➔ USE
click
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain Tjunction = 53.37°C, significantly cooler than for the single layer board.
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Now add a pad to pad join between the two large pads:
<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Pad To Pad ➔ Physical ➔ x2 ➔ Group 2 Assy
➔ Select Regn ➔ select two large pads ➔ USE ➔ click Yes button to confirm join

Recalculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain Tjunction = 53.31°C. This is a reduction of 0.06°C, or 0.2%. So the impact is
significantly smaller for a multilayer board.
As you did earlier, edit the join gap to be 0.1 mm (0.004):
<F12 Root Menu> ➔ Edit ➔ Join Intrfc ➔ Edge ➔ Pad To Pad ➔ Specify ➔ ".1" ➔ x2
➔ Group 2 Assy ➔ Select Regn ➔ select two large pads ➔ USE

You can verify that the gap was changed by getting a report for one of the pads:
<F7 Info> ➔ Trap ➔ Plate ➔ trap one of the large pads

On the last page of the report, you should see that the edge join interface type is
“pad-pad,.10 gap”.
Clear the report and calculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

With the smaller gap, Tjunction is reduced to 53.26°C. This brings the overall reduction to 0.11°C,
or 0.4%. Even with the smaller gap, the improvement is limited.
To conclude, the gap to gap join is primarily useful for single layer boards. It could also become
a factor for multilayer boards if ground planes do not extend under heat sources or if there are
no vias to conduct heat between layers.
The Sauna V5.05 Tour is now complete. Delete the model:
<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button
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