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    Supplemental Exercise 1: Transient And Duty Cycle Analysis

Is this exercise for you?

This exercise gives a complete discussion of transient and duty cycle analysis.

Some users should skip this exercise.  Sauna Standard users will not be able to perform any of
the calculations, as the Sauna Modeling System is required for transient and duty cycle analysis.
However, you can work this exercise with the Sauna Evaluation Program.

If you are only interested in steady state calculations, there is no need to work through this
exercise.

Finally, if you only need to perform simple transient calculations, this type of calculation was
introduced in Introductory Exercise 1: A Simple Finned Heat Sink.  It isn’t obligatory to work this
exercise, although you will benefit from the more complete description of transient analysis
methods.

Prerequisites

You should work through all of the introductory exercises and Intermediate Exercise 1:
Superassemblies And Basic Slicing prior to attempting this exercise.

Massless junction assumption

For most of this exercise, you will work with the model shown in Figure 4-1 on the next page.
This is the model that you created in the first introductory exercise.

The TO-247 heat source in Figure 4-1 is modeled with a basic heat source.  With a basic heat
source the junction is always assumed to be massless (thermal capacitance = 0.0).  This is an
excellent assumption when the analysis lasts longer than a few seconds.  For most of the
exercise, you will be modeling problems that extend for minutes, so there is no concern with the
massless junction assumption.

However, there are certainly many transient and duty cycle problems where the pulses last for
milliseconds, or less.  And Sauna can handle these millisecond-scale problems, provided you are
working with an enhanced source or a detailed component stackup.  This subject is explored in
the section "Junction with mass on a board stackup".

Preparing for the first transient calculation

The Figure 4-1 model should have been saved as “new_sink.smf” on your hard disk.  The
model can also be found in the “C:\Program Files (x86)\Sauna Thermal Modeling\Reference
Models”folder.  Load the model now:

<F12 Root Menu> ➔ File ➔ Open ➔ select new_sink.smf ➔ click Open button

Turn off fixed nodes:

click  
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Figure 4-1: Heat sink from first exercise

To make it easier to track temperatures, add two node labels as shown in Figure 4-2:

<F12 Root Menu> ➔  Edit ➔  Node ➔  Labels ➔  Trap 1 Node ➔  Any Node
➔ trap left-sink node ➔  type “left-sink” in text box ➔ click OK button

Any Node ➔ trap mid-sink node (X-coord = 100) ➔  type “mid-sink” in text box ➔ click OK button

After adding the label, make sure that Tleft-sink = 84.66°C and Tmid-sink 69.65°C.

left-sink

84.66

S1

112.98
136.98

mid-sink

69.65

 add node label
(X-coord = 100)

add node label
X

Y

Steady State

Figure 4-2: Adding node labels
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A simple transient analysis

Now you will perform a simple “warmup” transient analysis of the heat sink.  Initially the heat
sink will be at room temperature.  The analysis will cover the first 30 minutes after the tran-
sistor has been turned on.  Begin with:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps

You will reach a familiar menu:

  CALC TEMPS
>1 Steady
 2 Transient
 3 Duty Cycle

Up until now, you have primarily used “Steady”.  “Steady” provides steady state (fully
warmed up) temperatures for your model.  If you are interested in temperatures when a unit is
first turned on, you need to click on the second menu selection “Transient”.  The final menu
selection, “Duty Cycle”, will cause Sauna to perform a duty cycle temperature calculation.
With a duty cycle calculation, heat sources can be turned on/off during the course of an
analysis.  Duty cycle calculations can also handle time-varying fixed nodes.  This is a very
important capability which is discussed later in the exercise.

For now, you will be doing a simple transient analysis, so enter:

Transient

You will reach the Solver Type menu:

  SOLVER TYPE
>1 Optimized
 2 Explicit
 3 Implicit
 4 Quick Calc

Sauna provides several different solution methods.  If you choose “Optimized”, Sauna will
choose a solution method for you (optimized on the basis of minimum calculation time).
“Optimized” is normally the best choice.  Continue with:

Optimized ➔ Minutes  ➔ “30”

This brings up the Float Steps menu:

  FLOAT STEPS
>1 60
 2 20
 3 100
 4 200
 5 600
 6 1000
 7 1800
 8 Enter Steps

This menu controls two parameters: (1) how frequently float resistors are recalculated and
(2) how often Sauna saves temperatures.  To explain the first parameter, consider that model
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temperatures can vary quite significantly during the course of a transient analysis.  Since
model temperatures change, it becomes necessary to recalculate temperature-dependent float
resistors.  If you choose “60”, Sauna will use 60 float steps, meaning that float resistors will be
recalculated 60 times (every 30 seconds for a 30 minute analysis).

This brings up the 2nd parameter.  At every float step, Sauna saves a complete set of model
temperatures in the result file.  These are the only temperatures that Sauna saves.  If you want
to be able to plot an attractive curve of temperature vs. time, it’s a good idea to use 60 float
steps.  You might achieve good accuracy with just 10 float steps, but there won’t be many data
points to graph.

Continue with:

60

You will reach the Result File menu:

  RESULT FILE
>1 Default
 2 Specify

If you choose "Default", Sauna will write the temperature results in a text file with the name
"new_sink.srf" (assuming that the model name is “new_sink.smf”).  The file extension, "srf",
comes from Sauna result file.  Note that the result file is an ordinary text file which can be
viewed with any word processor.

Continue with:

Default

You will reach the Start From menu:

  START FROM
>1 Fixed Node
 2 Current
 3 Enter Temp
 4 Result File

A transient analysis always needs a starting point.  The most common choice is "Fixed Node".
If the model is initially at room temperature, you should select this option.

The other options on the Start From menu are also useful.  You can start with the current steady
state temperatures (“Current”) or you can enter your own starting temperature (“Enter Temp”).
With “Result File” you can chain together transient analyses.  Of course, you can do all these
things and more with duty cycle transient.

Enter these commands to start the transient calculation:

Fixed Node ➔ Natural ➔  “25”

Sauna will begin the transient analysis.  A number of status messages will be displayed in the
prompt zone at the bottom of the Sauna window.  At the beginning of the calculation, you will
see messages indicating that the model is being checked and various solver parameters are
being assigned.  After a few seconds, you will start to see this type of status message:

Completed float step 1 of 60.  Dt = 0.29 sec (explic)
To cancel the temperature calculation, type “c”
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These status messages let you track the progress of your calculation.  Besides indicating the
float step, the message also indicates the current time step and solver method (“explic” for
explicit).  More details on these topics are given in a later section.

When the calculation is complete, you should obtain Tjunct = 136.42°C, Tleft-sink = 84.10°C and
Tmid-sink = 69.08°C.  These temperatures are within 0.5°C of the steady state temperatures.  Note
that "Transient, Optimized, Time = 30:00.00" is displayed in the top left portion of the graphics
window.  This indicates that the currently displayed temperatures are from the final time step
in the analysis.

If you wish, you can try a 1 hour transient analysis to verify that you will ultimately reach the
steady state temperatures shown on Figure 4-2.

Viewing results

While it’s certainly interesting to know the final temperatures in a transient analysis, it’s equally
important to have temperature vs. time data.  To obtain this information, start with:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE ➔ Minutes

This will bring up the Output Type menu:

  OUTPUT TYPE
>1 Graph
 2 Graph/Limits
 3 Text
 4 Spreadsheet

If you select “Graph” or “Graph/Limits”, Sauna will generate a graph of temperature vs. time
for the selected nodes.  You will have the choice of displaying the graph on the screen, printing
the graph, or saving the graph in a graphics file.  “Text” is used to generate a temperature vs.
time table which can also be displayed, printed or saved in a file.  “Spreadsheet” generates a
table in the tab-delineated spreadsheet format.  This type of report can be directly loaded into
virtually any spreadsheet or graphing program.

Most users will want to start with a graph of data to the screen.  Continue with:

Graph ➔ Screen

You will see the graph shown in Figure 4-3 on the next page.  Notice that in the upper-right key
box, the hottest curve is placed in the top position.  The second hottest curve is in the next
position, etc.  This makes the graph easier to interpret.



Supplemental Exercise 1: Transient And Duty Cycle Analysis 4 - 7

Temperature vs. Time Plot
-------------------------
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Figure 4-3: Temperature vs. time graph

Clear the graph from the screen, then generate a temperature vs. time table:

Text ➔ Screen

Sauna will display a temperature vs. time table.  Note that when generating temperature vs.
time graphs or reports, there can be a maximum of 8 different temperatures sets.  (There are
currently 4 temperatures to display because the heat source has both a case temperature and a
junction temperature.)  Clear the report before continuing.

Before moving on, you should know about an additional way to view transient data.  If you
wish, you can use File ➔ Import to view complete data from any float step in the analysis.

As you have just seen, it’s easy to perform a transient analysis with Sauna.  Now you will move
on to Sauna’s duty cycle transient features.

What is duty cycle transient?

It can be said that there are three types of temperature calculations: steady state, simple
transient, and duty cycle transient.  You’ve already used Sauna to perform a number of steady
state calculations.

Above, you performed a simple transient analysis.  In a simple transient analysis, wattage and
fixed node temperatures (room ambients) are held constant during the analysis.  Ordinary node
temperatures and float resistors change with time, but not wattages or fixed node temperatures.

For many real world problems, however, simple transient is not  enough.  Consider antilock
brake (ABS) circuitry in an automobile.  When the driver of a car hits the brake pedal and ABS
activates, the control circuitry pulses the brakes.  This causes heat dissipation to rise and fall
rapidly.  To predict temperatures for an ABS module, duty cycle transient is a requirement.
Wattages must be allowed to vary with time.  There are many other real world problems where
duty cycle capability is essential.
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Creating a time base control element

For duty cycle transient to be efficient, there needs to be a simple way to define the variation of
wattages and fixed nodes with time.  This task is handled with time base control elements.

As the next step in this exercise, you will create a control element which defines a square wave
power vs. time relationship.  The square wave will consist of 5 pulses which are “1 minute on”
and “1 minute off” (total time is 10 minutes).

Create the time base control element with these commands:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ With Menus ➔ Time Base ➔ Q vs Time
➔ “square #1” ➔ Minutes ➔ Square Wave ➔ “5” ➔ “1,1” ➔ “1,0”

➔ 4 (the default) ➔ Fixed Node

This message will be displayed:

Control element “square #1” successfully created

The control element was created.  But unlike nodes and resistors, there isn’t anything to be seen
on the screen.  You will need to get a report to find out more about the control element.  To get
a listing of all control elements in the model, enter these commands:

<F7 Info> ➔ Control Elem ➔ List All ➔ Screen

The report will be displayed on the screen.  You will see that there is currently one control
element: “square #1”.  The control type is “q_vs_time”.  The report indicates that the control
element is not in use, as expected since the control element is not assigned to any nodes.

Now let’s get some detailed information on the control element.  After clearing the control
element list from the screen, make these selections:

Graph ➔ Time Base ➔ Show Ramp ➔ Minutes ➔ All ➔ Screen

The square wave control element will be graphed as shown in Figure 4-4.

Control Element Plot
--------------------
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Figure 4-4: Graph of square wave control element
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In the graph, you can see that there are 5 pulses for a total control element duration of 10
minutes.   Notice that the Y-axis label is “Wattage ratio”.  This means that the control element
provides a wattage ratio, not an absolute wattage.  For the square wave just defined, the wattage
during the “on” portion of the square wave will be the current node wattage multiplied by one.
If the control element is applied to the heat source, the wattage during the “on” portion will be
40 x 1 = 40 watts.  It’s very practical to use wattage ratios because a single control element can
control a number of nodes with varying wattages.

Now let’s look at a control element from a different standpoint.  After clearing the graph from
the screen, enter these commands:

Text Report ➔ Enter Label ➔  “square #1” ➔ Screen

The text description of the control element will be displayed on the screen.  Control elements in
Sauna are based on a simple scripting language.  When you used the menus to create the
control element, Sauna generated the control element script which is now displayed.  Notice
that there is a loop defined by the “begin_loop = 5” and “end_loop” instructions.

If you wish, you can use Sauna’s scripting language to directly define control elements.  A
control element can be created with your word processor and then imported into Sauna.  This
subject will be discussed later.

When you obtained the text report, you typed in the entire control element label.  To save you
some work, Sauna lets you use the wild card character.  So instead of typing in “square #1”,
you could just type “s∗”, or even simply “∗”.  When using wild cards, of course, you must be
careful that you don’t accidentally select the wrong control element.

Assigning control elements and calculating temperatures

After clearing the report, try performing a duty cycle calculation:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized
➔ Default ➔ Natural ➔ “25”

You will receive these error messages in the prompt zone:

Warning: control element “square #1” is not in use
Duty cycle calc: no time base control elements in use

To perform a duty cycle calculation, you need at least one time base control element.  Since a
duty cycle calculation is transient in nature, a control element is required to define the duration
of the analysis and the variation of wattage and fixed nodes with time.  At this point, you have
created a control element, but it isn’t assigned to any nodes.

Assign the control element to the heat source with:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔  Time Base ➔ Q vs Time
➔ “s∗∗∗∗” ➔ Heat Source ➔ All In Wind ➔ USE

To show that the duty cycle has been assigned, Sauna changes the symbol for the heat source
node.  The node will have a “nightshade” symbol as shown in Figure 4-5 on the next page.  If
you are using abbreviated node symbols, a smaller version of the nightshade symbol will be
used instead.

Now you can calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized
➔ Default ➔ Natural ➔ “25”
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Figure 4-5: Nightshade node symbol indicates that a control element has been assigned

After 10 minutes of on/off cycling, you should obtain Tjunct = 49.24°C, Tleft-sink = 49.11°C and
Tmid-sink = 43.07°C.  The temperatures are similar because the analysis ends with a one minute
“off” period.  To get a clear picture of how temperatures vary, obtain a temperature vs. time
graph:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp
➔ All In Wind ➔ USE ➔ Minutes ➔ Graph ➔ Screen

The graphed temperatures will be as shown in Figure 4-6:

Temperature vs. Time Plot
-------------------------
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Figure 4-6: Temperatures from square wave control element
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With the graphed temperatures, it can be seen that the heat source temperatures rise and fall
significantly while the “mid-sink” temperature shows a gradual increase with few up and
down variations.  The mid-sink node is responding to the time average dissipation, not the
instantaneous dissipation.  These trends become very clear with the graphing capability.

When you look at the graph, notice that there are 4 temperatures points for each “on” pulse and
4 temperatures points for each “off” pulse.  There are four temperatures per pulse because you
chose 4 float steps when creating the control element.  When you specify the number of float
steps, you are also specifying the number of output temperatures because Sauna only saves
temperatures at the end of each float step.  Clear the graph from the screen before continuing.

You’ve just seen how easy duty cycle transient can be.  With Sauna you will save many hours of
modeling time because of the advanced duty cycle capability.  And, as you will see below,
Sauna can handle much more complicated configurations than the example just worked.

A second duty cycle example: out of phase heat source

In the second duty cycle example, you will add a second heat source with square wave power
dissipation (see Figure 4-7).  However, the second heat source will be 180° out of phase.  Instead
of starting with 1 minute “on”, the square wave for the 2nd heat source will start with 1 minute
“off”.

Create the second heat source:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ “40” ➔ “S2” ➔ TO-247 ➔ Typical
➔ Standard ➔ Greased ➔ One ➔ trap the plate ➔ Coords/Trap ➔ “180,60”

The heat source will be added.

left-sink

S1

mid-sink

S2

2nd heat source
with control element

X

Y

Figure 4-7: Two heat sources on sink
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Next, create a 2nd control element:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ With Menus ➔ Time Base ➔ Q vs Time
➔ “square #2” ➔ Minutes ➔ Square Wave ➔ “5” ➔ “1,0” ➔ “1,1”

➔ 4 (the default) ➔ Fixed Node

Sauna will inform you that “control element “square #2” successfully created”.  This control
element is 180° out of phase from the first control element.  Verify this by graphing all control
elements in the model:

<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Minutes ➔ All ➔ Screen

Although the graph is a little difficult to read because sections of the curves are superimposed,
you should clearly see that when “square #1” is on, “square #2” is off (and vice versa).

After clearing the graph, assign the new control element to heat source “S2” (don’t use wild
cards this time):

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔  Time Base ➔ Q vs Time
➔ “square #2” ➔ Heat Source ➔ place right heat source in group ➔ USE

You will see a nightshade symbol for the right heat source.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle
➔ Optimized ➔ Default ➔ Natural ➔ “25”

After 10 minutes of cycling, you should obtain TS1-junct = 58.57°C and TS2-junct = 114.27°C.  Graph
temperatures:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp
➔ All In Wind ➔ USE ➔ Minutes ➔ Graph ➔ Screen

The graph presents a clear view of how temperatures changed over time.  Notice how the “mid-
sink” node shows little up and down cycling, just a steady increase.  Clear the graph before
continuing with the next section.

A third duty cycle example: ramped fixed node temperature

Up until now, you have used control elements to control wattages.  In this section, you will use
a Sauna control element to vary the room ambient fixed node.  The initial fixed temperature
will be 0°C.  Over a ten minute period, the room ambient will increase linearly to 60°C.  This
type of control element is useful for determining maximum temperatures during accelerated
life testing, as well as other time-varying boundary conditions.

Begin creating the control element as follows:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ With Menus ➔ Time Base
➔ Temp vs Time ➔ “ramp #1” ➔ Minutes ➔ Ramp ➔ “0” ➔ “10,60”
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You will reach another float step menu:

  FLOAT STEPS
>1 60
 2 20
 3 100
 4 200
 5 600
 6 1000
 7 1800
 8 Enter Steps

Normally, you would select “60” or some other fairly large number.  However, for reasons
explained below, you should specify just one float step:

Enter Steps ➔ “1”

Now, graph the newly created control element:

<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Minutes
➔ Temp vs Time ➔ Screen

This control element has only one float step.  There are only two points to graph: the start point
and end point.  If you look at the graph, the circle symbol is only shown for these two points.

After clearing the graph, turn on fixed nodes and assign the ramp control element:

click  

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔  Time Base ➔ Temp vs Time
➔ “r∗∗∗∗” ➔ All In Wind ➔ USE

Notice that the fixed node symbol changes when a control element is assigned.

One more time, graph the “ramp #1” control element:

<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Minutes
➔ Temp vs Time ➔ Screen

This time around 50 points are graphed.  Why?  It’s due to the wattage control elements.  The
float steps for the fixed node control element are different from the float steps for the wattage
control elements.  When Sauna detects this, it adds extra float steps so that all control elements
share the same time coordinates.  Sauna does this automatically, provided that the control
elements have actually been assigned to one or more nodes.

Clear the graph, then create another graph with the “stairstep” option:

Graph ➔ Time Base ➔ Stairsteps ➔ Minutes ➔ Temp vs Time ➔ Screen

Instead of a straight line, the control element is graphed as a series of stairsteps.  This is what
Sauna actually uses during a temperature calculation.  The stairsteps are Sauna’s approximation
of the linear ramp.  The more float steps you specify, the better the approximation to the ideal
case.

Notice that, for this graph, Sauna didn’t use circle symbols to show the points in the curve.
When a curve has too many points, Sauna omits the point symbols.  These keeps the graph
from getting overly cluttered.  Sauna does, however, always use a point symbol for the final
point in the curve.
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Let’s try one last graph.  It is possible to show all control elements, both wattage and fixed
temperature, in a single graph.  After clearing the current graph, enter:

Graph ➔ Time Base ➔ Stairsteps ➔ Minutes ➔ All ➔ Screen

This graph gives a clear view of all control elements in the model.  All of the control elements
created have a total duration of 10 minutes.  While float steps don’t have to be identical, all
control elements must have the same total time.

After clearing the graph, calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default ➔ Natural

For this duty cycle calculation, you don’t have to enter a room ambient temperature.  The room
ambient temperature is defined with a control element.

You should obtain TS1-junct = 55.56°C and TS2-junct = 111.27°C.  Graph temperatures:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp
➔ All In Wind ➔ USE ➔ Minutes ➔ Graph ➔ Screen

Notice that the fixed node temperature is graphed along with the heat source and sink nodes.
Clear the graph before moving to the next section.

Complex control elements

If you are not interested in complex control elements, feel free to skip ahead to the "Junction with mass on
a board stackup" section.  You can always return to this section at a later time.

You’ve just seen how Sauna can efficiently deal with square waves and ramps.  But these are
fairly simple waveforms to describe.  What about non-uniform waveforms?  For example, can
Sauna be used for the complex curve shown in Figure 4-8?  And, just to keep things interesting,
the starting point for the analysis should be a standby calculation at 50% power.  (A standby
calculation is a steady state calculation which immediately precedes the duty cycle calculation.)
Can Sauna handle this duty cycle as well?  (You can probably guess the answer.)

Control Element Plot
--------------------
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Figure 4-8: Example of a complex control element
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Fortunately, Sauna can effectively handle control elements of almost any complexity.  But the
method for describing the control element is different.  Instead of using the menus, you will use
a word processor to write a control element script.  The script is a simple computer program
which contains just the necessary commands for control elements.  Once the script is complete,
it can be imported into Sauna.

The best way to understand control element scripting is to look at an example.  Figure 4-9 show
the script for the complex control element of Figure 4-8.  The first thing to point out is that
control element scripts can contain comments.  Any text to the right of a “//” pair is a comment.
There are lots of comments in the example script to explain the various options.  All of these
comments are optional and will be ignored when the control element is imported.

//    ----- HEADER -----

Sauna control element file V1.1 // exact title is mandatory

label         = "Complex CE"    // maximum of 23 characters

type          = q_vs_time       // choices: q_vs_time, fixed_temp_vs_time

time_units    = seconds         // choices: hr:min:sec, usec, microseconds,

                                //          msec, milliseconds, sec, seconds,

                                //          min, minutes, hr, hours

initialize    = standby_init // choices: current_init, fixed_init, result_init,

                             //          standby_init, start_temp_init

standby_value = 0.5          // For standby_init, enter "standby_value = x.x"

                             // For start_temp_init, enter "start_temp = x.x"

                             // For other initializations, omit line entirely.

float_step    = 4            // can be changed later in duty cycle

//    ----- COMMANDS -----

0.0, 1.0, square

3.0, 1.0, ramp

6.0, 3.0, end_pulse

begin_loop = 2

   0.0, 1.0, square          // a loop must start with time = 0.0

   1.0, 0.0, square

   2.0, 0.0, end_pulse       // a loop must end with an end_pulse

end_loop

begin_loop = 2

   0.0, 0.0, ramp

   2.0, 5.0, end_pulse

   2.0, 0.0, square

   10.0, 0.0, end_pulse

end_loop

0.0, 1.0, square, float_step = 2 // first line after loop must have time = 0.0,

                                 // note the change in float step

2.0, 0.0, end_pulse              // when an end_pulse follows a square command,

                                 // the 2nd real number is ignored by Sauna

end_duty

Figure 4-9: Control element script

When you look at the control element script, you will see that a control element script contains
two basic components: the header section and the commands section.  Most of the header
section is mandatory.  In fact, the only optional line depends on the initialization type.  Two of
the initialization types, standby_init and start_temp_init, require a value.  So, if you have
specified standby_init, you must follow with a line of the type “standby value =  x.x”.  If you
specify start_temp_init, you must follow with a “start_temp = x.x” line.  For the other
initialization types, such as fixed_init, the float_step line will follow after the initialization line.
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After the header section, comes the commands section.  These commands define the actual
variation of wattage ratio with time.  While the commands may seem a bit cryptic at first, you
will quickly learn control element scripting.  Note that the example was carefully chosen to
demonstrate a number of control element possibilities.  Once you understand this example, you
should be able to define virtually any control element.

Note that Figure 4-9 shows the V1.1 scripting format.  However, the V1.0 format can still be
used.  There are only minor header differences between the two formats.

You will be creating the control element script with a word processor.  Then you will import the
control element into Sauna and assign the control element to both heat sources.

It’s a good idea to minimize the amount of typing.  First of all, there’s no need to include all the
comments shown above.  Second, it’s a good idea to use an existing control element script as a
starting point.   Start by getting a basic text report for an existing control element:

<F7 Info> ➔ Control Elem ➔ Text Report ➔ Enter Label ➔  “square #1” ➔ Screen

With the control element report displayed on the screen, you can see that the basic text report
includes the complete control element script.  This text report will make an excellent starting
point for creating the complex control element.  You will just need to delete the lines above
“Sauna control element file V1.1”.

After clearing the report from the screen, save the control element in a plain text file:

Text Report ➔ Enter Label ➔  “square #1” ➔ File ➔ change “Save as type” to “All Files (*.*)”
➔ type “complex.dty” in File name box➔ click Save button ➔ hit <Enter> to skip ➔ No

The control element report will be saved as “complex.dty”.  Note that “dty” is the standard file
extension for control element files.  It was necessary to change the “Save as type” to “All Files”
to avoid obtaining “complex.dty.txt”.

It may seem strange that the file extension is “dty”.  The reason is historical.  Before Sauna V4.0,
time base control elements were known as duty cycle elements, which made “dty” a logical
extension.

In a moment you will switch out of Sauna and finish creating the control element script in a
word processor.  As a precaution, save the current model:

<F12 Root Menu> ➔ File ➔ Save As ➔ change “Save as type” to “Sauna Model Files (*.smf)”
➔ type “sink_with_duty” in File name box ➔ click Save button

Next, minimize Sauna.  Startup up Notepad or your word processor.  When opening
“complex.dty”, change the “Files of type” to “All Files” so that “complex.dty” appears in the
file list (depending on your Windows setup, you may see “complex” instead of “complex.dty”).
After opening complex.dty, make the necessary changes to the control element script.
Remember, you do not need to include the comments.  Save the file.  If you use your word
processor, be sure to save “complex.dty” as a plain text file.

Now return to Sauna.  Delete all existing control elements and turn off fixed nodes:

<F12 Root Menu> ➔ Delete ➔ Control Elem ➔ Delete All ➔ click Yes button

click  
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It’s time to import the complex control element.  Begin with

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create

You will reach the Create Type menu:

  CREATE TYPE
>1 With Menus
 2 Import
 3 File Link

You have already used “With Menus” to create the square wave and ramp control elements.
Now it’s time to use one of the other two options.

Both “Import” and “File Link” use an external text file to create a control element.  But there are
some important differences.  With “Import”, the text file is used to generate a complete control
element within Sauna.  Once this has been done, the text file can be deleted.  “File Link” is
different.  With this option, Sauna maintains a permanent link to the text file.  Every time that
Sauna makes a temperature calculation, or even generates an Info report, the control element
file is reloaded.  Any changes in the text file will immediately be used by Sauna.

Which is the best choice?  When possible, use “Import” because you don’t have to worry about
accidentally deleting or modifying the text file.  It’s a safer choice.  However, for imported
control elements, you are limited to a maximum of 12 command lines.  So, for the current
problem, you are required to use the file link option.  Continue with:

File Link ➔ select complex.dty file ➔ click Open button

Hopefully, Sauna will create the control element and you will see the message “Control element
“Complex CE” successfully created”.  On the other hand, it is certainly possible that you made
a mistake when typing up the control element.  Look carefully at Sauna’s error message.  The
error message will include a line number.  If you get such an error, you will need to go back to
the control element text file and correct the error.  Then try again to create the control element.
Don’t be surprised if you make a mistake or two when creating a control element script for the
first time.  This is not an uncommon problem for beginners.  (If you can’t find an error in the
script, contact Technical Support for assistance.)

When you have succeeded in creating the control element, obtain a graph of your complex
control element:

<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔  Show Ramp ➔  Seconds ➔ All ➔ Screen

As you see, even for a file link control element, it’s possible to obtain a graph.  You should
verify that your graph is the same as the graph shown in Figure 4-8.

Clear the graph, then assign the control element to both heat sources with:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔ Time Base ➔ Q vs Time ➔ “∗∗∗∗”
➔ Heat Source ➔ All In Wind ➔ USE

The symbol will change for both heat sources.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle
➔ Optimized ➔ Default ➔ Natural ➔ “25”
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Since this control element uses a standby initialization, Sauna will precede the transient
calculation with a standby calculation.  Sauna displays status messages to indicate the start and
finish of the standby calculation.  However, for a small model, these messages are only
displayed for a brief period of time.

When the calculation is complete, you should obtain TS1-junct = 116.19°C and TS2-junct =  116.00°C.
(Note that the heat sources are not perfectly symmetric on the sink, so temperatures will not be
identical.)  These temperatures seem reasonable.  However, for a control element problem, the
final temperature is not always the maximum.  It is important to look at temperatures over the
entire duty cycle.  Obtain a graph:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp
➔ All In Wind ➔ USE ➔ Seconds ➔ Graph ➔ Screen

The graphed temperatures should appear as in Figure 4-10:

Temperature vs. Time Plot
-------------------------
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Figure 4-10: Temperatures for complex control element

With the full set of temperatures shown, temperatures don’t look reasonable any more.  The
peak junction temperature is nearly 230°C.

Finally, note that Sauna also has a control element “redefine” feature.  Above, you deleted
control elements, created a new control element, and then assigned the new control element to
the heat source nodes.  Instead of this three step process, you could have used Edit ➔
Control Elem ➔ Time Base ➔ Redefine to modify the control element characteristics, while
maintaining the node assignments, all in a single step.

Clear the graph before moving on to the next section.
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Junction with mass on a board stackup

Up until now, you have been working exclusively with basic heat sources.  With basic sources
the junction is always assumed to be massless.  At the beginning of the exercise, it was stated
that massless junctions are fine for analyses that extend for more than a few seconds.  You will
now verify that this recommendation is valid.

You will be using the model "dpak_four_lyr.smf" created in Introductory Exercise 5: Basics Of
Circuit Board Modeling.  This model can also be found in the "C:\Program Files (x86)\Sauna
Thermal Modeling\References Models" folder.  Load the model:

<F12 Root Menu> ➔ File ➔ Open ➔ select "dpak_four_lyr.smf" ➔ click Open button
➔ click Yes button to delete current model

click  

The model will be loaded.  You should see Tjunct = 50.47°C.  Perform a transient calculation of
30 minutes:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Transient ➔ Optimized ➔ Minutes ➔ "30"
➔ 60 ➔ Default ➔ Fixed Node ➔ "25"

The temperature calculation will begin.  You are sure to notice that the calculation takes longer,
particularly for the first time step.  Board stackup models have many nodes and this has a very
direct impact on calculation time.  If your computer was purchased in the last few years, the
calculation will take a minute or two.

When the calculation is complete, you should obtain Tjunct = 50.48°C, which is within 0.01°C of
the steady state temperature.

Now you will try a shorter duration analysis, so you can see how junction mass affects the final
result.  As mentioned earlier, basic source junctions are always massless, so the thermal
capacitance is  zero.  And, actually, enhanced sources are created with massless junctions by
default.  But, unlike basic sources, you can easily edit the junction capacitance.

Get an Info report for the S1 enhanced source:

<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ trap S1 source

On the first page, in the "-- General Properties --" section, you will see a capacitance of 0.0.  This
is the junction capacitance.  (For an enhanced source, the heat source node represents only the
junction.)

There is also a body assembly associated with the junction node.  The body assembly has mass.
Clear the node report, then obtain the assembly mass report:

<F7 Info> ➔ Assemblies ➔ Mass/Supers ➔ Screen

At the top of the report you will see that the body assembly ("Body>1") has a mass of 5.25E-4 kg
and a capacitance of 0.27 watt-sec/°C.  In the “-- Capacitance Totals --” section at the bottom,
the heat source capacitance is 0.0.

Clear the report before continuing.
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Before switching to non-zero junction capacitance, let's obtain some reference data for the
current model.  Begin with a transient analysis of 5 seconds:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Transient ➔ Optimized ➔ Seconds ➔ "5"
➔ 60 ➔ Default ➔ Fixed Node ➔ "25"

You should obtain Tjunct-no-mass = 35.28°C.  Next, try a 1 second analysis:

Transient ➔ Optimized ➔ Seconds ➔ "1" ➔ 60 ➔ Default ➔ Fixed Node ➔ "25"

For the 1 second analysis, you should obtain Tjunct-no-mass = 31.89°C.

Switching to junction with mass

Now that you have obtained some reference data, you can switch to a junction with mass.
Change the junction capacitance to "typical":

<F12 Root Menu> ➔ Edit ➔ Heat Input ➔ Enhanced Src ➔ Junct Capac
➔ trap S1 source ➔ Typical

Sauna will indicate that "assigned typ junction capacitance (4 x 4 x 0.3 silicon)".  Get an Info
report for the heat source:

<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ trap S1 source

On the first page, in the "-- General Properties --" section, you will see that the capacitance is
now 8.40E-3.  (The units of capacitance are watt-sec/°C.) Also, in the "-- Sub-type Properties --"
section, the capacitance type is shown as "typical for 4 mm x 4 mm silicon".

Clear the node report, then obtain an assembly mass report:

<F7 Info> ➔ Assemblies ➔ Mass/Supers ➔ Screen

In the "-- Capacitance Totals --" section, you will also see the new contribution from the heat
source junction.  Notice that the overall model capacitance has increased from 31.12 to 31.13, a
very modest increase of 0.03%.  Clear the report before continuing.

With the capacitance modified, you can repeat the transient analyses performed earlier.  Start
with the five second analysis:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Transient ➔ Optimized ➔ Seconds ➔ "5"
➔ 60 ➔ Default ➔ Fixed Node ➔ "25"

You should obtain Tjunct-with-mass = 35.19°C, compared with Tjunct-no-mass = 35.28°C.  In terms of
the ∆T to ambient, Tjunct-with-mass is 0.9% cooler.  So, for a five second analysis, the results are
largely the same.

Now try a 1 second analysis:

Transient ➔ Optimized ➔ Seconds ➔ "1" ➔ 60 ➔ Default ➔ Fixed Node ➔ "25"

You should obtain Tjunct-with-mass = 31.68°C, compared with Tjunct-no-mass = 31.89°C.  The ∆T
between the two cases is a larger 0.21°C.  In terms of the ∆T to ambient, Tjunct-with-mass is 3.0%
cooler.  While 3.0% is not a large change, it is starting to become significant.
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You should be aware that the response time of the junction is affected by more than just
capacitance.  There are also resistances involved, in particular the junction-to-case resistance.
So there is no simple cutoff for choosing between a massless junction and a junction with mass.
In general, you need to be alert for junction mass/capacitance impacts for analyses (pulses for
duty cycles) which are shorter than a few seconds.

High frequency effects

Earlier in the exercise you analyzed duty cycle problems where the on and off pulses were 1
minute long.  In this situation you saw that nodes close to the heat source cycled up and down,
while nodes far from the heat load tended to respond only to the average power (see Tmid-sink in
Figure 4-6 on page 4-10).  In this section you will try higher frequency duty cycles and see how
temperatures respond.

You will be monitoring two temperatures, Tjunct and Tpad as shown in Figure 4-11.  Tpad is on
the copper pad directly below the DPAK device.

S1

31.68

pad

30.44

X

Y

Transient, Optimized, Time = 00:01.00

Figure 4-11: Location of pad node

You need to be sure that you label the correct node, so start by isolating the front layer:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Copp>1

Add the label:

<F12 Root Menu> ➔ Edit ➔ Node ➔ Labels ➔ Trap 1 Node ➔ Any Node
➔ trap upper-right node of pad ➔ type "pad" in text box ➔ click OK button

You should see the temperature 30.44°C for the newly labeled node.  This is the temperature
after a 1 second transient analysis with Q = 1W.

Restore visibility:

click  
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Instantaneous and time average power

In the preceding section, you worked with power pulses of 1 second.  Now you will see what
happens as you simulate much shorter power pulses.  For reasons that will become clear later,
double the source wattage:

<F12 Root Menu> ➔ Edit ➔ Heat Input ➔ Enhanced Src ➔ Wattage ➔ trap S1 source ➔ "2"

Next, create and assign a simple "1 second on/1 second off" square wave control element:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ With Menus ➔ Time Base ➔ Q vs Time
➔ "square #1" ➔ Seconds ➔ Square Wave ➔ "3" ➔ "1,0" ➔ "1,1" ➔ 4 ➔ Fixed Node

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔ Time Base ➔ Q vs Time ➔ "∗∗∗∗"
➔ Heat Source ➔ All In Wind ➔ USE

Sauna will inform you that "control element "square #1" assigned to 1 node".

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default ➔ "25"

You should obtain TS1-junct = 41.35°C and Tpad = 38.74°C.  Obtain a transient temperature graph:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Seconds ➔ Graph ➔ Screen

You will see the curve shown in Figure 4-12:

Temperature vs. Time Plot
-------------------------
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Figure 4-12: Temperatures for 1 second pulses, strong thermal coupling
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The graph shows that the pad node is cycling almost as much as the junction.  In other words,
there is strong thermal coupling between the two.  (Note that the control element starts with an
off pulse, so the nodes stay at room temperature for the first half-cycle.)  Clear the graph before
continuing.

Now you will try a much higher frequency analysis, where the "on/off" pulses are just 5
millisecs.  You will use the "redefine" command, which lets you recreate a control element,
while maintaining node assignments.  Redefine the control element:

<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Redefine ➔ Q vs Time ➔ "∗∗∗∗"
➔ With Menus ➔ Millisecs ➔ Square Wave ➔ "100" ➔ "5,0" ➔ "5,1" ➔ 4 ➔ Fixed Node

Sauna will indicate that the control element has been redefined.  Graph the control element:

<F7 Info> ➔ Control Element ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Millisecs ➔ All ➔ Screen

The graph shows a dense square wave with a total duration of 1 second (1000 msecs).  After
clearing the graph, calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default ➔ "25"

You should obtain TS1-junct = 31.97°C and Tpad = 30.45°C.  Obtain a transient temperature graph:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Seconds ➔ Graph ➔ Screen

The graph is quite interesting.  As expected, Tjunct fluctuates, with a peak-to-peak amplitude of
0.6°C.  But for the pad node, which is directly underneath the device, the fluctuation is only
0.05°C.  The thermal coupling is very low and the pad node is responding almost exclusively to
the time average wattage.

Temperature vs. Time Plot
-------------------------
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Figure 4-13: Temperatures for 5 msec pulses, pad responds to time average power
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It is very interesting to compare the current results, which is a 50% duty cycle at 2W for
1 second, with the 1W simple transient analysis.  The Tjunct is higher for the 2W duty cycle
(31.97°C vs. 31.68°C, 4.3% higher).  However, for Tpad, the temperature is nearly identical
(30.45°C vs 30.44°C).

This is a classic case of the junction responding to the instantaneous wattage, while the rest of
the model responds only to the time average power.  In the current model, the square wave
frequency is a modest 100 Hz.  In transient analysis, you hear rules of thumb like "for
frequencies greater than 1 KHz, only the time average power gets out of the junction".  For
many situations, this is a valid rule.

There are certainly implications for thermal modeling.  If you have a high frequency duty cycle
over an extended period, you can work with the time average power, which greatly reduces the
calculation time.  You would only need to model the individual power pulses for the peak
temperature portions of the duty cycle.

If you have questions about how to handle these problems, feel free to contact Technical
Support.  And be sure to read the section "Quasi steady state transient" on page 4-29.  Clear the
graph before continuing to the next section.

Understanding the explicit and implicit methods

Each time that you performed a transient or duty cycle calculation, you used the Solver Type
menu:

 SOLVER TYPE
>1 Optimized
 2 Explicit
 3 Implicit
 4 Quick Calc

Up until now, you have always chosen "Optimized".  With the optimized approach, Sauna
looks at model characteristics and chooses between either the explicit or implicit solution
method.  The goal is to minimize calculation time while maintaining good accuracy.  If, on the
other hand, you choose "Explicit" instead of "Optimized", Sauna will be locked into the explicit
method.  Similarly, "Implicit" will force Sauna to use the implicit solver.

The last menu choice, "Quick Calc", is not discussed in this exercise.  For a discussion, see Quick
Calc Solver in the Using Sauna chapter.

Not everyone knows the difference between the explicit method and the implicit method.
Here's a quick summary:

Explicit method.  This is an easy-to-understand method which is covered in nearly all
introductory heat transfer textbooks.  Sometimes the explicit method is known as the
"forward difference" method.  With the explicit method, the node temperature at the next
time step is obtained by a simple heat balance which looks at adjacent node temperatures,
thermal capacitance and the ∆t.  While the explicit method is easy to understand and
implement, there is a major limitation.  If the time step is large, the solution becomes
unstable.  While it's easy to calculate the maximum time step for a stable solution, this stable
time step is often quite small.  If the time step is small, there will be many iterations and a
correspondingly large calculation time.  Models which are finely meshed, or which have
very small thermal resistances, can have very large explicit calculation times.
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Implicit method.  The implicit method is an alternative to the explicit technique.  The
implicit method is also known as the "backward difference" method.  With the implicit
method, there is a complete matrix inversion for each time step instead of a simple node-by-
node heat balance.  While it might be expected that the implicit method would be slow
because of the matrix inversions, it can actually be quicker than explicit because the time
step can be much larger.

Now here's an important point about the implicit method.  Although the implicit method is
always stable, this doesn't mean that the implicit method is always highly accurate.  The
implicit method won't give ridiculous answers but, without error control techniques, there
could easily be errors on the order of 10% - 30%.  To minimize errors, it becomes necessary
to use smaller time steps.  So while the implicit method doesn't have a stability problem
with large time steps, there is a potential accuracy problem.

To control errors with the implicit method, it's possible to use a step-doubling/step-halving
algorithm.  Conceptually it's very simple.  An initial implicit calculation is performed with a
large time step. Then the calculation is repeated with two half-steps and the results are
compared.  If there is a substantial difference between the two calculations, the time step is
again reduced by a factor of two.  The time step adjustment continues until acceptable
accuracy is obtained.  Once an acceptable time step has been found, the calculation can
proceed.  After a few additional time steps, an additional error check is performed.  If errors
are large, the time step is reduced again.   If, on the other hand, errors are very small, it
becomes possible to make the time step larger.  While this step-doubling/step-halving
approach may seem computationally intensive, the implicit method with error control can
still be 100 times faster than the explicit method.  But it all depends on the model
characteristics.

It should be clear that neither method will be optimal for all models.  Sauna's approach is to
choose a method automatically based on an estimation of calculation times.  One potential
problem is that it's hard to estimate in advance the total number of implicit calculations.  Sauna
resolves this problem by continually monitoring the total time required for the implicit
calculation.  Sometimes Sauna starts with the implicit method and then switches over mid-
stream to explicit because the implicit calculation is taking longer than anticipated.

Sample transient calculations

Now let's do some simple experiments and see how Sauna uses the different solver methods.

Begin by reloading “dpak_four_lyr.smf”:

<F12 Root Menu> ➔ File ➔ Open ➔ select "dpak_four_lyr.smf" ➔ click Open button
➔ click Yes button to delete current model

click  

The model will be loaded.  You should see Tjunct = 50.47°C.  Although it’s not relevant for this
section, this model has a massless junction.
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To start, you will use "Optimized" to perform a simple transient analysis with a duration of
5 minutes and 5 float steps.  Be sure to watch the messages in the prompt zone:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Transient ➔ Optimized ➔ Minutes
➔ "5" ➔ Enter Steps ➔ “5” ➔ Default ➔ Fixed Node ➔ "25"

Initially, you will see these messages:

Calculating parameters for Optimized solver...
Checking model...
Temperatures results will be written in dpak_four_lyr.srf
Model verified, 5 dissipation items

After a period of time, you will see this:

Reducing time step for implicit solver...
Current Dt = 15.00 sec Error = 0.72 Target = 0.10
Current Dt = 7.50 sec Error = 0.15 Target = 0.10

Completed float step 1 of 5, Dt = 3.75 sec (implic)
To cancel the temperature calculation, type "c"

As indicated, Sauna started with the implicit solver and reduced the solver time step (∆t) to
obtain an acceptable error.  In general, the first part of a transient analysis requires a smaller ∆t,
so you started with 15 seconds, but it was necessary to reduce the ∆t to 3.75 seconds.

After completing the first float step, you will see these messages:

Completed float step 2 of 5, Dt = 15.00 sec (implic)
To cancel the temperature calculation, type "c"
Completed float step 3 of 5, Dt = 30.00 sec (implic)
To cancel the temperature calculation, type "c"
Completed float step 4 of 5, Dt = 30.00 sec (implic)
To cancel the temperature calculation, type "c"

As the calculation proceeds, Sauna continually attempts to increase the ∆t.  By the 3rd float step,
the ∆t is 30 seconds, which is the maximum possible (∆tmax = float-step-time/2). When the
calculation is complete, you should obtain Tjunct = 48.63°C.

The previous calculation was done entirely with the implicit solver.  But if you change the
number of float steps, Sauna may choose to use the explicit solver.  To see this, repeat the same
5 minute analysis, but with 10 float steps:

Transient ➔ Optimized ➔ Minutes ➔ "5" ➔ Enter Steps ➔ “10” ➔ Default ➔ Fixed Node ➔ "25"

When you reach the point where Sauna reduces the implicit ∆t, you will see this:

Reducing time step for implicit solver...
Current Dt = 7.50 sec Error = 0.73 Target = 0.10
Switched to explicit solver...

Completed float step 1 of 10, Dt = 3.48E-3 sec (explic)
To cancel the temperature calculation, type "c"

For the first float step, Sauna started with the implicit solver, but switched to the explicit
method.  The switchover occurred because the implicit solver was converging slower than
expected.
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After completing the first float step, you will see these messages:

Completed float step 2 of 10, Dt = 15.00 sec (implic)
To cancel the temperature calculation, type "c"
Completed float step 3 of 10, Dt = 15.00 sec (implic)
To cancel the temperature calculation, type "c"

For the second and higher float steps, Sauna switched back to the implicit solver.  This is a fairly
common occurence since, as stated earlier, the first float step of analysis tends to require a
smaller ∆t, which favors the explicit method. The ∆t of 15 seconds is the maximum allowable
for a float step of 30 seconds.

When the calculation is complete, you should obtain Tjunct = 48.64°C.  Notice that the Tjunct is
slightly different (48.64°C vs. 48.63°C).  When you change the float step or solver method, the
temperature will be different by a small amount, generally not more than a few tenths of a
degree.

Besides “Optimized”, you can also directly specify the implicit or explicit solver.  Usually,
“Optimized” is the best choice.

Now here's a few details for those users that have experience with transient solvers.  To be
completely accurate, Sauna does not use a pure implicit solver.  Instead, Sauna uses a modified
Crank-Nicholson technique with a coefficient of 0.75.  For explicit, Sauna use a first-order
explicit formulation.

Managing transient calculation time

For complex models, transient and duty cycle analysis can take a long time.  This is particularly
true for duty cycle analysis with high frequency waveforms.  If you are not careful, you could
be facing calculation times of several hours.  This is not a good thing.

It is much better to keep calculation times under 5 minutes.  In this way you will be able to do
what-if analysis and you will be able to optimize your design.  When it take hours to complete a
single calculation, the what-if analysis tends to get skipped.

Here are some suggestions for improving transient calculation time.

1.  Reduce the number of nodes in the model.  Where possible, use the Remesh command to
switch entire assemblies to a coarser node spacing.  You can usually do this for the outer
walls of a box.  Be sure to do before and after calculations to verify that the impact is small
for the key heat generating components.

If you can't remesh the entire assembly because there is a heat source, use the slice
command to create assemblies that can be remeshed.  Follow the procedure outlined in
Intermediate Exercise 1: Superassemblies And Basic Slicing.

2.  Make junctions massless (zero capacitance).  As you have seen in this exercise, the
junction capacitance is only important for short duration analyis (pulses less than a few
seconds).

3.  Make certain assemblies massless (zero capacitance).  It's not uncommon for a model to
have small and thin assemblies that are well removed from heat loads.  A good place to start
is the Time Constant report.  To use the Time Constant report, you will need to start with a
steady state or transient calculation, so that all float resistor values are assigned.
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Obtain the time constant report with:

<F7 Info> ➔ Node/Resis ➔ Time Const ➔ All Nodes ➔ Screen

The report will indicate the location of the node with the smallest time constant.  The report
also shows the assembly of this node, so you could convert this assembly to zero
capacitance with:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ Zero Capac ➔ Set To Zero...

It should be noted that nodal time constant is a functin of both the thermal capacitance of
the node and the connecting resistor values.  So, as an alternative to using zero capacitance,
you can also increase time constants.  Time constants can be increased by editing assembly
capacitance and/or adjusting resistance values.

When you have completely finished modifying the model to increase the minimum time
constant, be sure to check the total model capacitance with Info ➔ Assemblies ➔
Mass/Supers...  You should be able to correct the time constant problem while maintaining a
total model capacitance which is within a few percent of the original total.

4.  Simplify duty cycles by using time average power.  If you are dealing with a power curve
similar to the left graph in Figure 4-14, there is no point in modeling all of the fluctuations in
the first half of the curve.  Instead, as shown in the figure, just use time average power for
the first half of the waveform.

Time

Wattage

Time

Wattage

original
waveform

simplified
waveform

Figure 4-14: Simplifying power curves

You should also read "Quasi steady state transient" on the next page.
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If you use the above tips, you should be able to keep transient calculation times within
reasonable bounds.  Still, it does take some experience to do this effectively.  If you need
assistance, be sure to contact Technical Support.

Beyond footprint heat sources

In this exercise you have worked exclusively with footprint heat sources.  You have seen that
enhanced footprint sources are more accurate for short duration transient because you can
assign a junction capacitance.  However, you should be aware that even an enhanced source is a
fairly simplified representation of a semiconductor device.  In some situations, you may need to
represent the device with a detailed stackup model.  Detailed stackup models are introduced in
Intermediate Exercise 2: Stack Joins And Stackup Models.  More advanced constructions are covered
in Supplemental Exercise 2: Semiconductor Stackup Models.

Nodes in fins and transient

As described in Intermediate Exercise 4: Heat Sink Models With Nodes In Fins And h vs. Length, you
will usually obtain somewhat more accurate temperatures if you create nodes in the fins.  This
approach is also useful for transient because it more accurately represents the model
capacitance.  Although the model will be more accurate, the impact on temperatures is usually
small.  Typically, nodes in fins reduces temperatures by about 1°C to 4°C.

Quasi steady state transient

Figure 4-11 shows temperature vs. time for a “quasi steady state” problem:
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0.00 50.00 100.00
20

30

40

50

60

70

80

90

Time (minutes)

Temp (°C) Source 1

Quasi steady state region

Figure 4-11: quasi steady state transient
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Sauna has some special features to deal with quasi steady state transient.  To learn more, visit
this webpage:

http://www.thermalsoftware.com/tech_notes

You should then download Technical Note #8 - Quasi Steady State Transient , which explains the
most efficient method for quasi steady state.

Wrapping Up

This concludes the exercise on transient and duty cycle modeling.  Delete the model with:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ “y”

If you have further questions, please contact Technical Support.


