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   Introductory Exercise 4: Multi-Plate Boxes

In the first portion of this exercise, this enclosure will be modeled:
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TO-218 package, 15W,
greased interface,
Rjc = 0.6˚C/W (typ. value)

box is zinc alloy 903,
4 mm wall thickness,
white paint surface,
top cover not shown

natural cooling @25C
fins: 20 long, 10 centerline, 2 thick

dimensions in mmX
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Figure 2-19: Box for first section of exercise

Modeling assumptions

For the models in this exercise, you will not be incorporating convection and radiation inside
the box.  This is a reasonable approach when the box is made of metal and all heat sources are
mounted directly to metal surfaces.  On the other hand, for plastic boxes, boxes with heat
sources on circuit boards, etc., internal convection and radiation are extremely important and
cannot be neglected.

In a later exercise, Introductory Exercise 6: Multi-Plate Box With Internal Board, you will have the
opportunity to model internal convection and radiation.  Also, at the end of that exercise, you
will be able to test the "no internal convection/radiation" assumption just made.

Creating the box

Start by switching to a perspective view:

click  
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Begin creating the box with these commands:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Box

You will reach the Box menu:

   BOX
>1 Multi-Plate
 2 Encl Assy

Sauna gives you two different ways to model a box.  You will be using “Multi-Plate”, the
recommended approach,  The second choice, "Encl Assy", is an older approach which is only
maintained to provide compatibility with earlier versions of Sauna.  In fact, “Encl Assy” will be
discontinued in the future.

The multi-plate method is straightforward.  You will provide the overall dimensions for the
box.  Sauna will then create 6 plate assemblies which are joined together at the edges.  Once the
box is created, you can edit any of the walls with the same commands used earlier for editing
plates.

Continue with:

Multi-Plate ➔ "150,50,150" ➔ (0,0,0) ➔ Uniform ➔ "4"

You will reach the Inside Box menu, which asks you to choose between “Mainly Horz” and
“Mainly Vert”.  To understand the choices, you need to view the reference picture:

click  Picture

This reference picture will be displayed:

Figure 2-20: "Mainly Horz"and “Mainly Vert” options

Sauna provides two options for constructing the corners of the box.  Most of the time you
should choose “Mainly Horz” (mainly horizontal.)  The “Mainly Vert” option is sometimes
used when the box has internal boards in the Vertical YZ plane.
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Clear the picture from the screen, then complete creating the box with:

Mainly Horz ➔ Other Metal ➔ Zn SAE 903 ➔ Paint/White ➔ Paint/White

The multi-plate box will be created.  You can also view the box in shade mode:

click  

It’s quite easy to create a box model with Sauna.

Changing the display setup for nodes and resistors

Switch back to wireframe mode and switch to abbreviated node and resistor symbols:

click  

<F6 Setup> ➔ Display ➔ Symbols ➔ Abbreviated

For complex models the abbreviated symbols improve screen clarity.  Also, the abbreviated
symbols reduce the time needed to regenerate the screen.  Note that you can also switch to
abbreviated symbols with the  button.

Many users choose to use the abbreviated symbols all the time.  If you want to make this choice
permanent, you just need to save the current setup with <F6 Setup> ➔ Save Setup.

Visibility for multi-plate boxes - overview

There are lots of nodes and resistors on the screen.  When working with a complex 3D thermal
model, you will need Sauna's Visibility commands to simplify the screen representation.  This is
usually done by making certain assemblies invisible.  It's important that you become comfort-
able modifying visibility.  If you don't, you will find working with 3D models quite tedious.

Fortunately, Sauna offers several different way to make assemblies either visible or invisible.
Actually, there are four basic approaches: “ordinary grouping in wireframe mode”, “grouping
with assembly labels”, “click surface visibility” and “visibility by plane”.  Each of these
approaches is important and is discussed below.

Visibility by ordinary grouping in wireframe mode

This approach is similar to what you have done in earlier exercises.  You should be in
wireframe mode in a perspective view.  Turn off the front wall of the box with:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Plate
➔ Select 1 ➔ trap (click) edge of front plate ➔ USE

The front plate will be turned off.  To see this clearly, switch to shade mode:

click  

Turning off an assembly this way is easy.  But you do need to know Sauna’s rules for an
“ambiguous trap”.  An ambiguous trap occurs when the trap box intersects the edges of two or
more assemblies.  To handle these situations, Sauna uses a 3D trapping priority.  The general
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rule is: “trap the assembly which is closest to the viewer”.  (Assemblies are sorted based on the
midpoint coordinate of the assembly.)  This simple rule works well in perspective views.  In an
orthogonal view, however, it’s fairly common to have assemblies which are side-by-side, so that
the assemblies are equidistant from the viewer.  In this case,  trap the left or lower edge of the
assembly you wish to select (use <F11 Help> ➔ Ref Picts ➔ Basics ➔ Trap Assy to view a
reference picture, also see the back cover of the Sauna User Manual).

To illustrate the 3D trapping priority, return to a front view and turn on all elements:

click  Front  ➔ click  

The graphics window will appear as shown in Figure 2-21.  As the figure shows, several of the
thick dashed lines for assembly edges are shared between multiple assemblies.  So, if you
attempt to trap an assembly by clicking on the upper edge of the box, the trap box would be
valid for three different assemblies: the front wall, the back wall and the top cover.  But with the
3D trapping priority, you are sure to trap the front wall, because this is the assembly which is
closest to you.  (If you are a bit confused by which edge belongs to which assembly, look at
Figure 2-20, “Mainly Horz” option.)

upper edge of front wall, back wall, top cover

lower edge of top cover

inside edge of right wall

lower edge of front wall, back wall, bottom cover

edge of front wall, back wall, right wall

X

Y

Figure 2-21: In a box model, several edges are shared

Let’s perform a test:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Plate ➔ Select 1
➔ click upper edge at location shown by arrow in Figure 2-21 ➔ USE

The front wall will be turned off.  But the screen image looks exactly the same.  In a front
orthogonal view, the front wall and the back wall have the same edges.  To verify that the front
wall was indeed turned off, activate shade mode:

click  
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Since the front wall has been turned off, you can now see the internal edges of the side walls
and covers.  To really make it clear that the front wall has been turned off, switch views:

click  

Now it’s perfectly clear that the front wall is turned off.  As you get used to working with
orthogonal views, it won’t be necessary to switch views to verify that the proper assembly was
turned off.

For some persons, it will take a while to get accustomed to Sauna’s orthogonal views.  If
necessary, spend some time reviewing Figure 2-21 (also “Mainly Horz” in Figure 2-20) and it
should become clear which edges belong to which assemblies.

Return to a front orthogonal view and reset visibility:

click  Front  ➔ click  

When you use grouping to modify visibility, you should also be able to use “Select Regn”.
“Select Regn” is extremely important because you can quickly and precisely select several
assemblies.  Although beginning users tend to prefer “Select 1”, one-by-one trapping of
assemblies is slow and frequently inaccurate.

As a quick test, you will modify visibility using the grouping rectangle shown in Figure 2-22.
Before starting, take a moment to decide which assemblies will remain visible.  Remember that
an assembly will be selected if the grouping rectangle intersects (overlaps) any edge of the
assembly.  It isn’t necessary that the grouping rectangle completely enclose an assembly.

Use this grouping rectangle
Which assemblies will remain visible?

X

Y

Figure 2-22: Use this grouping rectangle

Now modify visibility:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Plate ➔ Select Regn
➔ digitize point (see Fig. 2-22) ➔ digitize point ➔ USE

If done properly, three assemblies will be visible: the top cover, the bottom cover and the right
wall.
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If all of this appears logical, you should continue on with the next section.  However, if you are
unsure why certain assemblies were turned off, you need to do some further experimentation.
Turn on all assemblies with .  Then do some further tests with turning off assemblies.  It’s
very important that you understand how to select multiple assemblies with “Select Regn”.  If
you don’t grasp this, you will have trouble with the what-if problems later in the exercise.

Visibility by grouping with assembly labels

Start by turning on all assemblies:

click  

Suppose that you’re in a front, orthogonal view and need to turn off the back wall.  If you use
grouping, Sauna will trap the front wall, not the back wall.  One solution is to switch to a back
view and then perform the trap.  But there’s an easier way.  You can use assembly labels for
trapping.  Any time that you use “Select 1”, you can type in an assembly label instead of
clicking with the mouse.

Of course, if you are going to use an assembly label, you need to know which labels are
currently used.  Sauna provides a useful report for checking assembly labels:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

The report gives the assembly labels and overall dimensions for each assembly in the model.
As shown in the report, Sauna always uses these assembly labels for multi-plate boxes: “Back”,
“Bottom”, “Front”, “Left”, “Right”, “Top”.  Clear the report before continuing.

Let’s use an assembly label to turn off the back wall:

click  

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Plate ➔ Select 1 ➔ “Back” ➔ USE

The back wall will be turned off.  Actually, you don’t even have to type the entire label, you can
use the wildcard symbol (∗).  Try this:

Select 1 ➔ “f∗∗∗∗” ➔ USE

The front wall will be turned off.  Trapping with assembly labels works quite well for multi-
plate boxes.  You just need to be aware of the assembly labels.  (Note: selection with a label is
case insensitive, so “FRONT”, “front”, “F∗” all work.)

Besides “turn off”, Sauna also lets you isolate an assembly (or assemblies).  In this situation, you
choose the assembly which remains visible, while all other assemblies are turned off.  Isolate
the bottom cover with:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only ➔ Plate
➔ Select 1 ➔ “bottom” ➔ USE

Just the bottom cover will be visible.  The Isolate command is quite useful, you will use it often.

For additional details on trapping with an assembly label, see Understanding Assembly Labels
And Layers in the Using Sauna chapter.
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Click surface visibility

Once again, turn on all elements:
click  

Now let’s try “click surface” visibility.  Turn off the top cover with:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Click Surf
➔ click anywhere on the top cover

“Click Surf” is easy and wonderfully intuitive.  You don’t have to remember to click on the
edges, just click anywhere on the surface of the assembly.  You don’t even have to remember to
switch into shade mode.  It’s done for you automatically.

You can also use “Click Surf” when isolating assemblies.  Isolate the back wall with:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only ➔ Click Surf
➔ click anywhere on the back wall

While “Click Surf” is certainly useful, don’t become overly dependent on it.  “Click Surf” works
well for simple models but becomes tedious for complex models because you will have to click
on surfaces several times in a row.  For complex models, the methods described above
(wireframe grouping and trapping with assembly labels) are actually more useful.

Visibility by plane

Finally, it is easy to turn assemblies on or off by using the planes of the assemblies.  Enter the
following:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Check Box ➔ click “XY Plane” for plates
➔ click OK button

Only XY plates (“Front” and “Back”) will be visible.  The Isolate ➔ Check Box command is very
useful.

As you’ve seen, Sauna provides a number of ways to modify visibility.  Initially, you are sure to
prefer “Click Surf”.   But experienced users take advantage of all four methods for changing
visibility.  In particular, wireframe grouping in an orthogonal view is used very frequently.

Adding fins and heat sources

Now that you understand the different options for modifying visibility, it’s time to add fins to
the back wall.  Isolate the back wall with:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only ➔ Plate
➔ Select 1 ➔ “back” ➔ USE

click  
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When you add fins, you will need to choose between the component and secondary sides.  If
you look at the screen, you will see that the back of the plate is the secondary side.  Put another
way, the outer surface of the plate is the secondary side.  If the other assemblies were visible,
you would see that the outer surface is the secondary side for all of the plates making up the box.
Sauna assigns sides this way to make editing easier.  You just need to remember that, for a
multi-plate box, the secondary side is always the outer side.

Add fins with:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ New Fins
➔ "20,10,2" ➔ Secondary ➔ All In Wind ➔ USE

Next, place the two heat sources (use typical Rjc):

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "15" ➔ "Left" ➔ TO-218 ➔ Typical
➔ Standard ➔ Greased ➔ One ➔ trap the plate ➔ Ref/Dx-Dy-Dz

➔ trap front-lower-left corner ➔ "25,25"

Basic Source ➔ "15" ➔ "Right" ➔ TO-218 ➔ Typical ➔ Standard ➔ Greased ➔ One
➔ trap the plate ➔ Ref/Dx-Dy-Dz ➔ trap front-lower-right corner ➔ "-25,25"

The two heat sources will be created.  If you look at the screen, there are only 2 case-to-sink
resistors for each power transistor, less than the preferred 4 resistors.  In earlier exercises, you
used the “align to heat source” method to obtain 4 case-to-sink resistors   But since there are 2
power transistors, you would need to slice, which you haven’t learned yet.  So, instead, use the
Remesh command to double the node spacing:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align
➔ Both Axes ➔ Finer 2x ➔ All In Wind ➔ USE

After remeshing, there will be 4 case-to-sink resistors for each source.  The “align to heat
source” method is usually best, but there are other ways to obtain the necessary number of
case-to-sink resistors.  To learn about slicing and aligning to two heat sources, see Intermediate
Exercise 1: Superassemblies And Basic Slicing.

Connecting to ambient

Now that the back plate has been modified, all that remains is to create ambient nodes and float
resistors.  Since the secondary side is always the outer side, all the connections to ambient can
be made with a single command.  Start by restoring visibility:

click   ➔ click  

Create fixed temperature ambient nodes and float resistors with:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd-›Fix ➔ "Room Amb"
➔ Natural ➔ Secondary ➔ All In Wind ➔ USE

Six ambient nodes and 544 resistors will be created.  Make the ambient nodes invisible:

click  
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Calculating temperatures and remeshing

Now you are ready to calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the calculation is complete, you should obtain TLeft-junct = TRight-junct = 77.79°C.

Now you will try using fewer nodes and resistors in the front of the box.    This is easily
accomplished with Sauna's "remesh" command.  It will be interesting to see how a coarser mesh
impacts temperatures.

The next step in the exercise will be to use a coarser node spacing for all assemblies except the
back plate.   Then you will recalculate temperatures.  Begin by turning on fixed nodes and
switching to a top, orthogonal view:

click   ➔ click  Top

Remesh the front 5 plates with (see Figure 2-23):

 <F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Both Axes ➔ Coarser 4x
➔ Select Regn ➔ use grouping rectangle in Figure 2-23 ➔ USE

Sauna will remesh the 5 plates.  Remesh is a very useful command.  All edge joins were
recreated automatically and all connections to ambient were maintained.  Notice how easy it
was to select the 5 plates with a single “Select Regn”.

When you chose "Coarser 4x", Sauna doubles the node spacing for all plates in the group.  By
doubling the node spacing, the number of nodes in each plate is reduced by a factor of 4.

Left

68.79
77.79

Right

68.79
77.79

Room Amb

25.00

Room Amb

25.00

Room Amb

25.00

Room Amb

25.00

Room Amb

25.00

grouping
rectangle

X

Z

Steady State

Figure 2-23: Use this grouping rectangle
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Recalculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

The calculation will be quicker.  The power transistor junction temperature will be 77.86°C, as
opposed to 77.79°C obtained earlier.  Clearly, remeshing had only a very minor impact on
temperatures.

As a general rule in thermal modeling, you need a fine mesh around heat sources.  Elsewhere,
a coarse mesh can be quite sufficient.

Saving the model

In later exercises, you will be using the model that you just created.  Before going further, save
the model as "new_box":

<F12 Root Menu> ➔ File ➔ Save As ➔ type "new_box" in File name box ➔ click Save button

Remesh what-if

Above, when you remeshed the five plates in the front of the box, you used “Select Regn” in a
top orthogonal view (Figure 2-23).  The use of “Select Regn” in an orthogonal view is strongly
recommended.  All too often, beginners like to work in perspective views and use one-by-one
clicking on assemblies.  This can lead to problems when more complex models are encountered.
So the purpose of this simple what-if manipulation is to gain a little more practice with the use
of grouping regions in orthogonal views.

You should still be in a top orthogonal view and you should stay in a top orthogonal view
throughout this what-if section.

As the first part of the what-if, use Remesh to return the front five assemblies to the default
node spacing.  Then calculate temperatures.  As before, you should obtain junction
temperatures of 77.79°C.

Now, use “Coarser 4x” to remesh these three assemblies: left wall, bottom cover, and top cover.
These assemblies can be added to the group with a single “Select Regn”.  After remeshing,
calculate temperatures.  You should obtain TLeft-junct = 77.85°C and TRight-junct = 77.78°C.
You must obtain exactly these temperatures.  If not, you have made an error and need to try
again.  If you’re having problems, review Figure 2-22 and the associated description.

Now, one more time, return the front five assemblies to the default node spacing and
recalculate temperatures.  As always, you should obtain junction temperatures of 77.79°C.

Finally, you will use “Coarser 4x” to remesh the top cover, left wall, right wall and front wall,
but not the bottom cover.  Begin by placing the front five assemblies in the group but don’t
choose “USE”.  Then choose “Unselect 1” and enter an assembly label to remove the bottom
cover from the group.  Now you can choose “USE” to complete the remesh.  Recalculate
temperatures.  You should obtain Tjunction = 77.81°C for both heat sources.  Once again, if you
don’t obtain exactly this temperature, you have made an error and need to try again.  Do not
continue on with the exercise until you successfully obtain Tjunction = 77.81°C.
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Evaluating an alternative design

Now you will model the box shown in Figure 2-24.  This box is a modified version of the box
that you just modeled.  The fins are on the sides rather than the back plate.  However, the total
fin surface area is unchanged.  The same power transistors are also used, but they are now
mounted on a horizontal shelf.  You may want to make a guess as to whether this design will be
cooler or hotter than the design that you just evaluated.

25

25 from inside edge  for
both transistors

For both sides, fin  length = 10,
centerline dist. = 10,  thickness = 2

15W power transistors
mounted on horizontal shelf

8

21

Figure 2-24: Alternative design for box

Begin the second part of the exercise by removing fins from the back wall:

click   ➔ click  

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ Remove Fins
➔ Secondary ➔ Select 1 ➔ "back" ➔ USE

Since we will be moving the heat sources to the horizontal shelf, we no longer need a fine node
spacing on the back plate.  However, the current node spacing is a bit coarse if we plan to
connect to the middle of the side walls.  Change the node spacing for the entire box to 16:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Both Axes
➔ Enter Value ➔ "16" ➔ All In Wind ➔ USE
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Creating the horizontal shelf with "Plate In Box"

Now it's time to create the horizontal shelf.  Just as Sauna has a special command for creating a
box, Sauna also has special commands that make it easy to create the plates and boards inside
the box.

Begin as follows:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Plate In Box ➔ "Shelf"

You will reach the Plate In Box menu:

  PLATE IN BOX
>1 Calc/No Gap
 2 Calc/Gap
 3 Enter Dimen

The basic approach with "Plate In Box" is to define certain plate properties (thickness, reference
coordinate, material, surface) and then to place in the group the assemblies making up the box.
Sauna will create a new plate which fits inside the box.

Most commonly, you will choose "Calc/No Gap".  With "Calc/No Gap", Sauna will create a
plate which fits perfectly inside the box assemblies.  The other two possibilities, "Calc/Gap" and
"Enter Dimen", let you leave a uniform gap between the new plate and the walls of the box.

For the current model you should choose "Calc/No Gap":

Calc/No Gap ➔ "8" ➔ Horizontal

Now you must specify a coordinate in the Y-direction to define the vertical position of the shelf.
Since Figure 2-24 gives the dimensions to the bottom of the shelf, enter these commands to
finish creating the shelf:

Minimum ➔ "21" ➔ Other Metal ➔ Zn SAE 903 ➔ Paint/White
➔ Join ➔ Zero Resis ➔ All In Wind ➔ USE

The shelf will be created and joined to the side walls of the box.  The Plate In Box command
uses a number of menus, but it is very powerful and greatly reduces the chance of error.

To get a clear look at the newly created shelf, modify visibility as follows:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Click Surf ➔ click on top cover
➔ Click Surf ➔ click on front wall

Moving heat sources to the shelf

For the next few modifications, you only want to have the shelf and the back wall visible.  You
can easily achieve this with:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only ➔ Plate
➔ Select 1 ➔ “shelf” ➔ Select 1 ➔ “back” ➔ USE
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Since you will have heat sources on the shelf, change to a finer node spacing:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Both Axes ➔ Finer 2x
➔ place shelf in group (see comment in next paragraph) ➔ USE

To remesh the shelf, you were instructed to “place shelf in group” rather than the exact
command (Select 1 ➔ trap the Shelf or Select 1 ➔ “shelf”, etc.).  It is assumed that  grouping is
becoming routine.  You can now choose for yourself the appropriate grouping option.

Prior to shifting the heat sources, switch to a top view:

click  Top

Now you are ready to shift the heat sources.  For the left source, begin with:

<F12 Root Menu> ➔ Edit ➔ Heat Input ➔ Basic Source ➔ Shift ➔ trap left heat source
 ➔ Trap Assy ➔ trap shelf ➔ Ref/Dx-Dy-Dz

For the reference point, you need to trap the back left corner of the horizontal shelf.  However,
you must be careful not to inadvertently trap the back plate.  Trap as shown in Figure 2-25 and
Sauna will "snap" to the back corner of the assembly:

    

Left Right

trap here for
reference point

X

Z

Figure 2-25: reference point for shifting left heat source

Finish shifting the left heat source with:

trap back-left corner ➔ "25,,25"

The heat source will be moved to the shelf.  Note that “25,,25” is equivalent to “25,0,25”.  Now
shift the right heat source:

Shift ➔ trap right heat source ➔ Trap Assy ➔ trap shelf  ➔ Ref/Dx-Dy-Dz
➔ trap back-right corner ➔ "−−−−25,,25"

Verify that the heat sources were successfully moved to the shelf:

<F7 Info> ➔ Heat Load ➔ Input ➔ With Supers ➔ Screen

After confirming that the heat sources are on the shelf assembly, clear the report.
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Adding fins

Isolate the side walls and add fins:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only  ➔ By Plane
➔ Any Assy ➔ Vertical YZ

click  

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ New Fins
➔ "10,10,2" ➔ Secondary ➔ All In Wind ➔ USE

Now that the fins have been added, you need to turn on all assemblies while keeping fixed
nodes turned off.  You can do this with the  button which is normally used to turn off fixed
nodes.  However, the button is actually the equivalent of Visibility ➔ Turn On ➔ All/No Fix, so it
can be used to turn on all assemblies, while fixed nodes stay invisible.  Use the button now:

click  

Calculating temperatures

Now you can calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the calculation has been completed, you will obtain junction temperatures of 74.51°C.
Previously, the junction temperatures were 77.86°C.  You may be surprised that temperatures
for the power transistors actually decreased even though the transistors are no longer directly
mounted to a heat sink.  There are two explanations.  First, all surfaces of the box dissipate heat,
not just the finned surfaces.  The horizontal shelf reduces the total thermal resistance between
the heat sources and the six dissipating surfaces of the box.  Second, an appreciable portion of
the total temperature rise for a heat source occurs in the immediate vicinity of the source.  The
shelf is thicker than the back plate, 8 mm vs. 4 mm, and this reduces the temperature gradient
around the sources.

What-if modification #1: moving the shelf downward

As the first modification, you will move the shelf downward by 11 mm.

Try to move the shelf:

<F12 Root Menu> ➔ Move/Copy ➔ Move ➔ Trap 1 Assy ➔ trap the shelf ➔ Dy ➔ "-11"

The Move will not be allowed.  These messages will be displayed:

Join Rth between assy in group and assy not in group
-› Move/Copy aborts: invalid combination of elements

These messages are only displayed for a few seconds before being cleared.  (The messages are
cleared to make room for the final message: “Node temperatures and float resistors cleared.”)
To see the messages again, try to move the shelf downward a second time.
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To move the shelf, Sauna would have to break the joins between the side walls and the shelf.
This is not allowed, so that important portions of the model are not accidentally deleted.  So,
before moving, you must delete the joins between the shelf and the rest of the model.  Then you
will be able to move the shelf downward.  When the shelf is in the proper position it can be re-
joined to the side walls.

When deleting the resistors between the side walls and the shelf, you must take care to not
delete any joins between the front wall and the left wall, the front wall and the right wall, etc.
Sauna has a special command for this, the "Grp To Model" delete of assembly joins.  You will be
placing the shelf in group.  Sauna will then delete all joins between the shelf and the rest of the
model.  All other joins will be left intact.

Delete the joins:

<F12 Root Menu> ➔ Delete ➔ Join ➔ Edge ➔ Grp To Model
➔ Plate ➔ place shelf in group ➔ USE

The joins between the shelf and side walls will be deleted.  Sauna will also display this message:

4 joins were deleted

For the current problem, you placed a single assembly in the group.  However, it's certainly
possible to use "Grp To Model" with several assemblies.  In this case, Sauna will retain the joins
between members of the group, while deleting joins between the group and other assemblies in
the model.

Now that the necessary joins have been deleted, move the shelf downward:

<F12 Root Menu> ➔ Move/Copy ➔ Move ➔ Trap 1 Assy ➔ trap the shelf ➔ Dy ➔ "-11"

Now let's calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

Oops again!  Sauna will beep at you and display this message:

Invalid model: node without path to ambient

Since all heat in the thermal model must eventually flow to a fixed node, every general or heat
source node must have a resistor path to a fixed node.  This is not the case for the current model
because no connections were made between the shelf and the outer walls of the box.  In other
words, you need to re-join the shelf to the side walls.  For more information on this error
message, use Help ➔ Errors Help.

To reconnect, you can use "Grp To Model" one more time:

<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Zero Resis
➔ Grp To Model ➔ place shelf in group ➔ USE

Sauna will indicate that 4 joins were created.  Now you're ready to calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain junction temperatures of 74.40°C, a slight increase.  This is due to the fact
that the heat input is now closer to the bottom surface and the bottom surface has a lower heat
transfer coefficient because if faces down.  Overall, though, temperatures are only slightly
impacted by moving the shelf down.
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Saving the model

You will need the current model for upcoming exercises.  Before saving, however, check to see
how many nodes and resistors are in the model:

<F7 Info> ➔ Node/Resis ➔ Numb Nd/Rth ➔ Screen

The report will tell you that there are 567 nodes and 1594 resistors in the model.  On your hard
disk, this model will take up about 600 Kbytes.  Larger models can easily be 5 Mbytes in size.

After clearing the report, save the model:

<F12 Root Menu> ➔ File ➔ Save As ➔ type "new_shelf" in File name box ➔ click Save button

What-if #2: adding a center wall

Now you will add a center wall as shown in Figure 2-26:

Left Right

Center wall, 4 mm thick

X

Y

Figure 2-26: adding a center wall

With the Plate In Box command, it is easy to add a center wall.  You have already used “Plate In
Box” on page 2-52.  As before, you will use the same material and surface properties as for the
rest of the box.  Of course, you will need to specify “YZ Plane” for the center wall and use the
specified plate thickness of 4 mm.  At the X-Coord menu, you should choose "Centerline" and
enter "75" (the new wall is at the exact center of the box).

You should work in a front orthogonal view.  When you reach the grouping menu, you will
need to put these four assemblies in the group:  the front wall, back wall, shelf and top cover.
(The grouping menu limits you to assemblies in the XY and horizontal planes.)  Sauna will use
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these four assemblies to calculate the dimensions of the center wall.  Do not place the bottom
cover in the group.  If the bottom cover is in the group, Sauna won’t be able to determine if the
center wall should go between the shelf and the top cover or between the shelf and the bottom
cover.  In a front view, you can select the four assemblies with a single “Select Regn”.  This is
the preferred approach, but there are other ways to put the assemblies in the group.  But, once
again, do not put the bottom cover in the group.

Go ahead and add the center wall to the box (refer to page 2-52 if necessary).  If you experience
difficulties, pay careful attention to the error messages in the prompt zone.  The usual problem
is either too many assemblies in the group (an inappropriate “All In Wind”) or not enough
assemblies in the group (“XY plane: only 1 usable assembly in group”, etc.).  For continuing
problems, please see Using "Plate In Box" And "Board In Box" Successfully in the Using Sauna
chapter.  You can also look up the error messages with Help ➔ Errors Help.

Calculate temperatures.  You should obtain TLeft-junct = TRight-junct = 74.04°C, a slight reduction.
The extra metal in the center wall reduces temperature gradients within the box.

What-if #3, a smaller shelf

Now that you've seen how easy it is to add a center wall, delete the wall:

<F12 Root Menu> ➔ Delete ➔ Assembly ➔ Plate ➔ place center wall in group ➔ USE

Recalculate temperatures and, once again, you should obtain TLeft-junct = TRight-junct = 74.40°C.

The shelf design reduced temperatures.  However, it's a fairly expensive approach because of
the extra material required for the shelf.

As the third what-if modification, cut the size of the shelf in half.  Use Edit ➔ Plate/Board ➔
Dimensions to change the depth of the shelf to 71 mm.  You should retain the back half, which
means you must make the proper selection on the Keep Point menu.  If necessary, click  Picture

to view the reference picture.  Note that when the depth of the shelf is modified, Sauna will
have to break the join between the front wall and the shelf.

After the modification, get an Info report to make sure that the shelf is still joined to the proper
side walls.

When you recalculate temperatures, you should obtain TLeft-junct = TRight-junct = 76.51°C.  This is a
fairly modest 2.1°C increase.  If cutting costs were important, reducing the size of the shelf
would be a good approach.

What-if #4, a thinner shelf

A way to further reduce the cost of the box would be to make the shelf thinner.

Reduce the thickness of the shelf from 8 mm to 4 mm while keeping the same bottom
dimension.  After modifying the shelf thickness, recalculate temperatures.

With the thinner shelf, you will obtain TLeft-junct = TRight-junct = 82.73°C.  This is a bigger increase
of 6.2°C.  Clearly, the thickness of the metal directly under the transistors has an impact on
thermal performance.
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What-if #5, a smaller box

For the final modification, you will shorten the overall depth of the box to 140 mm.  The shelf
size will be unchanged.

As a first step, switch to a top orthogonal view.

Use Edit ➔ Plate/Board ➔ Dimensions to modify the left, right, bottom and top walls.  You will
want to reduce the Z-dimension by 10 mm while maintaining the same "End" point.  Changing
the Z-dimension this way will cause the joins to be broken with the front plate.  So you will
have to move the front wall and join it to the appropriate plates.

The new Tjunction will be 83.54°C.  If you don't get this temperature, use the reports to verify that
all assemblies have been properly joined together.

Wrapping up

This exercise is now complete.  Delete everything with:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

In Introductory Exercise 6: Multi-Plate Box With Internal Board you will model a multi-plate box
with circuit board and internal ambients.
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