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   Intermediate Exercise 3: More On Circuit Board Modeling

This exercise builds on the material presented in Introductory Exercise 5: Basics Of Circuit Board
Modeling.  You will start by learning the method for obtaining the junction-to-lead-pad thermal
resistance, starting from the junction-to-ambient resistance found on datasheets.  As you will
see, once the correct Rjunction-to-lead-pad has been obtained, you will obtain an accurate match with
published data for a variety of cooling conditions and board configurations.

After that, you will learn the method for aligning to multiple enhanced heat sources on a board
stackup.  The method is similar to what you learned in Intermediate Exercise 1: Superassemblies
And Basic Slicing, but there are some additional techniques for board stackups.

Then you will move on to the modeling of a flip chip device, first without a heat sink, then with
a heat sink on the top of the component.

After this, you will learn the method for modifying the internal planes of a board stackup.
Sauna lets you have individual traces and pads on internal layers, just as for outer layers.
Finally, you will learn several different methods for modeling components which are not found
in Sauna's libraries.

You can use the Sauna Evaluation Package to work the first part of the exercise (up through page 3-35).

Prerequisites

Before starting this exercise, you should have worked all of the introductory exercises.  It is
essential that you master the material in Introductory Exercise 5: Basics Of Circuit Board Modeling.
You should also work Intermediate Exercise 1: Superassemblies And Basic Slicing.

Obtaining Rjunction-to-lead-pad from Rjunction-to-ambient

In Introductory Exercise 5: Basics Of Circuit Board Modeling you created four different enhanced
heat sources.  Each time, you made use of the R_Lead_Pad menu:

  R_LEAD_PAD
>1 Typ-1500 C/W
 2 Enter Resis
 3 Enter R_para
 4 No Lead Conn

With this menu, you are specifying the thermal resistance between the enhanced source node,
which represents the junction of the device, and individual lead pads on the circuit board.  You
have been using the typical value of 1500 °C/W, which is a good starting point.  But it's better to
use a more precise value.

The problem is that Rjunction-to-lead-pad is not usually found on datasheets.  However, the
datasheet should show Rjunction-to-ambient.  It's not always called Rjunction-to-ambient, it may be
referred to as Rja or θjunction-to-ambient or θja or Rθ-ja.  But these are all the same thing, it's the
overall thermal resistance between the device junction temperature and the room environment
under a specified set of test conditions.

For the remainder of the exercise, Rja and Rlead-pad will be used for Rjunction-to-ambient  and
Rjunction-to-lead-pad.
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JEDEC test boards

The Rja from a datasheet only applies for a particular test board.  Most of the time, the datasheet
will indicate the test board.  You might see something like "single layer JEDEC board" or
"JEDEC 51-7 board" or "multilayer JEDEC board with vias".  The keyword here is JEDEC, for the
standardization organization.  JEDEC has published several standards which define thermal
test boards.  For surface mount components like QFP's and QFN's, there are three key
documents covering test boards:

JEDEC JESD51-3 Low Effective Thermal Conductivity Board (1S0P).  This board has only
a single copper layer.  The copper weight is 2 ounce.  For component body sizes of 27 mm or
less, the board will be as shown in Figure 3-12.  From a thermal standpoint, it's the trace
flareout of at least 25 mm (1") which is of importance.  The board is larger to allow for
power, ground and other connections to be made through an edge guide.  It is assumed,
with reason, that traces outside the 25 mm flareout have little or no impact on thermal
characteristics.  Note that the designation "1S0P" refers to 1 signal layer, 0 buried planes.

JEDEC JESD51-7 High Effective Thermal Conductivity Board (1S2P).  This board includes
the 2 ounce trace flareout shown in Figure 3-12, but adds two internal copper planes.  The
internal planes are 1 ounce copper, unlike the outer layer which is 2 ounce copper.  The
designation "1S2P" refers to 1 signal layer, 2 buried planes.  Note that this board does not
have thermal vias.

76.2 mm = 3.0"

114.3 mm

trace flareout of
at least 25 mm

trace width = 0.25 mm (0.010")
weight = 2 ounce

X

Z

Figure 3-12: JEDEC 51-3 board for components <= 27 mm
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JEDEC JESD51-5 Extension of Thermal Test Board Standards for Packages with Direct
Thermal Attachment Mechanisms (1S2P + Vias).  This standard covers a test board for a
component with heat slug (external copper pad directly soldered to board).  This is simply
the 51-7 test board with thermal vias.  The vias are only under the heat slug and the via
density is quite high (440 vias/inch2).  The vias are connected to the first buried plane only
(actually the standard is slightly ambiguous about this).

Most of the time, the datasheet will make it clear which JEDEC board was used.  For a package
with heat slug, it is expected that the test board would conform to JEDEC 51-5 (1S2P + vias)  For
non-slug devices, it could be either 51-3 or 51-7, but it seems likely that a manufacturer would
choose 51-7, because this provides a lower Rja, which provides a better specification number for
the datasheet.

For more information on the JEDEC standards, there is an excellent paper (TB379.3) from
Intersil Corporation available at www.intersil.com/data/tb/tb379.pdf.  And you can download
the full JEDEC standards for free at www.jedec.org (registration required).

Example problem: obtain Rlead-pad for Amkor 14 mm LQFP package

Now you will learn the method for obtaining Rlead-pad.  You will be working with a 100 lead
LQFP (low profile quad flatpack) device from Amkor Technology.  The body size is 14 mm x
14 mm.  Amkor Technology is a prominent manufacturer of integrated circuit packages used by
a variety of chip manufacturers.  They have a good reputation for providing complete and
accurate thermal data for their packages.

Here is the Amkor thermal data for the 100 lead LQFP package (1 watt dissipation):

Test board Diepad size (mm) Rja natural Rja 200 fpm Rja 500 fpm

Single layer 8 x 8 41.5°C/W 33.4°C/W 29.5°C/W
(JEDEC 51-3)

Multilayer 8 x 8 31.7 26.8 24.7
(JEDEC 51-7)

Multilayer with vias 10.3 x 10.3 20.6 15.3 13.4
(JEDEC 51-5)   heat slug

Table 3-1: Amkor thermal data for 14 x 14 LQFP (1 watt)

For the purposes of obtaining thermal resistances, you only need to model the portion of the test
board with the flareout.  Note that the standards call for the board to be in the horizontal plane
with the component placed on top.

Begin by creating a 76.2 mm x 76.2 mm (3” x 3”) board assembly:

click  Top

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Circuit Brd ➔ hit <Enter> to skip ➔ Rectangle
➔ Horizontal ➔ "76.2,76.2" ➔ .062"/1.57mm ➔ (0,0,0) ➔ FR4 ➔ Zer/Lam Only

➔ Enter mm ➔ ".23" ➔ One oz. ➔ None

The board assembly will be created.
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Note that you used a special via diameter of 0.23 mm (after plating).  This is the via diameter
specified by JEDEC 51-5.  This, of course, has no impact on the single layer board analysis, but
will be used later when you define vias.

Next, you will add a 25 mm flareout pattern.  This is easy to do because the 14 x 14, 100 lead
LQFP package is in Sauna's standard library.  Remember that the JEDEC spec requires two
ounce copper.  Create the trace flareout:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ trap board ➔ Component
➔ Two oz. ➔ Pad Library ➔ Quad ➔ LQFP ➔ 14 x 14 ➔ 100 Leads ➔ Detail/Flare

➔ 25 mm/1.0” ➔ No ➔ Coords/Trap ➔ "38.1,0,-38.1"

The trace pattern will be created.  Get an Info report for one of the flared traces:

<F7 Info> ➔ Trap ➔ Plate ➔ trap flared trace

Under "-- Trace/Pad Properties --", you should verify that the copper weight is 2 ounces.  Also,
be sure to check the trace width.  The trace width must be 0.25 mm (0.010"), per the
specifications.

Clear the report and add the LQFP component:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ Quad ➔ "1" ➔ "S1" ➔ LQFP
➔ 14 x 14 ➔ 100 Leads ➔ Middle ➔ Specify ➔ "8,8,.3" ➔ Centered ➔ Typ (0.1 mm)

➔ Typ-1500 C/W ➔ Ref Point ➔ trap reference point at center of pattern

The enhanced source will be created.  Align the mesh to the heat source:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ trap S1 heat source ➔ All In Wind ➔ USE

Sauna will indicate that “aligned nodes for 201 assemblies”.  Add float resistors with the "Enter
Later" option:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Enter Later
➔ Both Sides ➔ All In Wind ➔ USE

click  

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain TS1 = 63.26°C.  Since TS1 is a junction temperature and you are using 1 watt,
you are ready to calculate Rja:

Rja = (63.26 - 25) / 1 = 38.26°C/W

From the table above, the published value for Rja is 41.5°C/W.  Thus, Rja-Sauna is off by -7.8%.
This is not a large error, but it does makes sense to adjust the Rlead-pad to more closely match the
published data.
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You created the S1 source with Rlead-pad with 1500°C/W, so you should try a larger value.  Edit
Rlead-pad to 2000°C/W:

<F12 Root Menu> ➔ Edit ➔ Resistor ➔ Constant ➔ Enhan->Pad ➔ trap S1 source node
➔ Enter Resis ➔ "2000" ➔ Lead Pads ➔ All In Wind ➔ USE

Sauna will indicate that "edited enhanced-to-pad resistors for 100 lead pads".  Notice that when
you used "All In Wind", only the 100 lead pads were selected (not the traces in the flareout).
Lead pads are a special class of assemblies, as explained in "Understanding the rules for lead
pads", later in the exercise.

Verify the modification with an Info report:

<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ trap S1 source

On the second page of the report, you will see that the Rlead-pad has been modified to 2000°C/W.

Clear the report and calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

Now you should obtain Tj = 66.61°C.  The new Rja is 41.61°C/W which is within 1% of the
published value.  As a guideline, if the Sauna value for Rja is within 5% of the published value,
that's good enough and no further adjustment of Rlead-pad is required.

Of course, it's easy to match a single experimental value by tweaking a model.  So it's important
to verify that the data also matches published data under other conditions.  The Amkor data
above includes values for forced convection cooling, so calculate temperatures at 200 feet/min
air velocity:

Steady ➔ Forced Air ➔ Feet/Minute ➔ "200" ➔ "25"

You should obtain Tj = 59.18°C.  This gives Rja-Sauna = 34.18°C/W vs. Rja-Amkor = 33.4°C/W.  The
error is +2.3%, so there is close agreement.

Next, calculate temperatures at 500 ft/minute:

Steady ➔ Forced Air ➔ Feet/Minute ➔ "500" ➔ "25"

You should obtain Tj = 56.14°C, Rja-Sauna = 31.14°C/W vs. Rja-Amkor = 29.5°C/W.  In this case the
error is +5.6%, which is also close.  There is excellent agreement over a range of cooling
conditions.

As you have just seen, it only takes a few minutes to obtain Rlead-pad from Rja.

Analyzing with a multilayer board

The Amkor data is particularly useful because there is both natural and forced air data.  Many
datasheets only provide Rja for natural cooling.  Even better, Amkor provides data for both a
single and multilayer board.  So now you will convert to a JEDEC multilayer board and verify
that there is still good agreement.
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Begin by deleting float resistors:

click  

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

Subdivide into a multilayer stackup:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Stackup ➔ Board ➔ Intern Layer
➔ Two ➔ Uniform ➔ One oz. ➔ Typical ➔ All In Wind ➔ USE

The two internal planes will be added.  Note that, as specified by JEDEC, the internal planes
have 1 ounce copper while the flareout (signal layer) has two ounce copper.  Verify this with an
Info report:

<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

The report should show 2 oz. copper for “Copp>1” and 1 oz copper for “Copp>2” and
“Copp>3”.  As mentioned earlier, for non-heat slug devices, there are no vias.

Clear the report, then add “Enter Later” float resistors and calculate temperatures for natural
cooling:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Enter Later
➔ Both Sides ➔ All In Wind ➔ USE

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain Tj = 56.18, which gives Rja-Sauna = 31.18°C/W.  The Sauna value is within
1.7% of the Amkor value of 31.7°C/W.

Calculate temperatures for forced air cooling at 200 ft/min:

Steady ➔ Forced Air ➔ Feet/Minute ➔ "200" ➔ "25"

For this condition, you should obtain Tj = 51.26°C, which gives Rja-Sauna = 26.26°C/W.  The
Amkor value is 26.8°C/W, so the error is -2.0%.

Finally, calculate temperatures for forced air cooling at 500 ft/min:

Steady ➔ Forced Air ➔ Feet/Minute ➔ "500" ➔ "25"

For 500 feet/minute, you should obtain Tj = 49.61°C, so Rja-Sauna = 24.61°C/W.  With Rja-Amkor =
24.7°C/W, the error is -0.4%.  Overall, there is excellent agreement between Sauna and Amkor for the
multilayer board.

You have just seen that an enhanced source can accurately characterize an LQFP package
device, provided that the correct Rlead-pad is used.  With the 14 x 14 LQFP, you were actually
pretty close with the typical Rlead-pad of 1500°C/W.  So you may be wondering: "will this always
be the case?".
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The answer is "no".  The default Rlead-pad of 1500°C/W doesn't work perfectly for a wide range
of package sizes.  For a device size of 10 mm x 10 mm, the typical value should be a good
starting point.  But smaller packages will generally need a lower value of Rlead-pad, while bigger
packages will require a larger Rlead-pad.  For example, for the Amkor 7 x 7 LQFP package, the
best value for Rlead-pad was 500°C/W, while the larger 20 x 20 part required Rlead-pad of
3000°C/W.  So there can be a pretty big range in Rlead-pad, depending on package dimensions
and construction.  Therefore, don't rely on typical values and do the proper conversion of Rja to
Rlead-pad.

Heat slug device

As you can see from Table 3-1 on page 3-29, Amkor also makes a heat slug version of the 100
lead, 14 x 14 LQFP device.  It's not exactly the same part, of course, and the diepad is larger.  But
the leadcount and pitch are the same, so you can reuse the flareout.

Begin by deleting float resistors:

click  

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

Delete the heat source:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Heat Source ➔ Any Source ➔ All In Wind ➔ USE

<F1 Window> ➔ Refresh

Create the 10.3 x 10.3 pad at the center of the board:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad ➔ trap any trace or pad
➔ Pad/Rect ➔ Ref/Dx-Dy-Dz ➔ trap center ref point ➔ "-5.15,,-5.15"

➔ Dx-Dy-Dz ➔ "10.3,,10.3"

The center pad will be created.  Now you can add the heat source:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ Quad ➔ "1" ➔ "S1" ➔ LQFP
➔ 14 x 14 ➔ 100 Leads ➔ Heat Slug ➔ Use Brd Pad ➔ Typical ➔ Typ (0.1 mm)

➔ Enter Resis ➔ "2000" ➔ Ref Point ➔ trap center ref point

The heat source will be created.  Note that you used Rlead-pad = 2000°C/W, the value that you
determined above.  The heat slug part is not identical, but it's reasonable to use Rlead-pad for a
part of the same size.

The diepad is larger for the heat slug device, so you should realign the board:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ trap heat source node ➔ All In Wind ➔ USE

The board and traces will be realigned.  Now you need to add vias to the top laminate layer.
You will follow the same procedure as in Introductory Exercise 5: Basics Of Circuit Board Modeling.
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Start by isolating the top laminate layer and modifying the via display:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Lamin>1

<F6 Setup> ➔ Display ➔ Node ➔ Via Density ➔ Vias/In2

<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Enhan Diepad

Modify the via density to 440 vias/inch2:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Board Props ➔ Vias ➔ Density ➔ Vias/in2 ➔ "440"
➔ Node Group ➔ Select Regn ➔ select nodes inside red rectangle ➔ USE

Sauna will indicate that "via density modified for 4 nodes".  Get an Info report to check via
properties:

<F7 Info> ➔ Trap ➔ Board ➔ trap board

In the "-- Via Properties --" section, the report should indicate that via density varies between
0 - 440 vias/inch2.  Note that the via diameter is 0.23 mm ID and 0.30 mm OD.  These are the via
dimensions that you established when the board was first created.  This is what the JEDEC
specification requires, but it's a lot of vias and there is no need for such a small diameter.

Clear the report, then restore visibility and the display setup:

<F6 Setup> ➔ Display ➔ Use Default

click  

Add “Enter Later” float resistors and calculate temperatures for natural cooling:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Enter Later
➔ Both Sides ➔ All In Wind ➔ USE

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain Tj = 44.09°C, which provides an Rja of 19.09°C/W.  Amkor's value is
20.6°C/W.  So Rja-Sauna is 7.3% lower, which is pretty close.

In general, your first estimate should be pretty close for heat slug devices.  With a heat slug,
thermal performance is not as closely tied to Rlead-pad, so you don't need a perfect guess.  And,
of course, you always have the advantage of knowing the size of the heat slug.

On the other hand, it's a little more complicated to "tweak" the part.  That's because there are
two values to consider: Rjunction-to-case and Rlead-pad.  Rjunction-to-case is not important for devices
without heat slugs.  But it is a factor for heat slug parts because of the heat which is transferred
down through the slug.
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When the heat source was created, you used a "typical" Rjc.  To see this, get a report for the heat
source:

<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ trap S1 source

On the second page, the report will shown that the junction-to-case R is “1.84 (typical value)”.

Clear the report and increase the Rjc to 3°C/W:

<F12 Root Menu> ➔ Edit ➔ Heat Input ➔ Enhanced Src ➔ R_junct_case ➔ trap S1 source
➔ Specify ➔ "3"

Sauna will indicate that "assigned a special Rjc value to enhanced source".  Recalculate
temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain Tj = 44.60°C, so Rja = 19.60°C/W.  This is 4.9% less than Amkor's value of
20.6°C/W.  Since you are within 5%, this is considered acceptable.

Calculate temperatures with a 200 ft/minute flow rate:

Steady ➔ Forced Air ➔ Feet/Minute ➔ "200" ➔ "25"

You should obtain Tj = 39.68°C, so Rja = 14.68°C/W.  Amkor's value is 15.3°C/W, so the error is
-4.1%.

Finally, calculate at 500 ft/min flow rate:

Steady ➔ Forced Air ➔ Feet/Minute ➔ "500" ➔ "25"

At 500 ft/min, Tj = 38.22°C and Rja = 13.22°C.  Since Rja-Amkor = 13.4°C/W, the error is -1.3%.
Once again, there is a good match with published data for a range of cooling conditions.

As mentioned above, you can adjust either Rjc or Rlead-pad.  It is recommended that you start by
adjusting Rjc.  However, do not adjust Rjc by more than a factor of two.  Then, if necessary,
adjust Rlead-pad to achieve the target value for Rja.

The next page has a detailed step-by-step checklist for obtaining Rlead-pad.

This concludes the section which can be worked with the Sauna Evaluation Package.  For the rest of the
exercise, the Sauna Evaluation Package lets you create the models but you will not be able to calculate
temperatures.
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Checklist for obtaining Rlead-pad

For your future reference, here is a checklist to follow when creating JEDEC test boards:

1.  Create a 76.2 mm x 76.2 mm (3" x 3") board in the horizontal plane:

Single layer board (JEDEC 51-3).  Create a zero layer board.  The via density will
initially be zero, but you should specify 0.23 mm via inner diameter with one ounce
plating.  Use the default board label ("Lamin>1").  Alternatively, you can use the
"jedec_single_3inch" model in the "Sauna Thermal Modeling\Reference Models" folder.  (If you
use a file from the Reference Models folder, be sure to save it under a different name in a different
folder).

Multilayer board (JEDEC 51-5 or JEDEC 51-7).  Create the board described above for
JEDEC 51-3.  Then subdivide the board to add two internal copper planes (Edit ➔
Plate/Board ➔ Subdivide ➔ Stackup ➔ Board ➔ Intern Layer).  For the internal planes the
copper weight is one ounce.  You should use the default laminate thicknesses.
Alternatively, you can use the "jedec_multi_3inch" model in the "Sauna Thermal
Modeling\Reference Models" folder.  (If you use a file from the Reference Models folder, be sure
to save it under a different name in a different folder).

2.  On top of the board, create the appropriate copper trace pattern with a 25 mm flareout.
The copper weight should be 2 oz.  For a device with a centered heat slug, you would
normally create the board slug pad at the same time as the flareout.  For a non-centered heat
slug, create the board slug pad after creating the flareout.

3.  The trace width for the flareout must be 0.25 mm (.010").  If necessary, edit the trace
width (Edit ➔ Plate/Board ➔ Dimensions ➔ Trace/Pad ➔ Trace Width).

4.  Add an enhanced heat source.  Initially, start with the default Rlead-pad of 1500°C/W.  As
far as wattage is concerned, the datasheet may indicate that the Rja was obtained at a specific
wattage.  If this is the case, use this wattage.  Otherwise, use a wattage which provides a
junction temperature of about 50°C above ambient.  Note that a higher testing wattage
produces a lower Rja for natural cooling, so manufacturers tend to test with higher wattages.

5.  Align the board and traces to the heat source.

6.  For devices with heat slugs, add vias underneath the device:

a. Isolate the front laminate layer (Visibility ➔ Isolate ➔ Layer ➔ Lamin>1)

b. Turn on the display of via density (<F6 Setup> ➔ Display ➔ Node ➔ Via Density ➔
Via/In2)

c. Turn on diepad outlines (<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Enhan Diepad)

d. Edit the via density to 440 vias/inch2 (Edit ➔ Plate/Board ➔ Board Props ➔ Vias ➔
Density ➔ Via/in2 ➔ "440" ➔ Node Group ➔ select nodes inside red rectangle ➔ USE)

e. Restore the default display setup (F6 Setup ➔ Display ➔ Use Default)

f. IMPORTANT - Turn on all layers by clicking 

7.  Add float resistors to both sides of the board.
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8.  Calculate temperatures for natural cooling.

9.  Calculate Rja and, if necessary, modify the device characteristics to match the datasheet
Rja to within 5%.  If the device does not have a heat slug, adjust Rlead-pad (Edit ➔ Resistor ➔
Constant ➔ Enhan->Pad) to obtain the correct Rja.  For a device with heat slug, first adjust Rjc
(Edit ➔ Heat Input ➔ Enhanced Src ➔ R_junct_case).  But don't increase Rjc by more than a
factor of two from the default value.  Instead of a further increase in Rjc, increase Rlead-pad.
You do not have to delete/recreate float resistors during these modifications.

This completes the checklist.  As mentioned above, the Reference Models folder contains Sauna
models for the JEDEC 51-3 board (jedec_single_3inch.smf) and the JEDEC 51-7 board
(jedec_multi_3inch.smf).

Understanding the rules for lead pads

Begin by loading the qfp_dpak.smf model saved as part of Introductory Exercise 5: Basics Of
Circuit Board Modeling.  This should be in your working directory, or it can be loaded from the
Reference Models folder (C:\Program Files (x86)\Sauna Thermal Modeling\Reference Models).
Load the model:

<F12 Root Menu> ➔ File ➔ Open ➔ select qfp_dpak.smf ➔ click Open button
➔ click Yes button to delete existing model

click  Front

Delete float resistors:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

This model is fairly complex, so switch to abbreviated symbols:

<F6 Setup> ➔ Display ➔ Symbols ➔ Abbreviated

Earlier in the exercise, it was mentioned that lead pads are a special class of assembly.  As the
name implies, these are the pads closest to the enhanced source and these pads have resistor
connections to the enhanced source junction.

To see all of the lead pads in the current model, enter these commands (don't click USE):

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Constant ➔ Enhan->Pad ➔ trap S1 source
➔ Typ-1500 C/W ➔ Lead Pads ➔ All In Wind

A total of 24 lead pads will be selected: 2 lead pads for S1, 16 lead pads for S2, 2 lead pads for S3
(using lumped leads) and 4 lead pads for S4 (using lumped leads).

Don't click USE, just return to the root menu:

<F12 Root Menu>

The basic rule for lead pad assemblies is simple: do not modify lead pads.  So this means you
should not delete, reshape or slice lead pads.  On the other hand, there is no problem with
aligning to a heat source or remeshing.
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Now you will see how this works.  Delete the S1 heat source:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Heat Source ➔ Any Source ➔ Select 1
➔ trap S1 source ➔ USE

<F1 Window> ➔ Refresh

The heat source and body assembly will be deleted.

Now you will delete the right lead pad for the DPAK (see Figure 3-13):

<F12 Root Menu> ➔ Delete ➔ Assembly ➔ Plate ➔ Select 1 ➔ trap right lead pad ➔ USE

S2

S4

S3

delete right lead pad
X

Y

Figure 3-13: Delete this pad

The lead pad will be deleted.  Now attempt to recreate the S1 source:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ DPAK's ➔ "1" ➔ "S1"
➔ DPAK ➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point ➔ trap ref point

Sauna will display an error screen to inform you that there are missing lead pads.  If a lead pad
is missing, you will not be able to create the enhanced source.

Click the Done button to clear the error screen.  Then use Undo two times to restore the missing
pad:

<F12 Root Menu> ➔ Edit ➔ Undo ➔ click Yes to undo unsuccessful heat source creation

Undo ➔ click Yes to undo delete of pad
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Now you can add the heat source:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ DPAK's ➔ "1" ➔ "S1"
➔ DPAK ➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point ➔ trap ref point

Since the standard lead pads are now available, the heat source will be created.

It was also stated that you should not reshape lead pads.  For traces and pads, you can reshape
with the Shift Endpoint command.  Enter these commands to shift the lower end of the right
lead pad:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Dimensions ➔ Trace/Pad ➔ Shift Endpt
➔ trap lower edge of right DPAK pad ➔ Define Delta ➔ Dy ➔ "-10"

Sauna will display a warning screen because you are attempting to reshape a lead pad.
Normally, you would cancel.  But for this exercise, continue with:

click Done button to clear error screen ➔ click Yes button to continue

Sauna will reshape the lead pad.  But this has caused some other problems.  Get an Info report
for the S1 source:

<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ trap S1 source

On the second page of the report, Sauna will indicate that there is only 1 lead pad connection.  If
you reshape a lead pad, Sauna will simply remove the resistor connection to the enhanced
source.  This actually makes sense.  When Sauna creates enhanced->pad resistors, all of the
nodes in the lead pad assembly are used.  If you make the lead pad bigger or smaller, the
resistance will be applied over a different area of the board, which would be an error.

The rules for lead pads are pretty simple: do not delete, reshape or slice.  And, most of the time,
it is easy to follow these rules.

However, there is one situation which requires special consideration.  There are components in
standard sizes where one or more leads is missing.  But, as you have seen, Sauna expects a full
set of leads.  You certainly have the option of creating a non-standard part (see later in the
exercise).  But it's usually easier to handle the missing lead problem with a large Rlead-pad for the
"phantom" pads.  Just use a large resistance of 1.0E6°C/W or so.

Clear the report before continuing to the next section.

Aligning to multiple heat sources

In this section, you will continue working with the qfp_dpak.smf model.  Instead of correcting
the current model, just reload qfp_dpak.smf:

<F12 Root Menu> ➔ File ➔ Open ➔ select qfp_dpak.smf ➔ click Open button
➔ click Yes button to delete existing model

It won’t be necessary to delete/recreate float resistors:  But you should turn off the fixed node:

click  



3 - 40 Chapter 3: Intermediate Exercises

When the qfp_dpak.smf model was created, you aligned to the QFP (S4) heat source.  This is a
logical choice since this component dissipates 3 watts and is likely to be the most expensive
component on the board.  But it's best to align to all heat slug components with a significant
heat load.  So you will be aligning to both S1 and S4.

The basic method is the same as described in Intermediate Exercise 1: Superassemblies And Basic
Slicing.  In that exercise, you sliced at the midpoint between nodes to avoid problems with non-
uniform distributed wattage.  The qfp_dpak.smf model does not have any distributed wattage,
so this will not be a problem.  But there is non-uniform via density, so you will use the midpoint
slice to avoid this problem.

Referring to Figure 3-14, perform the first slice:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Line Slice ➔ Y-Coord ➔ Midpoint
➔ click on trap node #1 ➔ click on trap node #2 ➔ Select Regn

➔ grouping rectangle from Figure 3-14 ➔ USE

S1

70.73

S2

89.74

S4

95.67

S3

88.37

trap node #2

trap node #1

trap node #3
trap node #4

grouping
rectangle

X

Y

Steady State

Figure 3-14: Slicing points and grouping rectangle

The slice will be completed.  It's important that you use "Select Regn", because you must slice
through all the layers of the stackup.  Now slice a second time to separate the DPAK from the
QFP:

X-Coord ➔ Midpoint ➔ click on trap node #3 ➔ click on trap node #4 ➔ Select Regn
➔ grouping rectangle from Figure 3-14 ➔ USE

The second slice will be performed.  The board will be as shown in Figure 3-15.

Get a detailed listing of all the assemblies in the model:

<F7 Info> ➔ Assemblies ➔ List/Detail ➔ Screen
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On the final page of the report, you will see additional laminate assemblies.  For example,
before there was only "Lamin>1", now there is "Lamin>1", "Lamin>1>1" and "Lamin>1>2".  This
is due to the slicing, but you can still isolate the layer in the same way.  There are also additional
"Lamin>2" and "Lamin>3" assemblies, as well as additional copper assemblies.  Clear the report
before continuing.

The lower right portion of the board is already aligned the S4 QFP.  So no action is required
there.  But you do need to align the lower left assemblies to the S1 DPAK.

Referring to Figure 3-15, align to the S1 source:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ trap S1 heat source ➔ Select Regn

➔ use grouping rectangle from Figure 3-15 ➔ USE

S1

S2

S4

S3

grouping
rectangle for
alignment

X

Y

Figure 3-15: Grouping rectangle for alignment

The alignment will be rejected, due to non-uniform via density.  You will need to set the via
density to zero for the lower-left section of the board before aligning.  For most via density
modifications, you start by isolating a laminate layer.  But to modify the via density of an entire
assembly, the process is simpler.  Clear the error screen, then enter these commands:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Board Props ➔ Vias ➔ Density ➔ None ➔ Entire Board
➔ Group ➔ Select Regn ➔ use grouping rectangle from Figure 3-15 ➔ USE

Sauna will inform you that "via density modified" for 3 boards.  Now you can realign to S1:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ trap S1 heat source ➔ Select Regn

➔ use grouping rectangle from Figure 3-15 ➔ USE

The lower-left section will be realigned.
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As you have done before, add vias underneath the S1 source:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Lamin>1

<F6 Setup> ➔ Display ➔ Node ➔ Via Density ➔ Vias/In2

<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Enhanced Die

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Board Props ➔ Vias
➔ Density ➔ High (100) ➔ Node Group ➔ Select Regn

➔ grouping rectangle matches red outline of S1 source ➔ USE

Sauna will inform you that the via density was modified for 4 nodes.

Restore the display setup and visibility:

<F6 Setup> ➔ Display ➔ Use Default

Symbols ➔ Abbreviated

click  

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ “25”

You should obtain TS1-DPAK = 66.37°C, TS2-SOIC = 89.77°C, TS3-SOIC = 88.39°C and TS4-QFP =
95.72°C.  As compared with temperatures before realigning, there is almost no difference for the
SOIC and QFP heat sources.  But the DPAK temperature decreases by around 5°C, which shows
why alignment is recommended for heat slug components.

Converting to flip chip

In this section, you will switch to an inverted flip chip style for the QFP.  In the following
section, you will add a heat sink to the flip chip, resulting in a construction similar to
Figure 3-16:

exposed pad

Flip chip configuration

board

Figure 3-16: Typical flip chip with heat sink

The diepad size will be the same as before, 7 mm x 7 mm.  The wattage is also unchanged
at 3W.
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Begin by deleting fixed nodes and float resistors:

click  

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

Now you will remove the vias from underneath the QFP.  You don't need to edit the nodes, you
can simply remove vias from the entire assembly.  Also, since the "Lamin>1" layer is closest in a
front view, you can trap an edge and be sure that the frontmost board assembly will be selected.

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Board Props ➔ Vias ➔ Density ➔ None
➔ Entire Brd ➔ Group ➔ Select 1 ➔ trap lower-right board assembly ➔ USE

Sauna will indicate that “via density modified for 1 board”.  Delete the existing QFP source:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Heat Source ➔ Any Source ➔ Select 1
➔ trap S4 heat source ➔ USE

The QFP heat source and body assembly will be deleted.

You will be reusing the lead pads.  But there's no need for the center 7 x 7 copper pad.  Delete
the 7 x 7 pad:

<F12 Root Menu> ➔ Delete ➔ Assembly ➔ Plate ➔ Select 1 ➔ trap 7 x 7 pad ➔ USE

<F1 Window> ➔ Refresh

Notice that the reference point was not deleted.  You can use this point to place the reconfigured
QFP.  Create the flip chip QFP:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ Quad ➔ "3" ➔ "S4" ➔ MQFP
➔ 14 x 14 ➔ 64 Leads ➔ Flip To Top ➔ Specify ➔ "7,7,.3" ➔ Centered ➔ Specify ➔ “3.98”

➔ Typ (0.1 mm) ➔ Typ-1500 C/W ➔ Ref Point ➔ trap QFP reference point

The heat source will be created.  You used Rjunct-to-top = 3.98°C/W, which is the same Rjc as the
heat slug device.  (Notice that the component datasheet will probably refer to this resistance as
Rjunct-to-case, not Rjunct-to-top.)  Get an Info report:

<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ trap S4 source

On the second page of the report Sauna indicates that the upper layer thickness is "0.0 (flip
chip)".

Clear the report, then create float resistors and calculate temperatures:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Both Sides ➔ All In Wind ➔ USE

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ “25”

You should obtain TS4-QFP = 131.48°C.  The S4 temperature is 35.8°C warmer than before.  This is
to be expected.  The heat slug on the board side was removed and, for the moment, there is not
a heat sink on top of the component.
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Adding a heat sink

To add a heat sink, you will need to delete fixed nodes and float resistors:

click  

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

Isolate the enhanced sources, then switch to a right view:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Enhanced Src

click  Right

The screen will be similar to Figure 3-17, except there will not be a surface assembly for the S4
source.

As suggested by Figure 3-17, you will be using the surface assembly command.  For most Sauna
editing operations, you will not be able to add an enhanced source body assembly to the group.
But an exception is made for surface assemblies.

Create a surface assembly for the QFP:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Surface ➔ Component ➔ Plate ➔ Enter Thick ➔ "2"
➔ Enter Label ➔ "QFP-sink" ➔ Auto ➔ Specify ➔ Aluminum ➔ Extruded ➔ Anodized

➔ Select 1 ➔ trap S4 body assembly ➔ USE

The surface assembly will be created and the screen will be the same as Figure 3-17:

S1

S2

S4

S3

new surface assemblyY

Z

Figure 3-17: Surface assembly added to QFP heat source
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Now change the width of the surface assembly ("QFP-sink"):

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Dimensions ➔ Modify X ➔ Enter Dimen ➔ "20"
➔ Center ➔ Select 1 ➔ trap new QFP-sink assembly ➔ USE

QFP-sink will appear to be unchanged, but that’s because you are viewing the model in a right
view.  Now change the Y-dimension:

Modify Y ➔ Enter Dimen ➔ "20" ➔ Center ➔ Select 1 ➔ trap QFP-sink assembly ➔ USE

You will see the change in Y-dimension immediately. Switch to a perspective view:

click  

In a perspective view you will see that both the width and height have changed.  Add 15 mm
fins to QFP-sink:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ New Fins ➔ "15,4.5,1" ➔ Component
➔ Select 1 ➔ trap QFP-sink assembly ➔ USE

Restore visibility, switch to shade mode and zoom out:

click   ➔ click   ➔ click  

The screen should be as shown in Figure 3-18:

S1

S2

S4

S3

X

Y

Z

Figure 3-18: Perspective view of board with QFP heat sink
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Now you are ready to add float resistors.  Since the heat sink is only slight larger than the heat
source, you can use a simplified two step approach.  In the first step, create float resistors for
everything except the heat sink:

click  Top

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural ➔ Both Sides
➔ All In Wind ➔ Unselect 1 ➔ trap finned plate ➔ ➔ USE

Sauna will indicate that "4 fixed temp nodes and 1525 float resistors created".  Now zoom out
and create float resistors for the heat sink:

click  

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Float ➔ Isoltd->Fix ➔ Natural/Rad ➔ 100% Area
➔ Entire Assy ➔ Select 1 ➔ trap finned plate ➔ USE ➔ trap front fixed node

Sauna should indicate that "9 float resistors created".

Turn off fixed nodes and switch to a front view:

click   ➔ click  Front

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ “25”

You should obtain TS4-QFP = 76.76°C, which is 19°C cooler than with the slug soldered to the
board.  The other components are slightly cooler as well.  There was a clear benefit from the flip
chip with heat sink.

The method that you used for creating float resistors is appropriate when the heat sink is
roughly the same size as the component.  For a heat sink which is significantly larger than the
component, you should start by creating parallel gap resistors between the underside of the
heat sink and board.  After doing this, you would create float resistors for the rest of the board.

Modifying internal copper layers

Up until now, internal copper layers have always been "full copper".  This is not a requirement.
You can have individual traces and pads on an internal layer, just as for outer layers.  But there
are some extra steps that you need to learn about.

You will be modifying the “Copp>2” internal layer to obtain the geometry shown in Figure 3-19
on the next page:
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Lower-left corner
shifted by 15 mm

X

Y

Figure 3-19: Modified “Copp>2” internal layer

As a first step, isolate the “Copp>2” layer:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Copp>2

Approximate method: modify copper coverage

As it turns out, there's two different ways to modify an internal layer.  As suggested by Figure
3-19, you can use the Reshape command to obtain exactly the desired shape.  You will do this
shortly.

But there is a quick way to achieve a similar result.  Turn on copper coverage:

<F6 Setup> ➔ Display ➔ Node ➔ Cu Coverage ➔ On

You will see "100" for all nodes, which indicates "100% copper coverage".

The approximate method is pretty simple.  Instead of reshaping or slicing, you just set the
copper coverage to 0% in the area of the cutout.  With 0% copper coverage, there is a very large
in-plane resistance, so the thermal impact is largely the same as cutting away the copper plane.
The command would be (don't actually do it):

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ Trace/Pad
➔ Coverage ➔ 0% ➔ Node Group...

If you actually did the modification, the layer would be as shown in Figure 3-20 on the next
page:
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Figure 3-20: Modifying copper coverage to simulate the cutout

Once again, you don't have to do anything, just have a look at a Figure 3-20 and remember the
method.  The copper coverage method works quite well when a large section of copper plane is
removed.  It's not appropriate for modeling traces.

Before continuing, turn off copper coverage display:

<F6 Setup> ➔ Display ➔ Node ➔ Cu Coverage ➔ Off

Using the exact method to modify internal copper plane

Prior to reshaping the pad, you will need to delete float resistors:

click  

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

Once again, isolate the “Copp>2” layer:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Copp>2

Use the Reshape command to obtain the shape shown in Figure 3-19:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Dimensions ➔ Reshape ➔ One Vertex
➔ trap lower-left corner ➔ Dx ➔ “15” ➔ Vertical XY ➔ Select 1

➔ trap lower-left assembly ➔ USE

The lower-left assembly will be reshaped to match Figure 3-19 on the previous page.  There are
now thick dashed lines for all of the assembly boundaries.  Since there is no longer a rectangular
shape, Sauna will not create a superassembly.
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Turn on all layers:

click  

Check the board stackup:

<F12 Root Menu> ➔ Analyze ➔ Check ➔ Brd Stackup

Sauna will display an error screen stating that "2 zero layer boards have missing/invalid stack
joins".  Clear the error screen before continuing.

Before reshaping the copper layer, the “Lamin>1” layer was joined to the “Copp>2” layer, and
the “Copp>2” layer was joined to the “Lamin>2” layer.  There were no stack joins between the
“Lamin>1” and the “Lamin>2”, since “Copp>2” was full plane.  But with the modification,
there is now a section where “Lamin>1” and “Lamin>2” should be joined together.  In the
model, there is a thin air gap in the area to be joined.  Sauna has a special type of join, the "gap
allowed" join which allows you to ignore thin air gaps (gaps would not be present in a real
board).  It is possible to create the join directly with Model ➔ Join ➔ Stack ➔ Specialized ➔ Gap
Allowed...  But there is an even easier way.

Enter these commands to create any missing stack joins:

<F12 Root Menu> ➔ Model ➔ Join ➔ Stack ➔ Brd Stackup ➔ click any trace, pad or board

Sauna will display the message "60 possible joins: 59 already joined, 1 new join".  The missing
join has been created.

Now you need to recreate float resistors.  Since there is a finned heat sink on S4-QFP, you need
to follow the two step method from page 3-46.  First, create float resistors for everything except
the heat sink:

click  Top

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural ➔ Both Sides
➔ All In Wind ➔ Unselect 1 ➔ trap finned plate ➔ USE

Sauna will indicate that "4 fixed temp nodes and 1525 float resistors created".  Now zoom out
and create float resistors for the heat sink:

click  

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Float ➔ Isoltd->Fix ➔ Natural/Rad ➔ 100% Area
➔ Entire Assy ➔ Select 1 ➔ trap finned plate ➔ USE ➔ trap front fixed node

Sauna should indicate that "9 float resistors created".

Turn off fixed nodes and switch to a front view, then calculate temperatures:

click   ➔ click  Front

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ “25”

You should obtain TS1-DPAK = 61.81°C and TS4-QFP = 76.77°C.  The S1 source is about 0.2°C
warmer, while the S4 source is largely the same.  As a general rule, it's acceptable to remove
copper from an internal plane provided that the removed copper is not immediately adjacent to
a heat source.
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Adding a pad to an internal layer

Now you will add a pad to the “Copp>2” layer, as shown in Figure 3-21.  (Since you will not be
reshaping, you do not need to delete float resistors.)

new 5 mm x 15 mm pad

X

Y

Figure 3-21: New pad on “Copp>2” layer

Begin by isolating “Copp>2”:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Copp>2

Create the pad as follows:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad ➔ trap any assembly
➔ Pad/Rect ➔ Coords/Trap ➔ "2,5" ➔ Dx-Dy-Dz ➔ "5,15"

The pad will be created, but there will be two error screens informing you that there was a
conflict with a pre-existing join.  Sauna was attempting to join the new pad to the “Lamin>1”
and “Lamin>2” layers.  But a conflict arises because of the join that you created earlier between
the two laminate layers.

After clearing the error screens, use Undo to remove the rectangular pad:

<F12 Root Menu> ➔ Edit ➔ Undo ➔ click Yes button

Sauna has a command to delete all of the stack joins for an internal layer.  The command also
checks for "gap allowed" joins for adjacent laminate layers and will allow you to delete these
joins as well.  Delete the stack joins for the “Copp>2” layer:

<F12 Root Menu> ➔ Delete ➔ Join ➔ Stack ➔ Copper Layer ➔ trap any assembly
➔ click Yes to delete gap allowed joins

Sauna will indicate that 7 joins were deleted (6 for the copper assemblies, 1 between laminate
layers).  Now you can add the pad:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad ➔ trap any assembly
➔ Pad/Rect ➔ Coords/Trap ➔ "2,5" ➔ Dx-Dy-Dz ➔ "5,15"

The pad will be created and there will not be any error messages.
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Recreate the stack joins which were deleted earlier:

click  

<F12 Root Menu> ➔ Model ➔ Join ➔ Stack ➔ Brd Stackup ➔ click any trace, pad or board

You should see the message: "62 possible joins: 55 already joined, 7 new joins".  Calculate
temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain TS1-DPAK = 61.80°C and TS4-QFP = 76.77°C.  These temperatures are largely the
same as before.  This is not particularly surprising, since the only change was a small pad in an
area well removed from the heat sources.

Connecting heat source to 2nd buried plane

In the current model, the S1 source is connected with thermal vias to the first internal plane
(“Copp>2”).  Some boards will have the heat slugs connected to the first internal plane, while
other boards will bypass the first internal plane and connect to the second plane.  You will be
modifying the model so that the S1 source connects to the second internal plane, which is the
“Copp>3” layer.

The first laminate layer (“Lamin>1”) already has vias.  You will retain these vias, while also
adding vias to the “Lamin>2” layer.  But you may be wondering, how will I disconnect from the
“Copp>2” layer so that there is no thermal spreading?  As you will see shortly, the solution is to
modify copper coverage.

You will begin by adding vias to the “Lamin>2” layer.  Start by isolating this layer and turning
on via density display:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Lamin>2

<F6 Setup> ➔ Display ➔ Node ➔ Via Density ➔ Vias/In2

You should see 0 vias/in2 for the entire board.  Now turn on the heat sources and make die
outlines visible:

<F12 Root Menu> ➔ Visibility ➔ Turn On ➔ Node/Resis ➔ Footprint Src

<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Enhan Diepad

Edit the via density:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Board Props ➔ Vias ➔ Density ➔ High (100)
➔ Node Group ➔ Select Regn ➔ grouping rectangle matches S1 red outline ➔ USE

Sauna should indicate that 4 nodes were modified.

Now you will modify the “Copp>2” layer so that heat does not spread from the area where
thermal vias pass through.  Restore the default display setup and isolate the “Copp>2” layer:

<F6 Setup> ➔ Display ➔ Use Default

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Copp>2
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Activate copper coverage display:

<F6 Setup> ➔ Display ➔ Node ➔ Cu Coverage ➔ On

You will see "100" for 100% copper coverage for all nodes.

Turn on heat sources and make die outlines visible:

<F12 Root Menu> ➔ Visibility ➔ Turn On ➔ Node/Resis ➔ Footprint Src

<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Enhan Diepad

Next you will zoom in to match Figure 3-22, which shows copper coverage when the
modification is complete.  Zoom in now:

<F3 Zoom In> ➔ zoom in to match Figure 3-22
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Figure 3-22: Copper layer after modifying copper coverage

Make the modification:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ Trace/Pad ➔ Coverage ➔ 0%
➔ Node Group ➔ Select Regn ➔ grouping rectangle matches S1 red outline ➔ USE

You should see the message "copper coverage modified for 4 nodes" and the screen should
match Figure 3-22.

The modification is complete.  You just need to restore the display setup and visibility:

<F6 Setup> ➔ Display ➔ Use Default

Symbols ➔ Abbreviated

click   ➔ click  
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Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain TS1 = 65.65°C, which is about 4°C warmer than before.  While the
temperature increase is modest, there is clearly a penalty for connecting to the second internal
plane.  If necessary, you could compensate by using additional thermal vias.

Non-standard components #1: standard outline with special leads

Sauna provides a library of over 200 standard component packages and trace patterns.  That's
quite useful, but it is certainly possible that you will need to model a package which is not in
the library.  Fortunately, Sauna provides efficient tools for quickly modeling many of these non-
standard packages.

If you do not expect to create non-standard components in the near future, you can skip the next three
sections.  Just have a look at Figure 3-23 on the next page, then skip ahead to “Wrapping up” at the end
of the exercise.

To explore non-standard packages, only a simple board is needed.  Begin by deleting the
existing model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

Create a zero-layer board:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Circuit Brd ➔ hit <Enter> to skip ➔ Rectangle
➔ Vertical XY ➔ "80,80" ➔ .062"/1.57mm ➔ (0,0,0) ➔ FR4 ➔ Zer/Lam Only

➔ .025/0.64mm ➔ One oz. ➔ None

The board assembly will be created.  Now you will create the lead pattern for a non-standard
8 x 8 QFN (quad, flat, no leads) device.  Begin with:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ trap board ➔ Component
➔ One oz. ➔ Pad Library ➔ Quad ➔ QFN ➔ 8 x 8

You will reach the 8 x 8 menu:

   8 x 8
 1 32 Leads
 2 40 Leads
 3 52 Leads
 4 56 Leads
 5 Special

Sauna provides 4 different lead possibilities.  The 32 lead option provides for a lead pitch of 0.8
mm, the 40 lead option uses a 0.65 mm pitch and the 52 and 56 lead options use a 0.5 mm pitch.
(Lead pitch is the centerline distance between lead pads.)  But beyond these 4 standards, 8 x 8
packages are available in other combinations of pitch and lead count.  That is why a "special"
option was included with Sauna.

You will create the trace pattern for a 24 lead, 0.8 pitch component:

Special ➔ “24,.8” ➔ Detailed ➔ 5 mm/0.2” ➔ No ➔ Coords/Trap ➔ "20,40"

The pad pattern will be created.
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Switch into shade mode to more clearly see the pattern:

click  

When you use a special lead count and pitch, Sauna will automatically use a pad width which is
50%  of the pitch (a very common ratio).  Since the pitch is 0.8 mm, the pad width and trace
width are 0.4 mm.  If you don’t want this value, you can create a fully custom quad package
(see the next section).

It's a simple matter to add the actual component:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ Quad ➔ "1" ➔ "S1" ➔ QFN
➔ 8 x 8 ➔ Special ➔ “24,.8” ➔ Middle ➔ Typical/36% ➔ Typ (0.1 mm) ➔ Typ-1500 C/W

➔ Ref Point ➔ trap QFN reference point

The QFN component will be added.  Turn on shade mode:

click  

In shade mode, you will see that you have created the left component in Figure 3-23:

Non-standard
  8 x 8 QFN

Non-symmetric
quad package

Non-symmetric
dual package

X

Y

Figure 3-23: Non-standard components

Since you just created a “leadless” component, the actual lead pads are underneath the
component body.  Sauna's enhanced heat sources allow for lead pads outside the body,
underneath the body, or a combination of the two styles.

Non-standard components #2: non-symmetric quad flatpack

Now you will create the middle component in Figure 3-23.  The dimensions for this component
are shown in Figure 3-24 on the next page.  Instead of using a standard package outline, you
will directly specify all dimensions.  There’s more data to enter, but it’s a straightforward
process.
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4 left/right leads,
pitch = 2, pad width = 1

24 lower/upper leads,
pitch = 0.8, pad width = 0.4

X

Y

Figure 3-24: Dimensions for non-symmetric quad flatpack

Create the pads:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad ➔ trap any trace or pad
➔ Pad Library ➔ Quad ➔ Special ➔ Non-Symm ➔ "24,.8,0" ➔ hit <Enter> to skip ➔ "10,2"

➔ "4,2,0" ➔ hit <Enter> to skip ➔ "14,2" ➔ Detailed ➔ Pad Only ➔ No ➔ Coords/Trap ➔ "40,50"

The pads will be created.  Switch into shade mode to see the pads more clearly:

click  

Now you are ready to add the device.  Although you will have to retype many of the
dimensions, it’s not particularly difficult (just type carefully).  Add the device:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ Quad ➔ "1" ➔ "S2" ➔ Special
➔ "10,6,2" ➔ Non-Symm ➔ "24,.8,0" ➔ hit <Enter> to skip➔ "10,2" ➔ "4,2,0"

➔ hit <Enter> to skip➔ "14,2" ➔ Middle ➔ Typical/36% ➔ Typ (0.1 mm)
➔ Typ-1500 C/W ➔ Ref Point ➔ trap reference point

The non-symmetric component will be created.  Once again, switch into shade mode:

click  

The component will be as shown in the middle of Figure 3-23.

Non-standard components #3: non-symmetric dual component

In the last part of this section, you will create a non-symmetric dual component.  If you look at
Figure 3-23, you may recognize this as a SOT-223 device, which is in the library.  But Sauna also
let’s you create the identical configuration as a non-standard component.
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Create the pads:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad ➔ trap any trace or pad
➔ Pad Library ➔ Single/Dual ➔ Spec Dual ➔ Non-Symm ➔ "3,2.3,1.2" ➔ hit <Enter> to skip

➔ "3.85,2" ➔ "1,0,3.5" ➔ hit <Enter> to skip➔ "3.85,2" ➔ Detailed ➔ Pad Only ➔ No
➔ 0 Degrees ➔ Coords/Trap ➔ "60,30"

The pads will be created.  These pads are completely identical to the standard SOT-223 pads.  In
fact, you can place a standard SOT-223 enhanced source on the pads just created:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ Single/Dual ➔ "1" ➔ "S3"
➔ SOT-223 ➔ Typ (0.1 mm) ➔ Typ/Library ➔ Ref Point ➔ trap reference point

The heat source will be created.  When an enhanced source is created, Sauna needs to find the
matching pads.  But it doesn't matter if these pads were created as a special or as standard pads.

For all of the non-standard components just created, you are still able to disconnect/reattach,
remesh and align.  To illustrate, align to the S2 source:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ trap S2 heat source ➔ All In Wind ➔ USE

The board will be realigned.

You have just seen that you can easily create non-symmetric duals and non-symmetric quad
components.  What happens if you have a component with leads on three sides?

As a first option, you could create the exact three-sided pad pattern.  Then you could create a
special symmetric dual package but without a lead pad connection (select "No Lead Conn" on
the R_Lead_pad menu).  Then you could manually create the Rlead-pad's.  This would produce a
valid model.  But there's a significant problem.  You won't be able to realign the board without
losing all the lead pad connections for the three-sided component.

But there's a second way to handle the three-sided component.  Just create a non-standard quad
component.  After creating the component, edit the Rlead-pad’s on one side to have a large value,
such 1.0E6°C/W.  This will have the same effect as removing the leads from one side of the
component.

Metal core boards

If your company uses metal core (IMS) boards, be sure to see Intermediate Exercise 11: Surface
Assemblies And Metal Core Boards.  As you will see in the exercise, Sauna is an effective tool for
modeling these types of configurations.

Wrapping up

You have completed the exercise, you should delete the model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

For a detailed discussion of the assumptions and simplifications used with enhanced sources,
see the section "All About Enhanced Heat Sources" in the Using Sauna chapter.


