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   Introductory Exercise 2: Heat Sink What-If Modifications

Sauna models are very easy to modify.  In this exercise you will change the fin length, modify
the plate thickness, and make other changes.  As you will see, this is quite easy to do.

Menu buttons

When modifying models, it is desirable to minimize the number of menu selections.  Sauna
provides menu buttons (see Figure 2-11) for the most commonly used commands for changing
the window and display.

Menu buttons

Figure 2-11: Location of menu buttons

Here is a description of the menu buttons:

Zoom out to a window which shows the entire visible model.

Left  Front  Right  Top   Switch to one of the standard orthogonal views.

Switch to the front, twisted perspective view.

Turn on the entire model, including fixed nodes.

Turn off fixed nodes.

Activate shade mode, or if shade mode is already active, turn it off.

     Turn the view left, right, up or down.

Activate contour mode, or turn off contour mode if already active.

Switch between "full" and "abbreviated" symbols for nodes and resistors.

-  +   Progressively zoom out, progressively zoom in

     Scroll left, right, up or down.

You will find that the menu buttons are extremely useful.
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Forced air vs. natural cooling

You will continue to work with the model created in the first exercise.  Remember that this
model was saved on your disk as “new_sink.smf”.  The model can also be found in
“C:Program Files (x86)\Sauna Thermal Modeling\Reference Models”.   If necessary, load the
model with <F12 Root Menu> ➔ File ➔ Open...

You should be in a front view with fixed nodes off.  If necessary, enter:

click   ➔ click  Front

Start by repeating the steady state, natural cooling calculation:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

As before, you should obtain Tjunction = 136.98°C.

Let’s suppose that the design goal is keep Tjunction below 100°C at a 25°C ambient.  One possible
solution is to use a fan to blow air over the sink.  Sauna can also predict temperatures for this
cooling mode.  To analyze performance at an air flow rate of 600 feet/minute, make these menu
selections:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Forced Air ➔ Feet/Minute ➔ "600" ➔ "25"

A new set of temperatures will be calculated. There will be a significant decrease in
temperature.  The junction temperature is now down to 97.07°C, within the target range.

Notice that you specified a linear air flow rate of 600 feet/minute.  Fans, on the other hand, are
rated with a volume flow rate (CFM or m3/hr) and a static pressure.  For this exercise, you will
only work with linear air flow.  But Sauna does provide the capability to perform a flow and
thermal analysis of a fan/sink combination.  More details are given at the end of the exercise.

Finding an equivalent, naturally cooled heat sink

At this point, we have a heat sink which is acceptable in forced air cooling, but inadequate for
natural cooling.  Suppose that, for noise and cost reasons, using a fan is not possible.  How can
the heat sink be improved so that it has acceptable natural cooling performance?

In the first exercise, when you were reading the temperature report, you may have noticed that
there were significant variations in temperature along the plate.  Let's try making the plate
thicker so that there will be less of a temperature drop as heat spreads through the plate.  Make
these menu selections:

click  

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Dimensions ➔ Plate Thick ➔ Enter Value ➔ "10"
➔ Centerline ➔ Select 1 ➔ trap the plate (click edge) ➔ USE

The sink will be modified.  On the screen, several things will happen.  First, the dashed lines
which represent the sink outline will be redrawn to reflect the new dimensions.  You probably
expected this.

In addition, the node temperatures will be removed and the message "Node temperatures and
float resistors were cleared" will be displayed in the prompt zone.  Sauna took these actions to
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ensure that data is always up to date.  Any time you modify the sink geometry, previously
calculated temperatures become invalid.  Consequently, Sauna cleared temperatures from all of
the nodes.  The same problem occurs for "float" thermal resistors and Sauna clears these
resistors as well.

Now, recalculate temperatures for natural cooling:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

With the change in backplane thickness, the junction temperature is now 122.59°C as opposed
to 136.98°C calculated previously for natural cooling.  This is an improvement, but the junction
temperature is still outside the target range.

To further reduce temperatures, let's try making the fins longer.  Enter these commands:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ Fin Props ➔ Length
➔ "75" ➔ Secondary ➔ Select 1 ➔ trap the plate ➔ USE

Once again, the sink geometry will be updated and node temperatures cleared.  Resize the
window and switch into shade mode:

click   ➔ click  

Now you can clearly see the longer fins.  For now, leave shade mode activated.  It’s allowable to
have shade mode “on” during a temperature calculation.

Recalculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

The junction temperature has now been reduced to 99.83°C.  Since this is roughly the same
temperature as calculated for the original sink in forced convection, an equivalent natural
cooling design has been found.

Adding dissipation from the component side

In the above thermal model, dissipation is only allowed for the finned side of the heat sink.
There are no thermal resistors connected to ambient on the component side of the sink.  In
many situations, this is a reasonable modeling assumption.  For example, the sink might be
mounted on the walls of an electronic enclosure which has a warm internal ambient.  Since
there is an elevated component side ambient, most of the heat should be dissipated from the
secondary side.

Let's try testing the validity of this assumption.  Let's assume that the component side of the
sink is exposed to an ambient of 45°C.

Turn off shade mode and make fixed nodes visible again:

click   ➔ click  

Begin creating the component side ambient and float resistors with these commands:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd-›Fix
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You will reach this menu:

  AMBIENT LBL
>1 "Room Amb"
 2 Enter Label

When you created the secondary side ambient node, you used the default label "Room Amb".
You don't want to use the same label for the component side because with Sauna all fixed nodes
with the same label must have the same temperature.  So you need to enter a different label.
Finish with:

Enter Label ➔ "Comp Side" ➔ Enter Later ➔ Component ➔ Select 1 ➔ trap plate ➔ USE

A fixed node and float resistors will be created on the component side of the heat sink.  This will
be clearer if you switch to a top view:

click  Top

Recalculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25" ➔ "45"

A new junction temperature of 99.23°C will be obtained.  This is slightly cooler than the
temperature of 99.83°C calculated earlier.  So, if the component side ambient is 45°C, it's
reasonable (and conservative) to neglect heat transfer from the component side.

Since you have completed the what-if modification concerning the component side ambient,
you can delete this fixed node:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ Select 1
➔ trap Comp Side fixed node ➔ USE

The Undo command

Since everyone makes mistakes, Sauna includes an Undo command.  Undo the delete of the
component side fixed node with:

<F12 Root Menu> ➔ Edit ➔ Undo ➔ click the Yes button

You can undo up to 4 commands.  Of course, you don’t want the component side fixed node, so
you must delete a second time:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ Select 1
➔ trap Comp Side fixed node ➔ USE

What commands are legal in shade mode?

When you modified the heat sink model, all the changes were made in wireframe mode.  This is
a requirement of Sauna.  Grouping and shade mode are not compatible.  So many Sauna
commands can’t be done in shade mode.

You may wondering: “How will I remember which commands are legal for shade mode?”.
Fortunately, there is nothing to remember.  If shade mode is not permitted, Sauna will
automatically toggle into wireframe mode.
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Let’s demonstrate.  Begin by switching to a perspective view in shade mode:

click   ➔ click  

Now you will try a command, the move command, which is not compatible with shade mode.
Begin a move with:

<F12 Root Menu> ➔ Move/Copy ➔ Move ➔ Trap 1 Assy

As soon as you select “Trap 1 Assy” on the Move Select menu, Sauna automatically switches to
wireframe mode.  No intervention is required by you.  So the moral is: “if you want to turn on
shade mode, go ahead”.

Since we don't want to move the model, return to the Root menu:

<F12 Root Menu>

Note that there are also commands which can only be done in shade mode.  An example is
“click surface” visibility, which is used with box models.  If a Sauna command requires shade
mode, Sauna will automatically switch for you.  It all works very smoothly.

Default material colors

When you switch into shade mode, the heat sink is shaded with a light blue color.  This color
was chosen based on the material  family of the assembly.

To see how this works, enter the following commands:

click  

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ Material
➔ Plastic ➔ ABS ➔ Select 1 ➔ trap plate ➔ USE

click  

When you switch to an ABS plastic material, Sauna uses a shade of yellow to draw the
assembly.  Let’s try another material:

Plastic ➔ Epoxies ➔ Mold Comp ➔ Select 1 ➔ trap plate ➔ USE

click  

You just changed to “Mold Comp”, which is an abbreviation for molding compound.  Molding
compound is the silica-filled epoxy material used in standard semiconductor packages such as
DIP’s, TO-220’s, etc.  Sauna now draws the sink in a shade of black.

Here’s a listing of the colors that Sauna uses:

Material Family Color
circuit board green
ceramic pale gray
epoxy dark gray
metal light blue
plastic (non-epoxy) pale yellow
semiconductor pink
special material dark blue
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Backing up the path

Now is a good time to learn about backing up the path.  Begin by accessing the Window menu:

<F1 Window>

There are two different ways to backup the path:

Backup with the path line:  As you define and edit models, Sauna uses the path line to
show the sequence of menu selections that you have made.  Any time that you want to
return to a previous menu, you simply move the cursor to the path line at the top of the
screen and click on the desired menu name.  For example, right now you are at the Window
menu.  Choose "Set View" and then choose "Front". You will advance to the Projection menu.
To return to the Window menu, move the cursor to "Window" on the path line (at the top of the
screen).  Then click the mouse.  You'll go straight back to the Window menu.

Backing up from a prompt is a little different.  For example, choose "Width" and then
choose “Enter Width” on the Width menu.  You will be prompted with "Enter the new
window width".  At this point you can't get back to the Width menu by clicking on the path
line because the Width menu is still displayed in the main menu zone.  Instead, move the
cursor to the menu title, "Width".  Then click the mouse  You will be returned to the Width
menu.

Now, move the cursor to the menu title "Interrupt” on the path line.   Then click the mouse.  You
have backed up to the starting point, so the Root menu will be displayed.  This illustrates
another way to return to the Root menu.  This method is actually easier than clicking on
<F12 Root Menu> because you don’t have to move the cursor as far.

Backup with the Interrupt menu or keyboard:  <F2 Backup> is used to back up the path one
level.  For example, choose <F1 Window>.  Next, choose "Set View" and then choose "Front".
You will advance to the Projection menu.  Hit <F2 Backup> and you will go back to the View
menu.  Hit <F2 Backup> a second time and you will return to the Window menu.  Nothing
to it.

You should also know that with Sauna the <Esc> key is the exact equivalent of <F2 Backup>.

Some practice on your own

Up until now, you have been told menu-by-menu which commands to enter.  Now, however, is
a good time to try a few commands on your own.

Working on your own, return the sink to its original configuration.  Change the fin length to 25
and reduce the plate thickness to 5 mm.  Switch back to the original extruded aluminum
material.

When you have made these changes, recalculate temperatures for natural cooling.  You should
obtain a junction temperature of 136.98°C, just as before.  If you get a different temperature, use
<F7 Info> ➔ Trap ➔ Plate to obtain a report.  Then carefully read the report to find errors.
Experienced Sauna users always use the Info reports to check for errors.

Changing the fin orientation

When you added fins to the plate assembly in the first exercise, Sauna placed the fins in the
default orientation, so that the fin channels are vertical.  Although vertical fins are best, it’s also
interesting to try other fin configurations.  So now you will check performance with horizontal
fin channels.
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Switch to a perspective view and change the fin orientation:

click  

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ Fin Props ➔ Orientation ➔ XY + YZ
➔ Horizontal ➔ Secondary ➔ Select 1 ➔ trap plate ➔ USE

Sauna will briefly redraw the screen to show the new horizontal fins.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25”

With the horizontal fin channels, you should obtain Tjunction = 167.42°C.  This is an increase of
30°C, which shows that vertical fin channels are superior.  However, be aware that the
horizontal fin channels are still an improvement over a flat wall.  For a discussion of the merits
of the different fin orientations, be sure to read Comparing Naturally Cooled Horizontal Backplane
Heat Sinks With Vertical Backplane Heat Sinks in the Cooling Electronic Systems chapter.

Heat sink and fan combinations

In this exercise, you specified a linear air flow (ft/min).  If you are combining a heat sink with a
fan, you will not be able to obtain a linear flow from the fan data sheet.  A calculation needs to
be made which predicts the linear flow based on the flow and pressure characteristic of the fan,
combined with the flow resistance the fin channels.  Sauna provides two different ways to
proceed.  In the first method, Sauna's Toolbox is used to calculate a linear velocity, which is then
entered into the Sauna model.  This method is described in Introductory Exercise 7: Calculating
Air Flow For Fan-Cooled Heat sinks.  The second method, which is more sophisticated, involves
defining a multi-ambient flow network and assigning a fan within the Sauna model.  This
approach is described in Intermediate Exercise 9: Heat Sink Flow Networks With Fans.  For most
situations, the two methods provide similar results.  For long heat sinks with closely spaced
fins, the flow network method is more accurate

Wrapping up

To prepare for the next exercise, you will delete the entire model.  Enter these commands:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

Note that everything, even elements previously made invisible, will be deleted.

In the first two exercises, you have been exposed to a number of  Sauna concepts.  It takes
everyone a little while to get used to plate assemblies, fixed nodes, footprint heat sources, float
resistors, etc.  These are new ideas.  Fortunately, you have already covered the large majority of
these new concepts.  As you continue, you will see that Sauna is very consistent and easy to use.

Tips:

• As you work through the exercises, you should obtain exactly the same
temperature as in the manual.  Although small ∆T's are not significant in the
real world, when learning Sauna you should obtain exactly the right number.
If your numbers are off, use the Info reports to check carefully for errors.  The
Info reports are extremely useful for debugging models.

• When you have a problem, either with an exercise or a real model, don't
hesitate to call Technical Support.  Take advantage of the free assistance!
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