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Sauna™ Quick Tour #1: Heat Sinks, Duty Cycles
and Stackup Models

About Sauna Quick Tours

The Sauna Quick Tours let you preview the features provided by the Sauna thermal modeling
program.  You will create actual models, just like an experienced Sauna user.  The documen-
tation explains all modeling steps, so no background with Sauna is required.  However, as the
name implies, the Sauna Quick Tours are not detailed introductions to the software.  Many
important topics are skipped over or discussed briefly.  To become a skilled user, you need to
work the tutorial exercises found in the Sauna User Manuals.  Many of these exercise are also
available to prospective users on the thermalsoftware.com website.

A basic heat sink model

You will model the geometry shown in Figure 1.  Before beginning the exercise, make sure that the
error beep on your computer is turned on (not muted).
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Figure 1: Basic heat sink model

Begin by creating a plate assembly:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Plate ➔ "Heat Sink" (do not type the quotes)
➔ Rectangle ➔ Vertical XY  ➔ "150,100,5" (do not type the quotes) ➔ (0,0,0)

➔ Aluminum ➔ Extruded ➔ Anodized

The plate will be created.  You will see an array of nodes and resistor inside thick dashed lines.
The dashed lines represent the boundaries of the plate assembly.
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Before adding fins, you will switch to a perspective view.  For commonly used commands,
there are a series of buttons at the lower-left of the Sauna window.  The right button in the top
row is for switching to a perspective view.  Change the view with:

click  

Add fins on the back (secondary side) of the plate:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Plate Props ➔ New Fins
➔ “25,10,2” (do not type the quotes)➔ Secondary ➔ Select 1

➔ click on edge of plate (dashed line) ➔ USE

Additional dashed lines will be drawn to show the boundaries of the fins.  If you want to see
each individual fin, switch to shade mode:

click  

The model will be as shown in Figure 2:
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Figure 2: Plate with fins in shade mode

Turn off shade mode, then add the footprint heat source:

click  

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "30" ➔ "S1" ➔ TO-220 ➔ Typical
➔ Standard ➔ Greased ➔ One ➔ click edge of plate ➔ Coords/Trap  “75,45”

A "basic" heat source will be created.  With a basic heat source, it is assumed that all of the heat
leaves the package through the base of the component.  The other type of heat source,
"enhanced", allows for heat transfer through the base (slug), as well as through the leads.
Enhanced heat sources are primarily used with circuit boards, as you will see in Sauna Quick
Tour #2: Circuit Board Modeling .

If you look at the screen, you will that the heat source is connected to the plate with just one
case-to-sink resistor.  For best accuracy, you should have at least 4 case-to-sink resistors.  Sauna
has a command, the "Align Mesh" command, to quickly resize the plate mesh to match the size
and location of the heat source.  Align the mesh with:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ click on red heat source node ➔ All In Wind ➔ USE
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The node and resistor mesh will be recreated, and the heat source will be connected with 4 case-
to-sink resistors.  (Please note: if you make a mistake, use <F12 Root Menu> ➔ Edit ➔ Undo and
try again.)

Adding float resistors and a fixed node

At this point, you have defined the heat sink and heat input.  However, the current model is
invalid.  No heat flow path has been established between the heat sink and the ambient
temperature environment.  A "fixed temperature" node is required to represent the room
environment.  The name "fixed temperature" comes from the fact that ambient nodes have
temperatures which remain fixed throughout the temperature calculation.  You also need "float"
resistors to represent the convection and radiation.  These are called “float resistors” because
the resistance values are adjusted according to the ∆T and convection conditions.

Create the fixed node and float resistors:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd-›Fix ➔ "Room Amb"
➔ Enter Later ➔ Secondary ➔ All In Wind ➔ USE

The fixed node and float resistors will be created.  To better see the new nodes and resistors,
switch to a right view:

click  Right

The screen will be as shown in Figure 3:
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Figure 3: Fixed node and float resistors

Now that the heat flow path to ambient has been created, you can reduce screen clutter by
making these nodes and resistors invisible.  There's a button for this:

click  

Return to a front view:

click  Front
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In a moment, you will calculate temperatures.  However, before this, it's worthwhile to see a
report for the finned plate:

<F7 Info> ➔ Trap ➔ Plate ➔ click edge of plate

A comprehensive listing of the plate characteristics will be displayed.  If you advance to the
second page, you will see details on the convection and radiation parameters.  The Info reports
are an important tool for verifying that the model was created correctly.

After clearing the report from the screen, calculate temperatures with natural cooling:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

The temperature calculation will only take a second or two.  When complete, you will see two
temperatures for the heat source.  The upper temperature, 137.09°C, is the junction temperature.
The lower temperature, 107.09°C, is the case temperature (Tjunct = Tcase + q ⋅⋅⋅⋅ Rjunct-to-case).

It's also easy to obtain temperatures for forced air cooling.  Calculate temperatures at an air
velocity of 500 ft/min:

Steady ➔ Forced Air ➔ Feet/Minute ➔ "500" ➔ "25"

You should obtain Tjunct = 108.25°C.  It's also useful to see the temperature contours:

click  

Before continuing to the next section, turn off the contours:

click  

Duty cycle transient

If you are not interested in duty cycle transient, you can skip ahead to the next section, "Creating a chip
stackup".

Up until now, you have been performing "steady state" temperature calculations.  For a steady
state analysis, it is assumed that the unit has been turned on for sufficient time to achieve stable,
unchanging temperatures.  Besides steady state analysis, thermal simulation programs also
typically provide "simple transient".  In simple transient analysis, the unit starts at room
temperature and gradually rises to the final steady state temperatures.  The shape of the time-
temperature curve depends on the mass of the unit and the cooling characteristics.

Sauna does much more than just steady state and simple transient analysis.  Sauna provides
both "duty cycle" (power changes with time) and "power shutback/control" (power changes as
a function of temperature).  In this section you will work a square wave duty cycle problem.

To define the square wave problem, you will create a control element.  Create a control element
with:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ With Menus ➔ Time Base ➔ Q vs Time
➔ "Sq1" ➔ Minutes ➔ Square Wave ➔ "5" ➔ "1,1" ➔ "1,0" ➔ 4 (the default) ➔ Fixed Node

At the bottom of the screen, Sauna will indicate that "Control element "Sq1" successfully
created".
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Obtain a plot of the newly created control element:

<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Minutes ➔ All ➔ Screen

You will see this graph on the screen:

Control Element Plot
--------------------
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Figure 4: Control element graph

Control elements can be assigned to one or many nodes.  After clearing the graph from the
screen, assign the control element to the heat source:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔ Time Base ➔ Q vs Time ➔ "Sq1"
➔ Heat Source ➔ All In Wind ➔ USE

To show that the control element has been assigned, Sauna changes to a “nightshade” symbol
for the heat source node.

You can now calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default
➔ Natural ➔ "25"

The calculation takes longer than for a steady state calculation, but the total calculation time is
still only 10 seconds or so.  When complete, you should see TS1-junct = 40.49°C and TS1-case =
40.49°C.  This is probably surprising, but remember that the square wave ends with an "off"
period (see Figure 4 above).

To see the true variation of temperature, obtain a temperature vs. time graph:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Minutes ➔ Graph ➔ Screen

The graph will be as shown in Figure 5 on the next page:
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Temperature vs. Time Plot
-------------------------
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Figure 5: Temperature vs. time graph

This concludes the discussion of a duty cycle transient.  There are many more possibilities.
Sauna provides a scripting languages, so you can define very complex wattage/time
characteristics.  You can explore temperature shutback and control with "wattage vs.
temperature" control elements.  Sauna has features not matched in other thermal simulation
packages, regardless of price.

After clearing the graph from the screen, delete the control element:

<F12 Root Menu> ➔ Delete ➔ Control Elem ➔ Delete All ➔ click Yes button

Creating a chip stackup

Now you will model the chip stackup problem shown in Figure 6:

silicon chip, q = 30W,
10 x 10 x 0.5

copper flange,
25 x 25 x 0.5 die attach

interface

flat/grease
interface

X

Y

Z

Figure 6: Chip stackup on heat sink
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The chip stackup is located at the same position as the TO-220 power transistor.  Begin by
deleting the existing heat source:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Heat Source ➔ Any Source ➔ All In Wind ➔ USE

Now create the copper flange and silicon chip assemblies:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Plate ➔ "Flange" ➔ Rectangle ➔ Vertical XY
➔ "25,25,1" ➔ Coords/Trap ➔ "62.5,32.5,1" ➔ Copper ➔ Pure ➔ Emis=0.1

Plate ➔ "Sil Chip" ➔ Rectangle ➔ Vertical XY ➔ "10,10,.5" ➔ Coords/Trap ➔ "70,40,1.5"
➔ Semi + Misc ➔ Silicon ➔ Emis=0.1

As a quick visual check, switch to shade mode in a top view:

click   ➔ click  Top

If something is wrong, use Edit ➔ Undo and try again.  Return to a front view:

click  Front

Modifying the silicon chip

Now you want to modify visibility so that only the silicon chip is visible.  This is easy to do
with “click surface” visibility:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only ➔ Click Surf
➔ click surface of silicon chip

Turn off shade mode:

click  

You will see that the silicon chip has only one node.  For any heat dissipating plate, there
should be at least 4 nodes to achieve the best accuracy.  Remesh the plate:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Both Axes ➔ Finer 4x
➔ All In Wind ➔ USE

The silicon chip will be remeshed to have 4 nodes.

Next, you need to add the wattage to the silicon.  Apply a “distributed” heat load:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Plate ➔ "30" ➔ All In Wind ➔ USE

You will see the message “Distributed wattage applied to 1 assembly” at the bottom of the
screen.  Also, note that the nodes are outlined in red to show that distributed wattage is present.

To make it easy to monitor junction temperature, add a label to the top-left node of the silicon
chip:

<F12 Root Menu> ➔ Edit ➔ Node ➔ Labels ➔ Trap 1 Node ➔ Any Node ➔ click top-left node
➔ enter "Tjunct" in text box ➔ click OK button
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Stack joins and mesh alignment

Turn on all assemblies:

click  

Now you need to define a heat flow path from the silicon chip to the heat sink.  This involves
creating stack joins.  When creating stack joins, the general rule is that nodes must be perfectly
aligned in the plane of the assembly (there are a few exceptions).  If you look at the screen, you
will see that the nodes in the silicon chip do not line up with the nodes in the copper flange.
And you have the same alignment problem between the copper flange and heat sink.

Fortunately, Sauna can usually align the nodes automatically.  Sauna aligns the larger assembly
to match the smaller assembly.  It's done this way because the smaller assemblies are usually
the heat generators.  As a user, you just have to click "Yes" when Sauna asks if the nodes can be
realigned.

Create the join between the silicon chip and the copper flange:

<F12 Root Menu> ➔ Model ➔ Join ➔ Stack ➔ Ordinary ➔ Strict ➔ Die Attach ➔ Trap 2 Assy
➔ click edge of Flange ➔ click edge of Sil Chip ➔ click Yes button to accept realign

Sauna will indicate that “Sil Chip, Flange successfully joined”.  Join the flange to the heat sink:

Stack ➔ Ordinary ➔ Strict ➔ Flat/Grease ➔ Trap 2 Assy ➔ click edge of Heat Sink
➔ click edge of Flange ➔ click Yes button to accept realign

After joining, the model will appear as shown in Figure 7:

Tjunct

X

Y

Figure 7: Model after creating stack joins

You are ready to calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain Tjunct = 93.11°C.  This is lower than the temperature obtained for the TO-220
device.  This is to be expected, the stackup is significantly larger.
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Moving and copying the stackup

In the final section of the exercise, you will the move the original chip stackup to the left.  Then
you will create a copy on the right side of the sink.  The final geometry will be as shown in
Figure 8.  It will take about 5 minutes to complete the modification.  If your available time is
limited, feel free to skip the remainder of the exercise.  Otherwise, please continue on.

die attach
interface

silicon chip, q = 30W,
    10 x 10 x 0.5

copper flange,
25 x 25 x 0.5

Figure 8: Heat sink with two chip stackups

To begin, you will move the stackup to the left by 42 mm.  Moving is a three step process: (1)
delete the join to the heat sink, (2) move the stackup and (3) rejoin to the heat sink.

When deleting the flange-to-sink join, you need to be careful that you don't delete the chip-to-
flange join.  To assist with this, Sauna provides the "Group To Model" delete.  You will place the
chip and flange in the group and Sauna will then delete all joins between the group and the rest
of the model.  For the current relatively simple model, it isn’t essential to use a Group To Model
delete.  However, for more complex stackups, Group To Model deletes are very important.

Delete the flange-to-sink join with:

<F12 Root Menu> ➔ Delete ➔ Join ➔ Stack ➔ Grp To Model ➔ Plate ➔ Select 1
➔ click edge of flange ➔ Select 1 ➔ click edge of sil chip ➔ USE

Sauna will indicate that "1 join was deleted".

Move the stackup:

<F12 Root Menu> ➔ Move/Copy ➔ Move ➔ Assembly ➔ Plate ➔ Select 1 ➔ click edge of flange
➔ Select 1 ➔ click edge of sil chip ➔ USE ➔ Dx ➔ "−−−−42"
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Join to the sink:

<F12 Root Menu> ➔ Model ➔ Join ➔ Stack ➔ Ordinary ➔ Strict ➔ Flat/Grease ➔ Trap 2 Assy
➔ click edge of Heat Sink ➔ click edge of Flange ➔ click Yes button to accept realign

The nodes will be realigned and the stack join created.

Although you have not yet copied the stackup, calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain Tjunct = 96.24°C.  The temperature increases because the stackup is no longer
centered on the sink.

Copying the stackup

Now you will place a copy of the stackup on the upper-right of the heat sink (∆X = 87, ∆Y = 27).
Begin by making the copy:

<F12 Root Menu> ➔ Move/Copy ➔ Copy ➔ One ➔ Assembly ➔ Plate ➔ Select 1
➔ click edge of flange ➔ Select 1 ➔ click edge of sil chip ➔ USE

➔ Dx-Dy-Dz ➔ "87,27"

The copy will be created.  Normally, the next step is to join the 2nd stackup to the sink.
However, there is a problem.  Sauna can't align the heat sink to match both the left stackup and
right stackup.  Fortunately, there's a simple solution.  You need to slice the heat sink.  This will
create independent meshes on the left and on the right.

Slice the heat sink at X = 75 mm:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Line Slice ➔ X-Coord ➔ Enter Value
➔ "75" ➔ Select 1 ➔ click edge of heat sink ➔ USE

With the slice, there will be two independent meshes of nodes and resistors.  Now you can
create a stack join for the right stackup.  Make sure that you click on the right flange and the
far-right edge of the heat sink.  Make the join:

<F12 Root Menu> ➔ Model ➔ Join ➔ Stack ➔ Ordinary ➔ Strict ➔ Flat/Grease ➔ Trap 2 Assy
➔ click edge of right flange ➔ click far-right edge of sink ➔ click Yes button to accept realign

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain Tjunct-left = 121.87°C and Tjunct-right = 123.77°C.

This exercise is complete.  You should delete the model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

There are three other Sauna Quick Tours, as described on the next two pages.
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Sauna Quick Tour #2: Circuit Board Modeling

In the second Sauna Quick Tour, you will see how Sauna can be used for both quick models
and detailed studies of circuit boards:

S1

DPAK package power
device, Q=1W,
X=40, Y=31.5

80

80

24

traces are
0.5 mm wide

single layer
FR4 board,
1 oz. copper

X

Y

Z
  What-if #1:

Shorter Traces
  What-if #2:
25 x 25 Pad

  What-if #3:
Four Layer Board

10

25

25

two internal planes,
1 ounce copper

high via density under
device (100 vias/in2)

Simple DPAK device model DPAK device what-ifs

S2

S3

S1

S4

QFP device with
8 x 8 heat slug,
thermal vias

SOIC-16 device

SOIC-16 device

DPAK device,
thermal vias

X

Y

Z

Four layer board with multiple components

Sauna Quick Tour #3: Basic Finned Box, Box With Board

With Sauna you can do a quick analysis of a box, or you can model in great detail (including
internal convection and gray radiation analysis with automatic view factor calculation).  These
boxes are modeled:
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D2PAK package,
2 W, solder interface,
(120,11.6,-120), typ. Rjc
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Four layer board, 140 x 140,
FR4, 1 oz. plating,
top/bott layers: 10% copper,
internal layers: full plane

14 x 14 LQFP, 2 watts,
100 leads, no heat slug,
Rja = 32˚C/W on 4 lyr brd,
(40,11.6,-40)

5 watts distributed
over 60 mm x 80 mm

Basic finned box Box with internal board
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Sauna Quick Tour #4: Modeling LED Boards

You can model boards with both low power and high power LED's.  Sauna's library includes 40
standard LED packages, covering a wide range of automotive, industrial and consumer lighting
applications (user-defined packages are also allowed).  It's easy to experiment with different
pad sizes, add or remove internal copper planes, test different via densities and simulate boards
which are bonded to heat sinks.

thermal pad

ceramic body

die
wire bond

cathode
anode

die
wire bond

copper
leads epoxy body

PLCC package

ceramic package

S1 S2

S3

OSLON
Square LED

aluminum heat sink

epoxy
interface

Multilayer board with high
power LED, heat sink

Wrapping up and disclaimers

Thank you for working through Sauna Quick Tour #1.  We hope you will work through the other
Sauna Quick Tours.

Remember that the Sauna Quick Tours only provide an overview of Sauna's capabilities.
Important details have been omitted.  If you want to create accurate Sauna models, you must
work through the Introductory Exercises in the Sauna User Manuals.  Many of these exercises
are also available online to prospective users (www.thermalsoftware.com/eval_exercises.htm).
You can even work through the exercises with the Sauna Evaluation Package.

If you have questions, be sure to contact Technical Support (support@thermalsoftware.com,
734-761-1956).  Please note that transient and duty cycle analysis is only available with the
advanced version of the software: Sauna Modeling System.  �
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