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   Intermediate Exercise 1: Superassemblies And Basic Slicing

An important concept in Sauna is the superassembly.  Superassemblies let you subdivide a
plate or circuit board into a number of pieces and yet still work with the dimensions of the
overall plate during heat transfer calculations.  This is a valuable capability.  When a
superassembly is present, you avoid the flow length errors that you observed in Introductory
Exercise 8: Modeling Errors.

Undoubtedly you have noticed menu selections which refer to superassemblies.  For example,
to get a Temperature report, you entered <F7 Info> ➔ Temperature ➔ Current ➔ With Supers ➔
Screen.  "With Supers" stands for "With Superassemblies".  In this exercise you finally find out
what a superassembly is.

Superassemblies are usually created by slicing.  So you will learn how to perform basic line
slices in this exercise.  The most common reason for slicing is to make it possible to align a plate
or board to more than one heat source.  You will learn this technique in the exercise.

Prerequisites

You should have worked the first three introductory exercises.

Loading the heat sink model

For learning about superassemblies, you will be using the heat sink that you created in Intro-
ductory Exercise 1.  This model should be on your hard disk under the name "new_sink.smf".
(The model can also be found in “C:Program Files (x86)\Sauna Thermal Modeling\Reference
Models”.)  Load the model with:

<F12 Root Menu> ➔ File ➔ Open ➔ select new_sink.smf ➔ click Open button

Turn off fixed nodes and switch to a front, orthogonal view:

click   ➔ click  Front

You should see TS1-junct = 136.98°C, the steady state temperature for natural cooling.

Obtain a temperature report:

<F7 Info> ➔ Temperature ➔ Current ➔ With Supers ➔ Screen

Under the heading "-- Heat Source Temperatures --", the report should indicate that the S1 heat
source is part of the assembly "My Sink".

Clear the report before continuing.
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Using the slice command to create a superassembly

There are no commands in Sauna for explicitly creating a superassembly.  Instead, Sauna
creates the superassembly automatically  when the program detects that two similar assemblies
are edge-joined together.  So, if you want to cause a superassembly to be created, you need to
divide the heat sink into two pieces.

Use the slice command to subdivide the assembly:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Line Slice ➔ X-Coord
➔ Enter Value ➔ "38" ➔ All In Wind ➔ USE

Executing the slice command causes two things to happen.  First, the obvious step, Sauna cuts
the original assembly into two separate assemblies and joins the two assemblies together.
Second, and this is much less obvious, Sauna scans all assemblies in the model to determine
which assemblies are joined together.  If two assemblies are joined together and have the same
plane, thickness, material and fin characteristics, Sauna creates a superassembly which
represents the overall dimensions of the joined assemblies.  For your model, there are now 2
regular assemblies plus a superassembly.  If you look at the screen, you will see a thin dashed
line marking the internal edge of the two regular assemblies.

Recalculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain TS1-junct = 136.97°C, which is within 0.01°C of the previous temperature..
When temperatures are calculated, Sauna use the dimensions of the superassembly so you
avoid the flow length problems that you saw in Introductory Exercise 8: Modeling Errors (more on
this later.)

To allow you to easily see that a superassembly is present, Sauna changes the assembly line
thickness.  If a regular assembly is part of a superassembly, it is drawn with a thin dashed line.
Superassemblies are drawn with the standard thick lines.  When Sauna draws your model, the
left and right assemblies are drawn first.  A thin dashed line is used to draw these assemblies.
Then, the superassembly is drawn with thick lines.  It all happens pretty quickly, of course, so it
can be hard to see.

To better see how Sauna draws assemblies and superassemblies, switch to a perspective view:

click  

As an experiment, you will use the Move command to place the assemblies in the group:

<F12 Root Menu> ➔ Move/Copy ➔ Move ➔ Assembly ➔ Plate  ➔ Select 1

Now, use your mouse and click on the right assembly as shown in Figure 3-1 on the next page
(don't click on the outline of the fins).
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Figure 3-1: adding the right assembly to the group

With the right assembly in the group, you can see how the internal assembly is drawn with a
thin dashed line.  Normally, when the assembly is not in the group, the thin assembly lines are
covered up by the superassembly lines.

Note that, as shown in Figure 3-1, the fin outline is not drawn for each assembly.  Rather, the fin
outline is only drawn for the superassembly.  Thus, you can't click on the fin outline to place an
assembly in the group.  The fin outline belongs to the superassembly, not to either of the
constituent assemblies.

Try clicking on the fin outline:

Select 1 ➔ click on the fin outline

Sauna will beep at you and will display an error screen about trapping a regular assembly.

Since we don't want to move the model, clear the error screen and return to the Root menu:

<F12 Root Menu>

Now let’s see how Sauna draws superassemblies in shade mode.  Switch to shade mode now:

click  

As you can see, in shade mode Sauna draws only the superassembly.  You can’t see the internal
assemblies

You can obtain Info reports for either the superassembly or the constituent assemblies.  Begin
by getting an Info report for the left assembly:

<F7 Info> ➔ Trap ➔ Plate ➔ trap left assembly

At the top of the report, notice that the assembly label is "My Sink".  This is the original
assembly, reduced in width.  When you slice an assembly into two pieces, the original assembly
will be the piece which contains the origin point.
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After clearing the report window, get an Info report for the right assembly:

Plate ➔ trap right assembly

This is a brand new assembly.  The label for this assembly, "Plate 2", was generated automatic-
ally by Sauna.

Clear the report for the right plate, then obtain an Info report for the superassembly:

Plate Super ➔ trap a superassembly thick line

The Info report for the superassembly lists out the overall dimensions for the sink.  Notice that
the superassembly label is "SA-My Sink".  The prefix, "SA-", tells you that this is a superassem-
bly.  The rest of the label is the same as for your original assembly.  Thus a superassembly label
is generated with:

superassembly label = "SA-" + label of assembly which contains origin point

Now, let's try obtaining a temperature report.  Clear the superassembly report, then begin with:

<F7 Info> ➔ Temperature ➔ Current

You will reach this menu:

   CURRENT
>1 With Supers
 2 Detailed

When obtaining reports, you will frequently encounter menus similar to this.  If your model has
superassemblies, this menu lets you choose the amount of information listed out.  (If your
model doesn't have superassemblies, you can choose either option.)  Currently the super-
assembly contains 2 constituent assemblies.  However, some superassemblies contain many
constituent assemblies.  If information is listed out for every single assembly (the "Detailed"
option), the report becomes too long and is difficult to understand.  Thus, it is better to choose
"With Supers".  Characteristics are not listed for the constituent assemblies, only overall data for
the superassembly is shown.

Finish obtaining the report with:

With Supers ➔ Screen

In the Temperature report that you obtained before slicing, the heat source was shown as being
part of the "My Sink" assembly.  In the report you just generated, the heat source is now shown
as belonging to the "SA-My Sink" superassembly.  Average temperatures are also listed for the
entire superassembly.  The "With Supers" option is preferred because it gives only the data you
really need to verify your model.  Clear the report before continuing to the next section.

Breaking apart the superassembly

Just as there is no explicit command for creating a superassembly, there is also no explicit
command for deleting a superassembly.  You must modify the model to cause Sauna to clear
the superassembly.
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One obvious way to clear the superassembly would be to delete the join resistors between the
two assemblies.  Of course, with that approach there would be no heat flow between the two
assemblies.  A different approach will be used.  You will modify the thickness of the right plate.
If the two assemblies do not have uniform dimensions, the superassembly will be cleared.

Modify the right plate as follows:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Dimensions ➔ Plate Thick ➔ Enter Value
➔ "5.01" ➔ Centerline ➔ place right plate in group ➔ USE

If the instruction “place right plate in group” does not make sense, please refer to the top of page
2-56 in Introductory Exercise 4: Multi-Plate Boxes.

The superassembly will be cleared and the left and right assemblies will be drawn with thick
lines.  Notice that the fin outline is now drawn separately for each assembly.

You may be wondering what impact this will have on temperatures.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You will obtain TS1-junct = 132.41°C, a 4.6°C decrease.  Temperatures decrease because Sauna is
treating each assembly as if it were isolated.  While the flow length is still the same, Sauna will
assume that each sink has end fins which are open to the environment.  With a naturally cooled
sink, the end fins dissipate appreciably more heat than the internal fins.  So if Sauna treats both
assemblies as isolated, there will be two sets of end fins.  The predicted temperatures will be too
low.  For a heat sink which has closely spaced fins, the temperature discrepancy could easily be
greater than the 4.6°C shift just observed.

Switch into shade mode:

click  

In shade mode, you can clearly see the edge between the left and right assemblies.  Since you
can see the edge, you know that a superassembly is not present.  This becomes very clear in a
top, orthogonal view:

click  Top

In this view it is easy to see the irregular placement of the fins.  And even though the last fin on
the left plate is very close to the first fin on the right plate, Sauna will treat each plate as if it
were isolated.  (If your sink actually looks like this, contact Technical Support for efficient ways
to model these fin configurations.)
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Modifying the node spacing to simplify the model

Superassemblies make it easy to modify node spacing over a portion of the model.  To
illustrate, you will try using a very coarse node spacing for the right assembly.

Begin by returning to uniform plate thickness:

<F12 Root Menu> ➔ Edit ➔ Undo ➔ click Yes button to undo edit thickness

Once again, you should see TS1-junct = 136.97°C.  Next, change the node spacing on the right
assembly:

click  Front

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Both Axes
➔ Coarser 4x ➔ place right plate in group ➔ USE

The right plate will be remeshed.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You will obtain nearly the same temperature as before, TS1-junct = 136.96°C.  While it is
important to use a fine node spacing around heat sources, a coarse node spacing can be used
elsewhere.  You may wish to try making the node spacing on the right assembly even coarser.
It won't have much impact on the heat source temperature.

Note that superassemblies are not used for editing.  Suppose, for example, that you wished to
change the fin length for the entire sink.  When editing, you will have to place both assemblies
in the group.  There is no way for you to place a superassembly in the group.  Superassemblies
are created and cleared by Sauna, not by the user.

Superassemblies and click surface visibility

Let’s see how superassemblies are handled when using “click surface” visibility.  Enter the
following:

click  

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Click Surf
➔ click anywhere on heat sink

The entire heat sink will be turned off.  If a superassembly is present, “click surface” will turn
off the entire superassembly.

Turn on the heat sink assembly:

click  
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Reversing a slice

To remove a slice, use the Merge command:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Merge/Fill ➔ Merge ➔ Deflt Space ➔ Vertical XY
➔ All In Wind ➔ USE

This slice will be removed, so that there is only one assembly in the model.  However, after
merging, the nodes are no longer aligned to the heat source.  So you should realign to the heat
source:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ trap S1 source ➔ All In Wind ➔ USE

Now the model is back to the starting point.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

As before, you should obtain TS1-junct = 136.98°C.

Adding a rectangular heat source and distributed wattage

As mentioned at the beginning of the exercise, Sauna users frequently slice an assembly to
make it possible to align to multiple heat sources.  To see how this works, you will add a second
heat source.  The second source will be rectangular.  Add the source with:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "20" ➔ "S2" ➔ Special ➔ Typical
➔ Rectangle ➔ "15,10" ➔ hit <Enter> to skip ➔ Enter Rth ➔ "1" ➔ One

➔ trap plate ➔ Coords/Trap ➔ "125,30"

The heat source will be created, but it's not quite what you want.  Zoom in on the S2 source:

<F3 Zoom In> ➔ zoom in on S2 source (show about 25 nodes)

In the zoomed in view, you will see a triangular connection, not the rectangular connection that
you want.  The problem is the node spacing.  With the heat sink aligned to the S1 source, which
is a larger TO-247 package, there are not enough nodes for a rectangular connection with the
correct suface area.

Zoom out:

click  

The solution, of course, is to slice the heat sink and realign the right assembly to the S2 source.
But before you do that, you will add some distributed wattage to the heat sink.  Referring to
Figure 3-2, enter these commands:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Plate Nodes ➔ "5" ➔ Face Area
➔ Select Regn ➔ use grouping rectangle from Figure 3-2 on next page ➔ USE
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Figure 3-2: Grouping rectangle for distributed wattage

The distribute wattage will be added to the 9 nodes.  Now you are ready to slice.

Slicing at an arbitrary coordinate

Try slicing at “X = 40”:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Line Slice ➔ X-Coord
➔ Enter Value ➔ "40" ➔ All In Wind ➔ USE

The slice will not be allowed and an error screen will be displayed.  The error screen indicates
that the problem is "non-uniform distributed wattage".  Sauna will inform you that the slice will
be allowed if you slice at the midpoint between two nodes.  Clear the error screen before
continuing.

Here's a more detailed explanation.  The sink does have non-uniform distributed wattage, since
you added heat input to 9 of the assembly nodes.  When you slice at an arbitrary location,
Sauna will need to regenerate the node and resistor mesh.  As a result of the new mesh, nodes
will not be in exactly the same position as before.  Since Sauna cannot assign wattage in the
identical pattern, the slice is cancelled.  (Should you need to slice at exactly X = 40, then the
distributed wattage should be cleared before slicing.  After slicing, you would reapply the
wattage.)

But, as the error screen suggests, there is a way to proceed without making any modifications.
Provided that you have some flexibility for the slicing coordinate, you can slice at the midpoint
between nodes, as described in the next section.

Slicing at the midpoint between nodes

Referring to Figure 3-3, perform the midpoint slice:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Line Slice ➔ X-Coord ➔ Midpoint
➔ trap node #1 in Figure 3-3 on next page ➔ trap node #2 ➔ All In Wind ➔ USE
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Figure 3-3: Slicing at the midpoint between nodes

The operation will complete without error.  With a midpoint slice, Sauna does not
delete/recreate nodes, so non-uniform node wattage is not at issue.

Now you can align the right assembly to the S2 source:

<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Remesh/Align ➔ Align Mesh ➔ Heat Source
➔ 4 Node Conn ➔ trap S2 source ➔ place right assembly in group ➔ USE

After aligning, the S2 source will be connected with 6 resistors.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain TS1-junct = 156.40°C and TS2-junct = 131.00°C.

Other situations for midpoint slices

In the above example, non-uniform wattage prevented you from slicing at an arbitrary
coordinate.  Besides wattage, you will have the same problem with non-uniform copper
coverage and, in particular, non-uniform via density.

To avoid these problems, it is recommended that you routinely use midpoint slices.  (Unless, of
course, you need to slice at a specific coordinate.  These types of slices are discussed in the next
exercise.)

Wrapping up

This exercise is complete.  Delete the model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button


