Thermal
Solutions
Sauna™ V4.5 Release Notes
Welcome to Version V4.5 of the Sauna thermal modeling package.

Getting started with Sauna V4.5
Please begin by reading “Sauna V4.5 New Features List” on the next page.
When you are ready to begin using Sauna V4.5, work through "Using Raw Data Control Elements", which
starts on page 4. This is a brief exercise which takes around 20 minutes to complete.

User manual revisions
The changes to the Sauna V4.35 User Manual (the last printed manual) are relatively minor. If you are an
experienced user, you only need to work the exercise included with these release notes. There is an
updated version of Supplemental Exercise 1: Transient And Duty Cycle Analysis, which includes new
material explaining raw data control elements. However, this subject is quite adequately explained in the
release notes.
Of course, it's a bit different if you are learning Sauna for the first time. In this case it helps to have
exercises where you can enter all commands exactly as shown. So the Sauna installation includes the
latest version of these exercises (available through the Start Menu):
• Introductory Exercise 5: Basics Of Circuit Board Modeling
• Introductory Exercise 6: Multi-Plate Box With Internal Board
• Intermediate Exercise 3: More On Circuit Board Modeling.
• Intermediate Exercise 11: Surface Assemblies And Metal Core Boards.
• Supplemental Exercise 1: Transient And Duty Cycle Analysis
For everything else, the exercises in the Sauna V4.35 User Manual are current.

Installation
To install or update Sauna, see the “Installation” chapter in the Sauna User Manual. The method is the
same as for previous Sauna releases.

Sauna is a trademark of Thermal Solutions Inc.
Thermal Solutions Inc., 3135 S. State St., Suite 350C, Ann Arbor MI 48108 www.thermalsoftware.com 734-761-1956

Sauna V4.5 New Features List
Much larger models are possible
•

100,000 nodes for Sauna Modeling System (previously 15,000 node limit)

•

20,000 nodes for Sauna Standard (previously 7,500 nodes)
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Random power profile, model with “raw data” control elements

New raw data control elements (Sauna MS feature)
•

use for random power data from experimental measurements or simulations

•

scripting is not required, input is from a tab or comma delineated spreadsheet file

•

no fixed limit on the number of steps, more than 1,000,000 steps possible

•

raw data types: wattage vs. time, boundary temperature vs. time
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Control Element Plot
--------------------
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Simplify raw data control elements to obtain results quickly

New tools for simplifying raw data control elements (Sauna MS feature)
•

for large models with complex power curves, simplification tools are essential

•

simplify entire control element
- obtain preliminary results
- identify critical zones of power curve, important for random data where it’s not obvious
where maximum temperatures will be reached

•

simplify a range of control element
- many power curves have high power for just 5 or 10% of the total time
- simplify unimportant ranges while using fine resolution for areas of high power

•

obtain results in minutes, not hours

Product refinements
•

faster drawing of models

•

can interrupt drawing with “c” key (for cancel), useful when working with large models

•

easier to change layer visibility

•

when graphing time-based controls, can specify a time range or Y-value range (or both)

•

bug fixes

3

Using Raw Data Control Elements
The Sauna Modeling System version is required to work this exercise.
For a number of years, Sauna has provided the ability to define power and temperature duty
cycles. This has been handled with control elements which make use of a simple scripting
language. The scripting language makes it easy to create square waves, ramps and loops. This
classic Sauna method is described in Supplemental Exercise 1: Transient And Duty Cycle Modeling.
The scripting method has performed well over the years. However, it was awkward to work
with a large set of random data, such as the power curve shown in Figure 1:
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Figure 1: Random power curve

The power curve in Figure 1 has 1000 steps and could be converted into a script. But a number
of users indicated that they would prefer to work with raw data in a simple spreadsheet format,
without having to add a script header or commands. With Sauna V4.5 this is now possible.
But raw data input quickly introduces another issue: calculation time. The raw data is typically
generated from measurements or a simulation program. This tends to produce large numbers
of data points, 100K data points is not unusual. So while Sauna has been modified to accept this
number of points, the calculation times can be unwieldy. A product goal with Sauna has
always been to provide results quickly. But a medium sized model with 100K point duty cycle
may need hours to complete the calculation. So an important part of the raw data enhancement
was to provide simplification tools so that a preliminary result can be obtained in minutes, not
hours.
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A simple example: ramp.dty
The Reference Models folder contains the file "ramp.dty". This file contains this power-time
data (and nothing else):
0,0
1,.1
2,.2
3,.3
4,.4
5,.5
...
25,2.5
26,2.6
27,2.7
28,2.8
29,2.9
30,3.0

So ramp.dty is a simple series of data points which can be opened and edited with any
spreadsheet program.
Now you will create a control element which is based on this data. You do not need to open a
model for the first part of the exercise. Begin with:
<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ File Link

You will reach the File Link menu:
FILE LINK
>1 Full Script
2 Raw Data

"Full Script" is the old method. You will be using the new method, "Raw Data". Because you
are using this option, you will be required to supply some additional information such as
control type, time units, etc. With "Full Script" this information is contained in the external file,
but with "Raw Data" you define this information within Sauna.
Continue with:
Raw Data ➔ Q vs Time ➔ "ramp1" ➔ Seconds ➔ 1 ➔ Fixed Node ➔ Comma
➔ navigate to C:\Program Files (x86)\Sauna Thermal Modeling\Reference Models
➔ select "ramp.dty" ➔ click Open

Sauna will indicate that "Control element "ramp1" successfully created."
This is a control element, so there is nothing to see on the screen. Start by obtaining a basic text
report:
<F7 Info> ➔ Control Elem ➔ Text Report ➔ Enter Label ➔ "ramp1" ➔ Screen
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There is some useful information at the top of the report. Note that the report shows the total
time (30 seconds), the time average value (1.5), and the total number of steps (30). Notice that
simplification is currently off. At the bottom of the report you will see the time/value data for
the 30 steps. You should note that ", ramp" was added for each pair. This was not in the
original file but was added automatically by Sauna.
Clear the report from the screen, then obtain a graph:
Graph ➔ Time Base ➔ Stairsteps ➔ Seconds ➔ All ➔ Full Graph ➔ Screen

The graph is shown in Figure 2. You can clearly see a linearly increasing series of steps, varying
between 0.0 and 3.0 over 30 seconds. The time interval is uniform at 1 second, but uniform time
interval is not a requirement for raw data control elements. The time average value is 1.5,
which was shown in the text report.
Click the Done button to clear the graph before moving to the next section.
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Figure 2: Ramp duty cycle

Simplifying raw data control elements
Although the current control is rather simple, it is useful for learning about the different raw
data simplification options. To simplify, begin with:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw
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You will reach the Simplify menu:

>1
2
3
4
5
6
7
8

SIMPLIFY
Simplif Off
x 2
x 5
x 10
x 100
x 1000
Enter Factor
Max Possible

If you choose "x 2", each two steps will be combined together. For "x 5", five steps will be
combined, etc. The "Max Possible" option is probably intriguing. This option combines all of
the steps into a single square step at the time average value. This may seem odd at first, but it's
very useful for simplifying a portion of the raw data.
Use the "x 5" option, then graph the simplified control element:
x 5 ➔ Entire Ctrl ➔ All
<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Stairsteps ➔ Seconds
➔ All ➔ Full Graph ➔ Screen

Now the graph shows 6 steps, instead of 30 previously.
Clear the graph and try the "Max possible" option:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ Max Possible
➔ Entire Ctrl ➔ All
<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Stairsteps ➔ Seconds
➔ All ➔ Full Graph ➔ Screen

Now the graph shows a single step at the time average value of 1.5. This doesn't make a lot of
sense for this control element, but as you will see, it's useful in other situations. Clear the graph
before continuing.

Simplifying a portion of the control
It's quite common to have random data where there is high power for just 5 or 10% of the total
duty cycle (for example, see Figure 1). So it's extremely useful to be able to simplify the
unimportant ranges and use fine resolution only for the area of high power.
Simplify the first half of the control element as follows:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ x 5 ➔ Specify Time
➔ Seconds ➔ "0,15" ➔ All
<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Stairsteps ➔ Seconds
➔ All ➔ Full Graph ➔ Screen

The graph will be as shown in Figure 3 on the next page:
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Figure 3: Simplified ramp control element

With this change, you can see how some control elements can be simplified dramatically.

Working with more complicated raw data
Now you will move on to something significantly more complex. Begin by deleting the existing
control element:
<F12 Root Menu> ➔ Delete ➔ Control Elem ➔ Delete All ➔ click Yes button

Open new_sink.smf from the Reference Models folder:
<F12 Root Menu> ➔ File ➔ Open ➔ select new_sink.smf ➔ click Open button
click

"new_sink.smf" is the model created in the first introductory exercise.
When transient calculations are performed, Sauna will create the result file (.srf file) in the
current folder (working directory). At the moment the working directory is the Reference
Models folder and it is not recommended that you save any files in this folder. To switch the
working directory, you just need to save the Sauna model in another folder. (A good choice is
the folder that you usually use for saving Sauna models.) Save the model as “raw_sink” in a
different folder:
<F12 Root Menu> ➔ File ➔ Save As ➔ navigate to a folder of your choice
➔ type "raw_sink" in file name box ➔ click Save button
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Now create a raw data control element using random.dty from the Reference Models folder:
<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ File Link ➔ Raw Data
➔ Q vs Time ➔ "random1" ➔ Seconds ➔ 1 ➔ Fixed Node ➔ Comma
➔ navigate back to C:\Program Files (x86)\Sauna Thermal Modeling\Reference Models
➔ select "random.dty" ➔ click Open

Sauna will indicate that "raw_sink.smf" was successfully saved. While it is awkward to switch
between folders, this will not be a problem when you create your own raw data control
elements. Just place the raw data files in the same folder as your model.
Obtain a graph of the newly created control element:
<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Seconds
➔ All ➔ Full Graph ➔ Screen

The graph will be as shown in Figure 1 on page 4. Clear the graph, then obtain a text report:
Text Report ➔ Enter Label ➔ "*" ➔ Screen

The report will indicate that the total time is 100 seconds, the time average value is 0.46 and
there are a total of 1000 steps.
Fortunately this model is relatively simple, so it's possible to do a full calculation in a minute or
so. After clearing the report, assign the control element to the heat source:
<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔ Time Base ➔ Q vs Time ➔ "*"
➔ Heat Source ➔ All In Wind ➔ USE

Next, control elements provide a wattage ratio. At the moment, the wattage of the heat source
is 40W and the maximum wattage ratio of the control element is 24, providing a peak wattage of
960W. This is clearly too much. So reduce the wattage to 5 watts, which brings the peak
wattage down to 120 watts. Make the change:
<F12 Root Menu> ➔ Edit ➔ Heat Input ➔ Basic Source ➔ Wattage ➔ "5" ➔ All In Wind ➔ USE

Now perform the full duty cycle calculation:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default ➔ Natural ➔ "25"

When the calculation is complete, you will see TS1-junct = 26.55°C. But you need to obtain a
transient report:
<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Seconds ➔ Graph ➔ Screen

The graph will be as shown in Figure 4 on the next page. Note that the peak TS1-junct is 90°C and
this value is reached at about 57 seconds. If you are only interested in peak temperatures,
everything after this could be deleted. This could easily be done by opening random.dty in a
spreadsheet program, or even a text editor, and deleting all the cells from 58 seconds onward.
No changes are necessary within Sauna. You won't do this now, but it's easy to accomplish.
Clear the graph before continuing.
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Figure 4: Temperature vs. time for heat source

Simplifying the control element
Now you will experiment with simplification. It did not take long to perform the duty cycle
calculation with this model, but that will certainly not be the case for all duty cycles.
Try simplifying the entire duty cycle by a factor of 10:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ x 10 ➔ Entire Ctrl ➔ All

Graph the simplified control element:
<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Seconds
➔ All ➔ Full Graph ➔ Screen

The graph will be as shown in Figure 5 on the next page. With the graph on the screen, you will
see that the peak wattage ratio has dropped from 24 to 6.3. So you can't use the simplified
control element to accurately predict temperatures in this case. But it's still interesting to
calculate temperatures.
Clear the graph, then recalculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default ➔ Natural ➔ "25"

The calculation will be substantially quicker, because the number of steps has been reduced by
a factor of 10. As before, TS1-junct = 26.55°C.
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Figure 5: Simplified control element

Obtain a temperature graph:
<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Seconds ➔ Graph ➔ Screen

The graph shows the same general pattern as before. But the peak temperature has been
reduced from 90°C to 52°C. So was this calculation a waste of time? Not really. This graph
clearly shows that the peak occurs at around 56 seconds. For many sets of data, it is not obvious
where peak temperatures will occur.
It seems clear that the current control element can be simplified. But choosing the limits of the
simplification range must be done correctly. First, remove the existing simplification:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ Simplify Off ➔ All

Generate a more detailed graph for the time range of 40-60 seconds:
<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Seconds
➔ All ➔ Time Range ➔ "40,60" ➔ Screen

The graph will be displayed. The power level is very low prior to t = 50 sec. So it's safe to
simplify the control element over the range of 0-45 seconds.
Clear the graph, then simplify over 0-45 seconds with the same 10x simplification factor:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ x 10
➔ Specify Time ➔ Seconds ➔ "0,45" ➔ All
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Generate a graph:
<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Seconds
➔ All ➔ Full Graph ➔ Screen

The graph will be as shown in Figure 6.

Wattage ratio

Control Element Plot
--------------------

random1

30

20

10

0

-10
0.00

20.00

40.00

60.00

80.00

100.00

Time (seconds)

Figure 6: Simplified control, first 45 seconds only

Clear the graph and calculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default ➔ Natural ➔ "25"

Once again, TS1-junct = 26.55°C. But, as always, a graph is necessary:
<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Seconds ➔ Graph ➔ Screen

While temperatures in the first half of the curve are different due to the simplification, the same
maximum T S1-junct = 90°C is reached. The simplification was successful.
As one last experiment, use the "Max Possible" option over the same 0-45 range:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ Max Possible
➔ Specify Time ➔ Seconds ➔ "0,45" ➔ All
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Graph the control element:
<F7 Info> ➔ Control Elem ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Seconds
➔ All ➔ Full Graph ➔ Screen

The graph will show a single step over the range of 0-45 seconds, which is the maximum
possible simplification.
Clear the graph, then calculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default
➔ Natural ➔ "25"

When the calculation is complete, you should obtain TS1-junct = 26.57°C. But, as always, a graph
is necessary:
<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Seconds ➔ Graph ➔ Screen

The maximum temperature is now a bit higher, a few tenths more than before. So there is
certainly a point where the simplification starts to impact results. Still, "Max Possible"
simplification is a useful option when you want to quickly obtain preliminary results. (Note:
when you need to obtain an exact value from a graph, use one of the Graph/Limits options.)
This exercise is complete, you can delete the model:
<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button
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