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Sauna™ Quick Tour #3: Basic Finned Box, Box With Board

About Sauna Quick Tours

The Sauna Quick Tours let you preview the features provided by the Sauna thermal modeling
program.  You will create actual models, just like an experienced Sauna user.  The documen-
tation explains all modeling steps, so no background with Sauna is required.  However, as the
name implies, the Sauna Quick Tours are not detailed introductions to the software.  Many
important topics are skipped over or discussed briefly.  To become a skilled user, you need to
work the tutorial exercises found in the Sauna User Manuals.  Many of these exercise are also
available to prospective users on the thermalsoftware.com website.

Basic finned box

You will start by modeling the box shown in Figure 1.  It is assumed that there is no heat
dissipation inside the box, so you can focus on the outside walls.  Later in the exercise, you will
add a circuit board and model internal convection and radiation (see Figure 5 on page 7).
Before beginning the exercise, make sure that the error beep on your computer is turned on (not muted).
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TO-218 package, 15W,
greased interface,
Rjc = 0.6˚C/W (typ. value)

box is zinc alloy 903,
4 mm wall thickness,
white paint surface,
top cover not shown

natural cooling @25C
fins: 20 long, 10 centerline, 2 thick
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Figure 1: Finned box with power transistors (top cover removed)
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Create the box with these commands:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Box/Can ➔ Rect Box
➔ "150,50,150"(do not type the quotes) ➔ (0,0,0) ➔ Uniform

➔ "4" (do not type the quotes) ➔ Mainly Horz
➔ Other Metal ➔ Zn SAE 903 ➔ Paint/White ➔ Paint/White

Sauna will create a multi-plate box.  The box is composed of 6 plate assemblies and each plate
has a mesh of nodes and resistors.  Thick dashed lines show the boundary of each assembly.

It is useful to see the model in a perspective view.  For commonly used commands, there are
seven rows of menu buttons at the lower left of the Sauna window.  The right button in the top
row is for switching to a perspective view.  Switch the view with:

click  

You can also view the model in a shaded view:

click  

Return to wireframe mode by clicking the shade mode button a second time:

click  

Adding fins and heat sources

In a moment you will add heat sources and fins to the back wall.  It will be easier if only the
back wall is visible.  Sauna provides several visibility commands to temporarily turn off parts
of the model.  As a first step.  let's see how Sauna has assigned labels to the six assemblies
which make up the box.  Obtain an assembly list report:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

As shown in the report, Sauna has assigned logical labels (“Back”, “Bottom”, “Front”, etc.) to
the assemblies.  You can use these labels to turn off assemblies.

Click the Done button to clear the report, then isolate the back wall:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only ➔ Any Assy Grp
➔ Select 1 ➔ "back" (do not type the quotes) ➔ USE

Just the back wall will be visible.  Resize the window with:

click  

The window will appear as shown in Figure 2 on the next page.  As indicated in the figure,
Sauna uses different line patterns to draw the plate outline.  A short dash is used to indicate the
"component side" (front face) of the back wall.  A long dashed line shows the "secondary side"
(back face).
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Figure 2: Component and secondary side for back wall

Since the fins are on the back of the box, you will add fins to the secondary side:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Plt/Bar Prop ➔ New Fins
➔ "20,10,2" ➔ Secondary ➔ All In Wind ➔ USE

Additional dashed lines will be added to show the outline of the fins.  To clearly see each fin,
switch to shade mode:

click  

Return to wireframe mode:

click  

Place the first heat source:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "15" ➔ "Left" ➔ TO-218 ➔ Typical
➔ Standard ➔ Greased ➔ Plate/Board ➔ One ➔ click edge (dashed line) of plate

➔ Coords/Trap ➔ "25,25"

The first heat source will be created.  Add the second heat source with:

Basic Source ➔ "15" ➔ "Right" ➔ TO-218 ➔ Typical ➔ Standard ➔ Greased ➔ Plate/Board
➔ One ➔ click edge (dashed line) of plate ➔ Coords/Trap ➔ "125,25"

The second heat source will be created.  If you look at the screen, there are only two case-to-sink
resistors for each power transistor.  For best accuracy, you should have at least 3 case-to-sink
resistors.  Remesh the plate to obtain 4 case-to-sink resistors:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Remesh ➔ In Plane
➔ Both Axes ➔ Finer 2x ➔ All In Wind ➔ USE

After remeshing, there will be 4 case-to-sink resistors for each heat source.
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Adding float resistors and a fixed node

At this point, you have defined the box and heat input.  However, the current model is invalid.
No heat flow path has been established between the heat sink and the ambient temperature
environment.  A "fixed temperature" node is required to represent the room environment.  The
name "fixed temperature" comes from the fact that ambient nodes have temperatures which
remain fixed throughout the temperature calculation.  You also need "float" resistors to
represent the convection and radiation.  These are called “float resistors” because the resistance
values are adjusted according to the ∆T and convection conditions.

Begin by restoring visibility:

click   ➔ click  

When working with the back wall, you saw that the component side faced in and the secondary
side faced out.  As it turns out, Sauna uses the same rule for all of the assemblies in the box.  So
you can create ambients for all six plates at the same time:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd-›Fix ➔ "Room Amb"
➔ Natural ➔ Secondary ➔ All In Wind ➔ USE

In the prompt zone at the lower-left, Sauna will indicate that "6 fixed temp nodes and 544 float
resistors created".  To get a clearer view of the model, switch to a top view:

click  Top

The model will be as shown in Figure 3:

Left Right

Room Amb

Room Amb Room Amb Room Amb

Room Amb

fixed temperature nodes
(represent room ambient)

float resistors
(convection and radiation)

X

Z

Figure 3: Box model with float resistors and fixed nodes

Now that the heat flow path to ambient has been created, you can reduce screen clutter by
making the fixed nodes and float resistors invisible.  There's a button for this:

click  
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Switch to a perspective view and calculate temperatures:

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

The temperature calculation will only take a few seconds.  When complete, you will see two
temperatures for each heat source (the left and right heat sources should be identical).  The
upper temperature, 77.79°C, is the junction temperature.  The lower temperature, 68.79°C, is the
case temperature (Tjunct = Tcase + q ⋅⋅⋅⋅ Rjunct-to-case).

It's also interesting to view temperature contours:

click  

What-if #1: horizontal fin channels

In a product development environment, you're frequently interested in evaluating design
alternatives.  With Sauna, you can easily change wall thickness, material properties, fin
dimensions, cooling mode, etc.  You will now perform two “what-if” modifications.

When you added fins to the back of the box, Sauna placed the fins in the default orientation, so
the fin channels are vertical.  Although vertical fin channels are best, it's also interesting to
check the performance with horizontal fins.

Change the fin orientation with:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Plt/Bar Prop ➔ Fin Props ➔ Orientation ➔ XY + YZ
➔ Horizontal ➔ Secondary ➔ Select 1 ➔ "back" ➔ USE

Sauna will briefly flash the screen in shade mode to show the new fin orientation.  To see the
new fin configuration more clearly, switch to shade mode in a right view:

click   ➔ click  Right

Turn off shade mode and return to a perspective view:

click   ➔ click  

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

For both heat sources, you should obtain Tjunct = 82.24°C.  This is an increase of only 4.5°C.  In
this situation, horizontal fin channels would probably be acceptable.

It's easy to return to the previous fin configuration.  Just use the Undo command:

<F12 Root Menu> ➔ Edit ➔ Undo ➔ click Yes button

After using Undo, you should see Tjunct = 77.79°C.  This is the temperature from the previous
calculation.
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What-if #2: adding a shelf

Many boxes have internal walls and partitions.  As the second what-if, you will add a
horizontal shelf to the box shown in Figure 4.  Since these types of constructions are common,
Sauna has commands for adding a shelf to either a rectangular box or a round can.

Add the shelf:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Plt In Bx/Cn ➔ Rect In Box ➔ "Shelf" ➔ Horizontal
➔ Minimum ➔ Enter Value ➔ "10" ➔ “10” ➔ No Gap ➔ Other Metal ➔ Zn SAE 903

➔ Paint/White ➔ Join ➔ Zero Resis ➔ All In Wind ➔ USE

The shelf will be created.  To clearly see the shelf, turn off the front wall:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly
➔ Click Surf ➔ click anywhere on front wall

The model will be as shown in Figure 4:
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Figure 4: Box with shelf

Turn off shade mode and restore visibility:

click   ➔ click  

Calculate temperatures

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain Tjunct = 74.06°C for both heat sources.  This is a reduction of around 4°C.  The
extra metal in the shelf reduces temperature gradients around the heat sources.
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Adding circuit board with internal convection and radiation

Now you will add a board to the box, as shown in Figure 5:

D2PAK package,
2 W, solder interface,
(120,11.6,-120), typ. Rjc

10

Four layer board, 140 x 140,
FR4, 1 oz. plating,
top/bott layers: 10% copper,
internal layers: full plane

14 x 14 LQFP, 2 watts,
100 leads, no heat slug,
Rja = 32˚C/W on 4 lyr brd,
(40,11.6,-40)

existing box, front and
top covers not shown

5 watts distributed
over 60 mm x 80 mm

(80,11.6,-20)

Figure 5: Finned box with circuit board

Begin by deleting the shelf:

<F12 Root Menu> ➔ Delete ➔ Assembly ➔ Any Assy ➔ Select 1 ➔ click edge of shelf ➔ USE

You also need to delete the right heat source:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Heat Source ➔ Any Source
➔ Select 1 ➔ click right red heat source node ➔ USE

<F1 Window> ➔ Refresh

Planar vs. detailed stackup board models

Sauna provides two different methods for modeling circuit boards: planar and detailed stackup.
The planar method is a simplified approach, which has been in use for over a decade.  In this
type of model, there is no ∆T between the faces of the board.  For a multilayer board, you can
think of all the layers as being "smashed" together.  Also, with the planar approach, you do not
model individual traces and pads.  Instead, the copper coverage is modified.

As the name implies, the detailed stackup method is more precise.  With this method you will
create individual traces and pads.  You will also modify the via density, so you will be able to
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add the vias underneath the DPAK device.  If you have already worked through Sauna Quick
Tour #2: Circuit Board Modeling , you have used the detailed stackup method.

In this exercise you will use both the planar and detailed stackup methods, starting with the
planar approach.  Both methods are useful, as you will see.

Creating a planar board

You will be using the "Board In Box/Can" command to create the circuit board.  The circuit
board is 140 mm x 140 mm, which is smaller than the internal dimensions of the box (142 x 142).
So when you reach the Gap To Wall menu, you will specify a 1 mm gap between the wall and
the board.

Begin with:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Brd In Bx/Cn ➔ Rect In Box ➔ "Main Brd" ➔ Horizontal
➔ Minimum ➔  Enter Value ➔ "10" ➔ Enter Gap ➔ "1" ➔ .062"/1.6mm  ➔ FR4 ➔ Four ➔ One oz.

You will reach the Cu Coverage (copper coverage) menu:

 CU COVERAGE
>1 5%
 2 0%
 3 10%
 4 25%
 5 50%
 6 75%
 7 100%
 8 Enter

Since you are creating a planar board, you need to specify the average copper coverage over the
four layers of the board.  With two full internal planes and 10% coverage on the outer planes,
the average copper coverage is (2 ∗ 1.0) + (2 ∗ 0.1) / 4 = 55%.  Complete creation of the board
with:

 Enter ➔ “55” ➔ No Join ➔ All In Wind ➔ USE

The board will be created in the proper position inside the box.  Verify that the board has the
proper characteristics:

<F7 Info> ➔ Trap ➔ Board ➔ click edge of board

You should verify that the board dimensions are 140 mm x 140 mm.  In the "-- Copper Layer
Properties --" section on the first page, you should see 4 copper layers, 1 oz.  plating and 55%
copper coverage.  Clear the report before continuing.

Using abbreviated symbols

With the newly created board, there are significantly more nodes and resistors on the screen.  It
is becoming difficult to clearly see the outline of the assemblies.  To improve screen clarity,
switch to abbreviated symbols:

<F6 Setup> ➔ Display ➔ Symbols ➔ Abbreviated



9

If desired, you can permanently switch to abbreviated symbols by saving the current display
setup (<F6 Setup> ➔ Save Setup).

Adding the D2PAK device

Add the D2PAK heat source to the board:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "2" ➔ "S1" ➔ D2PAK ➔ Typical
➔ Solder 0.1mm ➔ Plate/Board ➔ One ➔ click edge of board ➔ Coords/Trap ➔ "120,11.6,-120"

The heat source will be added to the back-right section of the board.  Although difficult to see in
the current view, there are 4 case-to-sink resistors, which is the recommended number of
resistors for accurate results.

Adding distributed wattage, modeling quad flat pack

Figure 5 (page 7) shows a section of the board with 5 watts of distributed wattage.  On a real
board, this might correspond to a zone of components with modest dissipation and operating
well within the component limits.  The only challenge here is to properly select the board
nodes.

But there is also the issue of the quad flat pack.  Unfortunately, there is no precise way to model
this type of quad package with a basic heat source on a planar board.  So you will simply apply
distributed wattage over an enlarged footprint for the device.  When the analysis is complete,
you will make a rough estimate of Tjunct by using Rja and a local internal ambient temperature.
In the second half of the exercise, you will perform a more detailed (and accurate) analysis with
an enhanced source.

Isolate the circuit board, then switch to a top view:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only
➔ Board Group ➔ All In Wind ➔ USE

click  Top

Just the board will be visible.  As mentioned earlier, there are four case-to-sink resistors for S1.

Before adding the distributed wattage, you will create two reference rectangles.  The rectangles
are an aid for selecting the board nodes.  Rectangles are simply line elements that have no effect
on thermal characteristics.

Create a reference rectangle for the 60 mm x 80 mm area of dissipation:

<F12 Root Menu> ➔ Line/Point ➔ Line ➔ New Line ➔ Rectangle ➔ Coords/Trap ➔ "80,11.6,-20"
➔ Dx-Dy-Dz ➔ "60,0,-80"

The rectangle will be created.  Now you need to define the heat dissipation area for the QFP.
The body size is 14 x 14, but the leads will certainly assist in spreading the heat over a wider
area.  Since the first 10-15 mm of traces are most important, you will distribute the heat over a
36 x 36 area.  Add the rectangle with:

Rectangle ➔ Coords/Trap ➔ "22,11.6,-22" ➔ Dx-Dy-Dz ➔ "36,0,-36"

The rectangle for the QFP will be added.
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Now that the two reference rectangles have been created, you can easily select the correct
nodes.  You will be using "Select Region" for the first time.  With "Select Region" you digitize
twice to define a grouping rectangle.  With Sauna, digitize means “click and release” (which
you will do two times).  It’s not hold the mouse button down and drag.  Begin by adding
distributed wattage for the QFP (see Figure 6):

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Node Group ➔ Board Nodes ➔ "2"
➔ Face Area ➔ Select Regn ➔ use digitize point #1 in Figure 6 ➔ use digitize point #2 ➔ USE

S1

digitize  
point #1

digitze point #2

digitize point #3

digitize point #4
X

Z

Figure 6: Selecting nodes for distributed wattage

At the lower-left, Sauna will indicate that "distributed wattage applied to 64 nodes".  If you got
a different number of nodes, use Edit ➔ Undo and try again.

Now add the distributed wattage for the 60 x 80 rectangle:

Node Group ➔ Board Nodes ➔ "5" ➔ Face Area ➔ Select Regn ➔ use digitize point #3
➔ use digitize point #4 ➔ USE

This time you should see the message "distributed wattage applied to 192 nodes".  Verify the
model wattage:

<F7 Info> ➔ Heat Load ➔ Input ➔ With Supers ➔ Screen

Under the heading "-- Wattage Totals --", the report should indicate that Qtotal = 24W.  After
verifying the total heat load, clear the report.

The rectangles can now be deleted:

<F12 Root Menu> ➔ Delete ➔ Line/Point ➔ Line ➔ All In Wind ➔ USE

The rectangles will be deleted.  Of course, since the rectangles have no impact on thermal
characteristics, it is not actually necessary to delete these elements
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Before moving on, it should be noted that there is an even quicker way to model the board
dissipation.  Instead of defining two zones of dissipation, you could simply assign a total of 7
watts to the entire board.  For a quick model, this would be fine.

Creating convection and radiation networks

The gap between the board and bottom cover is 6 mm.  Many boxes have thin air gaps like this.
When the gap is less than 10 mm (0.4"), the air is largely stationary.  But a significant amount of
heat is transferred through direct conduction and radiation.  And, the thinner the gap, the better
the heat transfer.

Since thin air gaps are common, Sauna provides parallel gap resistors.  These are easy to use,
but you must be careful to select the correct assemblies.  As a first step, turn on all assemblies
and switch to a front view:

click  ➔ click  Front

Once again, you will use “Select Region” to define a grouping rectangle.  But this time you will
select assemblies, not nodes.  If the grouping rectangle intersects an assembly edge, the
assembly will be selected (added to the group).  With Select Region you can select many
assemblies simultaneously, without having to click repeatedly on assembly edges.  You will be
using the grouping rectangle shown in Figure 7.  The grouping rectangle does not need to be
identical to Figure 7, just reasonably close.

Now create the gap resistors:

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Float ➔  Gap ➔ Cond/Radtn ➔ Convectn OK
➔ Horizontal ➔ 100% Area ➔ Entire Assy ➔ Select Regn

➔ digitize upper-left corner of grouping rectangle (see Figure 7)
➔ digitize lower-right corner of rectangle ➔ USE

Left

S1

grouping rectangle
for gap resistors

X

Y

Figure 7: Grouping rectangle for gap resistors
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The gap resistors will be created.  Sauna will indictate that “1444 gap resistors created;
area = 1.96E+4”.

Now you will model convection and radiation above the board.  The board and top cover are
separated by roughly 35 mm.  Air will circulate in this region so you can't use gap resistors.
You need to create convection and radiation networks.  The convection network is comprised of
internal ambients and convection resistors.  The radiation network is based on a gray radiation
analysis, which involve view factors, surface type and ∆Τ.  Sauna calculates the radiation view
factors for you automatically.  In fact, Sauna calculates all the necessary convection and
radiation characteristics automatically.  As a user, you only need to define the networks.

When you create the convection and radiation networks, you will use "Select Region" with the
grouping rectangle shown in Figure 8.  Create the networks:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Horiz Para ➔ Cnv/Rd Ntwk ➔ 4 Ambients
➔ 100% Area ➔ 6 Surf Box ➔ Select Regn

➔ digitize upper-left corner of grouping rectangle (see Figure 8)
➔ digitize lower-right corner of rectangle ➔ USE

Left

S1

grouping rectangle for convection
    and radiation networks

bottom of grouping rectangle is below
   board and above bottom cover

X

Y

Figure 8: Grouping rectangle for convection and radiation networks

The convection and radiation networks will be created.  To better understand the new
networks, turn off assemblies in the XY plane:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ By Plane ➔ Any Assy ➔ XY/Z-Axis

The screen will be as shown in Figure 9 on the next page.  Below the board, the gap resistors
handle both convection and radiation.  Above the board there are separate convection and
radiation networks.
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S1

Frt/rightFrt/left

gray radiation network:
radiosity nodes and gray
radiation resistors

convection network:
internal ambients and light
blue convection resistors

gap resistors include both
convection and radiation,
dark blue color

X

Y

Figure 9: Convection and radiation inside box

Restore visibility and calculate temperatures:

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain TLeft-junct = 74.38°C and TS1-junct = 93.04°C.

Estimating the QFP junction temperature, activating contours

Switch to a perspective view

click  

In the perspective view, you can clearly see that TAmb-Frt/left = 54.39°C.  You can use the ambient
temperature and the Rja (32°C/W) to estimate a junction temperature. Thus, TQFP-junct = 54.39 +
2 * 32 = 118.39°C.  This should be considered a preliminary estimate, as discussed in the section
“Comparing planar results with stackup results”.

It's also interesting to see the contours.  Turn on contours:

click  

Turn off these assemblies:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Click Surf ➔ click anywhere on front wall
➔ Click Surf ➔ click anywhere on right wall ➔ Click Surf ➔ click anywhere on top cover

The screen will be as shown in Figure 10 on the next page.  This completes the analysis with a
planar board.  In the remaining sections you will model the board with a detailed stackup.
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Left

S1

X

Y

Z

Temp ˚C

90.40

85.84

81.27

76.70

72.13

67.57

63.00

58.43

53.86

49.30

44.73

Steady State

Figure 10: Temperature contours for the planar board model

Preparing to create the detailed stackup

If you worked through Sauna Quick Tour #2: Circuit Board Modeling, you are already familiar with the
creation of detailed stackups.  So it is not essential that you work through the remainder of this Quick
Tour.

While it is possible to convert a planar board into a stackup, it’s generally simpler to delete the
planar board and start over.

Restore assembly visibility, then delete the planar board:

click   ➔ click  Front

<F12 Root Menu> ➔ Delete ➔ Assembly ➔ Board ➔ All In Wind ➔ USE

Delete the gray radiation network and internal ambients:

<F12 Root Menu> ➔ Delete ➔ Special Del ➔ Gray Netwk ➔ All Netwks

<F12 Root Menu> ➔ Delete ➔ Node ➔ Internal Amb ➔ All In Wind ➔ USE

Now you are ready to create the board stackup.

Using in “board in box/can” to create the first laminate layer

Create the initial laminate layer:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Brd In Bx/Cn ➔ Rect In Box ➔ hit <Enter> to skip
➔ Horizontal ➔ Minimum ➔  Enter Value ➔ "10" ➔ Enter Gap ➔ "1" ➔ .062"/1.6mm  ➔ FR4

➔ Zer/Lam Only ➔ .025"/0.64mm ➔ One oz. ➔ None ➔ No Join ➔ All In Wind ➔ USE

The board will be created.  Since you did not directly specify a label, the board label will be
"Lamin>1".  (This is the recommended approach, do not use an arbitrary label in this situation.)
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Isolate the board and switch to a top view:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Brd Stackups

click  Top

Adding traces and pads

Add the trace pattern for the D2PAK:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ click edge of board
➔ Component ➔ One oz.  ➔ Library ➔ DPAK's ➔ D2PAK ➔ 2 ➔ Same As Body

➔ Pad Only ➔ 0 Degrees ➔ Coords/Trap ➔ "120,0,-120"

The D2PAK pads will be added.  Note that you used placement coordinates of "120,0,-120", so
the Y-coordinate is 0, which is not actually on the board.  In fact, the Y-coordinate is ignored
because Sauna will always snap the trace pattern onto the proper side of the board.  Now add
pads for the QFP, using a 15 mm flare pattern:

<F2 Backup> ➔ Quad ➔ LQFP ➔ 14 x 14 ➔ 100 Leads ➔ Detail/Flare ➔ 15 mm/0.6" ➔ No
➔ Coords/Trap ➔ "40,0,-40"

The trace pattern will be added to the board.

There is one more pad to create.  With the planar board, you assigned wattage directly to the
board nodes.  But with a board stackup, it makes more sense to assign the wattage to a pad.
Create a 60 x 80 pad:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad ➔ click a trace or pad
➔ Pads ➔ Rectangle ➔ Coords/Trap ➔ "80,0,-20" ➔ Dx-Dy-Dz ➔ "60,0,-80"

Since the 60 x 80 pad represents an area of components and traces, you will reduce the copper
coverage, to better match the effective thermal conductivity of this zone.  Modify the copper
coverage to 25%:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Plt/Bar Prop ➔ Trace/Pad ➔ Coverage ➔ Both Direc
➔ 25% ➔ Entire Assy ➔ Select 1 ➔ click edge of 60 x 80 pad ➔ USE

Sauna will inform you that "copper coverage modified for 1 trace/pad".

Adding heat sources

Begin by adding the D2PAK device:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ DPAK's ➔ "2" ➔ "S1"
➔ D2PAK ➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point ➔ click D2PAK ref point

The D2PAK heat source will be added.  Next, begin creating the QFP source:

Quad ➔ “2” ➔ “S2” ➔ LQFP ➔ 14 x 14 ➔ 100 Leads ➔ Middle ➔ Typical/36% ➔ Typ (0.1 mm)

You will reach the R_lead_pad menu:
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  R_LEAD_PAD
>1 Typ-1500 C/W
 2 Enter Resis
 3 R_para
 4 No Lead Conn

Up until now, you have always used "Typ-1500 C/W".  But as stated in the board exercise,
Rjunct-to-lead-pad is an important parameter, particularly for components without heat slugs.  The
recommended way to obtain Rjunct-to-lead-pad is to "reverse engineer" the  Rjunct-to-amb, taking into
account the vendor's test board.  This method, which provides an excellent match with
published data, is explained in Intermediate Exercise 3: More On Circuit Board Modeling (available
on the Sauna evaluation webpage).  In the intermediate exercise, an analysis is performed for
a 14 x 14, 100 lead QFP with an Rja of 32°C/W, the same as shown in Figure 5.  A value of
Rjunct-to-lead-pad = 2000°C/W is obtained.  You will use this value.  Continue with:

Enter Resis ➔ "2000" ➔ Ref Point ➔ click QFP ref point

The QFP device will be added.  Switch to shade mode:

click  

In shade mode, you can clearly see the enhanced sources which, unlike basic sources, includes a
3D body assembly.

S1

S2

X

Z

Figure 11: Enhanced sources on board

Finally, you need to add the distributed wattage:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Any Assy ➔ "5"
➔ Select 1 ➔ click edge of 60 x 80 pad ➔ USE

Distributed wattage will be applied.
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You should verify that the total wattage is correct:

<F7 Info> ➔ Heat Load ➔ Input ➔ With Supers ➔ Screen

With all the traces, the report will extend over several pages.  But at the end, you should see 24
watts of total dissipation.  Clear the report before continuing.

Since the D2PAK is a heat slug component, you should align the board stackup to this source:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source
➔ 4 Node Conn ➔ click S1 heat source ➔ All In Wind ➔ USE

Sauna will inform you that "aligned nodes for 205 assemblies".  However, everything will look
the same.  That's because the D2PAK placement point already matched the mesh.  So, in this
case, the alignment was not actually necessary.

Adding layers to the stackup

You are ready to create the internal board layers:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Subdivide ➔ Stackup ➔ Board ➔ Intern Layer
➔ Two ➔ Uniform ➔ One oz. ➔ Typical ➔ All In Wind ➔ USE

The internal layers will be created.  You should obtain a board stackup report:

<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

The  board stackup report shows 3 copper layers and 3 laminate (dielectric) layers.  You used
the "typical" option, so the laminate thicknesses are 0.396 mm, 0.711 mm and 0.396 mm.  Notice
that copper coverage for the Copp>1 layer is less than 100%, because of the 25% copper
coverage on the large pad.  The Copp>1 layer has copper area = 5,385.22 mm2, less than full-
plane.  On the other hand, the internal layers, Copp>2 and Copp>3, have 100% copper coverage
and are full-plane (area = 19,600 mm2).  Clear the report before continuing.

Modifying via density

All that remains is to add vias under the D2PAK device.  The vias will extend from the D2PAK
pad on the surface to the first internal copper plane.  So you need to modify the first laminate
layer, "Lamin>1", and not the other laminate layers.  The first step is to isolate "Lamin>1":

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Lamin>1

With this visibility change, you will see only the top laminate assembly and the heat sources.
All other laminate layers are turned off, as are all traces and pads.  The heat sources are visible
because Sauna links heat sources to board assemblies, not traces and pads.

While the correct layer is visible, you still need to take care to modify only the nodes
underneath the "S1" D2PAK.  Start by activating the display of via density.

<F6 Setup> ➔ Display ➔ Node ➔ Via Density ➔ Vias/In2

You will see "0i", for 0 vias per inch2, displayed across the board.  Currently, this layer has zero
vias.  To identify the exact nodes to be modified, turn on diepad outlines:

<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Enhan Diepad
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Now you will see red outlines for both the S1 and S2 sources (the outline of the S2 source is
rather difficult to see without zooming in).  Now you can change the via density:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Board Props ➔ Vias ➔ Density ➔ High (100)
➔ Node Group ➔ Select Regn ➔ click back-left corner of D2PAK red outline

➔ click front-right corner of D2PAK red outline ➔ USE

Sauna should indicate that 4 nodes were modified.  For these 4 nodes, “100i”is now displayed.

Restore the default display setup, turn on model elements and switch to a front view:

<F6 Setup> ➔ Display ➔ Use Default

Symbols ➔ Abbreviated

click   ➔ click  Front

One last time, obtain the board stackup report:

<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

The report should show that the Lamin>1 layer has vias, while the other layers do not.  You
should clear the report before continuing.

Completing the model and calculating temperatures

You will follow the same procedure as before for adding ambients and float resistors, beginning
with the gap resistors:

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Float ➔ Gap ➔ Cond/Radtn ➔ Convectn OK
➔ Horizontal ➔ 100% Area ➔ Entire Assy ➔ Select Regn

➔ use grouping rectangle from Figure 12 ➔ USE

Left

S1S2

recommended grouping rectangle

X

Y

Figure 12: Recommended grouping rectangle for gap resistors
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The gap resistors will be created and Sauna will inform you that “1444 gap resistors created;
area = 1.96E+4”.  Now create convection and radiation networks above the board:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Horiz Para ➔ Cnv/Rd Ntwk ➔ 4 Ambients
➔ 100% Area ➔ 6 Surf Box ➔ Select Regn ➔ grouping rectangle from Fig. 8 (page 12) ➔ USE

Convection and radiation networks will be created.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

The calculation will take longer, due to the larger model size with additional layers.  When
complete, you should obtain TLeft-junct = 74.38°C, TS1-junct = 100.63°C and TS2-junct = 114.03°C.

Comparing planar results with stackup results

So now you have modeled the box two different ways.  With the planar board approach, it only
took a few minutes to define both the board and complete convection and radiation networks.
The detailed stackup method took somewhat longer, but the task was still completed in
minutes, not hours.  But how does the accuracy of the two methods compare?

Table 1 compares the junction temperatures for the detailed stackup and planar models.  Some
interesting conclusions can be drawn.  First, for a wall mounted device, such as the TO-218
device, the details of board modeling are not important.  There will be little, if any, impact.

Heat Source Stackup Planar ∆∆∆∆T Percentage
Tjunct Tjunct Change

Left (wall 74.38 74.38 0.00 0.0%
mounted TO-218)

S1 (D2PAK) 100.63 93.04 -7.59 -10.0%

S2 (QFP) 114.03 118.39 +4.36 +4.9%

Table 1: Detailed stackup and planar results

Second, for a device with a large heat slug and few leads, like the D2PAK, the planar
assumption is optimistic because, effectively, the planar model provides infinite vias to all
layers.  Although the planar model is optimistic, temperatures were still within 10% for the
D2PAK device.  So, for the "DPAK class" of component, the planar model is adequate.

However, it's not so easy to make a conclusion about the non-heat slug QFP, or any component
that relies heavily on cooling through the leads.  For the problem just analyzed, the
temperatures are fairly close.  But you shouldn't count on this.  For these types of components,
the planar model provides a "first pass" temperature, with an error band of ±20% or so.

Finally, there's this question: what about modeling components with small heat slugs on a
planar board?  For example, you might be modeling a 10 x 10, 64 lead QFP with a 6 x 6 heat
slug.  In this case, experience has shown that you can model with a basic source which is
slightly larger (approx.  20%) than the actual heat slug.

Of course, in all cases, the most accurate results come from the detailed stackup method.  And
the graphics will look much better in your Powerpoint presentations!
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Other types of box models

The current box model is really quite simple.  You can do much more with Sauna.  You can
have multiple boards, including partial boards.  Also, "box in box" models can be handled
without great difficulty.  Figure 13 shows a more complex box model, as well as a round can
model.  The procedure for modeling round cans is quite similar to the method used for
rectangular boxes.

S1

S2

internal box

daughter boards of
  varying lengths

main board

Air Flow
ABS can, diameter = 150,
height = 50, wall thickness = 2

DPAK package, 5 W,
X=-25, Z=-25,
default Rjc, Rcs DPAK package, 3 W,

X=25, Z=0,
default Rjc, Rcs

Figure 13: Complex rectangular box, round can enclosure

Wrapping up and disclaimers

This exercise is complete.  You should delete the current model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

Remember that the Sauna Quick Tours only provide an overview of Sauna's capabilities.
Important details have been omitted.  If you want to create accurate Sauna models, you must
work through the Introductory Exercises in the Sauna User Manuals.   Many of the exercises are
available online (www.thermalsoftware.com/eval_exercises.htm).  You can even work through the
exercises with the Sauna Evaluation Package.

If you have questions, be sure to contact Technical Support (support@thermalsoftware.com,
734-761-1956).

There are five other Sauna Quick Tours, as described on the following pages.



21

Sauna Quick Tour #1: Heat Sinks, Duty Cycles And Stackup Models

In the first Sauna Quick Tour, you will model these configurations:

100

5

75

45

TO-220 package, 30W,
Rjc = 1.3˚C/W, greased interface

fins: 25 long, 10 centerline, 2 thick

150

Temperature vs. Time Plot
-------------------------

0.00 5.00 10.00
20
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40

50
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80

90

100

110

120

130

Time (minutes)

Temp (˚C) S1 (junct)

S1 (case)

Heat sink with standard device Duty cycle transient

die attach
interface

silicon chip, q = 30W,
    10 x 10 x 0.5

copper flange,
25 x 25 x 0.5

Heat sink with custom stackups

Sauna Quick Tour #2: Circuit Board Modeling

In the second Sauna Quick Tour, you will see how Sauna can be used for both quick models
and detailed studies of circuit boards:

S1

DPAK package power
device, Q=1W,
X=40, Y=31.5

80

80

24

traces are
0.5 mm wide

single layer
FR4 board,
1 oz. copper

X

Y

Z
  What-if #1:

Shorter Traces
  What-if #2:
25 x 25 Pad

  What-if #3:
Four Layer Board

10

25

25

two internal planes,
1 ounce copper

high via density under
device (100 vias/in2)

Simple DPAK device model DPAK device what-ifs

S2

S3

S1

S4

QFP device with
8 x 8 heat slug,
thermal vias

SOIC-16 device

SOIC-16 device

DPAK device,
thermal vias

X

Y

Z

Four layer board with multiple components
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Sauna Quick Tour #4: Modeling LED Boards

You can model boards with both low power and high power LED's.  Sauna's library includes 40
standard LED packages, covering a wide range of automotive, industrial and consumer lighting
applications (user-defined packages are also allowed).  It's easy to experiment with different
pad sizes, add or remove internal copper planes, test different via densities and simulate boards
which are bonded to heat sinks.

thermal pad

ceramic body

die
wire bond

cathode
anode

die
wire bond

copper
leads epoxy body

PLCC package

ceramic package

S1 S2

S3

OSLON
Square LED

aluminum heat sink

epoxy
interface

Multilayer board with high
power LED, heat sink

Sauna Quick Tour #5: Tubes and Cold Plates

Sauna is not just for air cooling.  You can also easily handle liquid cooling with water,
antifreeze mixtures, and more.  In the fifth Sauna Quick Tour, you will start with a simple tube
model.  Then you will model a full cold plate, including heat sources.

200

24

24

6061 aluminum

16 diam

100W heat load
 at top center

 

water cooling,
1 gallon/minute

Outer Diam = 16 mm
Inner Diam = 14 mm
Center = (12,12)

100

50

50

50

25 x 25 power module,
Q = 100 W, Rjc = 0.1˚C/W,
Rcs = 0.05˚C/W

water out

aluminum,
6061 T0

Tubes and cold plates with llquid cooling
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Sauna Quick Tour #6: Exporting models to SPICE for electrical-thermal
co-simulation

In this exercise you will export a Sauna model to the LTspice circuit simulation program.  The
LTspice program is an industry standard and is available as a free download.  You will start
with simple configurations and finish with the circuit below.  When an LTspice circuit includes
a Sauna model, there are surprising insights about circuit performance.  Thermal changes
everything.

Co-simulation with Infineon CoolSiC MOSFET

Wrapping up and disclaimers

Thank you for working through Sauna Quick Tour #3.  We hope you will work through the other
Sauna Quick Tours.

Remember that the Sauna Quick Tours only provide an overview of Sauna's capabilities.
Important details have been omitted.  If you want to create accurate Sauna models, you must
work through the Introductory Exercises in the Sauna User Manuals.  Many of these exercises
are also available online to prospective users (www.thermalsoftware.com/eval_exercises.htm).
You can even work through the exercises with the Sauna Evaluation Package.

If you have questions, be sure to contact Technical Support (support@thermalsoftware.com,
734-761-1956).  Please note that transient and duty cycle analysis is only available with the
advanced version of the software: Sauna Modeling System.  �
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